7 Replies Latest reply on Sep 28, 2010 10:40 AM by xbrotherx

    Can't import WSDL

    craig.d Level 1
      I'm having problems importing a web service WSDL into my Flex app. Everything goes fine until I hit the final Finish button on the wizard, then I get an error dialog that just says "An error occurred. The wizard cannot complete successfully." I have tried another WSDL and it worked OK.

      Does anyone know 1) what might be going wrong and 2) if there's any way to get any detail on what the problem really is?
        • 1. Re: Can't import WSDL
          AlHolden Level 1
          Have you tried placing the URL to the WSDL file into your web browser? See if it renders like a nicely formatted XML page, or just throws an error.

          Also, there are Web Service testing tools out there (I think strikeiron.com has one), which will let you connect and call a web service in a more interactive manner. These will provide a more interactive experience.

          I just use ColdFusion to build my own method testing pages, so I can call one with the same parameters as my Flex app and see what's REALLY up.
          • 2. Re: Can't import WSDL
            craig.d Level 1
            Yep, can see the xml fine
            • 3. Re: Can't import WSDL
              craig.d Level 1
              Also, the web service is known to work. I'm just trying to import it to generate the code I need for the app I'm working on.
              • 4. Re: Can't import WSDL
                craig.d Level 1
                Incidentally, there was a bug report about this that is exactly the problem I'm having, but it's marked closed.

                http://bugs.adobe.com/jira/browse/FB-15991
                • 5. Re: Can't import WSDL
                  AlHolden Level 1
                  Assuming your Flex Builder is running build 219054 or better*; then I guess you could try the wsdl they used for the bug, update the bug with your own wsdl, or both.
                  * FlexBuilder 3 comes bundled with the auto update installer, but by default does not have the updater installed. So there can be a newer build out there.
                  • 6. Can't import WSDL
                    craig.d Level 1
                    Apparently I'm running build 214193, but the "Search for Flex Builder Updates..." option in the help menu doesn't seem to do anything.

                    Edit: After installing the Adobe Updater, I now get a dialog when checking for updates, but it then claims there are no newer versions available.
                    • 7. Re: Can't import WSDL
                      xbrotherx Level 1

                      Craig.d, did you ever get this resolved? For some reason I can import my needed wsdl in Flex Builder 3 on OSX 10.5.* but in Flex Builder 3 on OSX 10.6.* I get the error you were getting. And my Flex Builder build is the same on both laptops (3.0.214193)

                       

                      That Gumbo build referenced in the Adobe jira issue is Flash Builder 4 I believe and my wsdl doesn't import at all with that one. Sheesh.