10 Replies Latest reply: Jul 8, 2009 4:27 AM by korosif RSS

    Unable to install plug-in

    ericbelair Community Member
      I get the following error when I attempt to add teh Cairngorm Plug-in to Flex Builder 3:

      Cairngorm Plugin (0.0.6.200811131413) requires plug-in "org.eclipse.emf.codegen".

      Can anyone help?

      Thanks.
        • 1. Re: Unable to install plug-in
          Community Member
          I´m having the same problem here!

          Can anyone help us?
          • 2. Re: Unable to install plug-in
            You have to take another features under Europa Discovery Site

            Java Development (the first one)
            Models and Model development (the fourth top)

            Let me know if you still have the problem.
            • 3. Re: Unable to install plug-in
              I tried installing Cairngorm Plugin in Flex Builder 3 (3.0.2.214193)

              and I received the following error.

              Current configuration contains errors that are not corrected by the requested operation and more errors would be introduced. See details for more information.
              ----- Current configuration problems -----
              Eclipse RCP Patch 2 for 3.3.1 (3.3.1.v20071204_331) requires feature "org.eclipse.rcp (3.3.1.R33x_r20070802-8y8eE8sEV3Fz0z0GlHJrXvTAUS)".
              Eclipse RCP Patch 3 for 3.3.1 (3.3.1.v20080102_331) requires feature "org.eclipse.rcp (3.3.1.R33x_r20070802-8y8eE8sEV3Fz0z0GlHJrXvTAUS)".
              ----- Configuration problems after the operation -----
              Eclipse RCP Patch 2 for 3.3.1 (3.3.1.v20071204_331) requires feature "org.eclipse.rcp (3.3.1.R33x_r20070802-8y8eE8sEV3Fz0z0GlHJrXvTAUS)".
              Eclipse RCP Patch 3 for 3.3.1 (3.3.1.v20080102_331) requires feature "org.eclipse.rcp (3.3.1.R33x_r20070802-8y8eE8sEV3Fz0z0GlHJrXvTAUS)".
              Cairngorm Plugin (0.0.6.200811131413) requires plug-in "org.eclipse.emf.codegen".

              As mentioned by Franck, I tried installing the Java Development and Models and Model Development. And got the following error.

              Current configuration contains errors that are not corrected by the requested operation and more errors would be introduced. See details for more information.
              ----- Current configuration problems -----
              Eclipse RCP Patch 2 for 3.3.1 (3.3.1.v20071204_331) requires feature "org.eclipse.rcp (3.3.1.R33x_r20070802-8y8eE8sEV3Fz0z0GlHJrXvTAUS)".
              Eclipse RCP Patch 3 for 3.3.1 (3.3.1.v20080102_331) requires feature "org.eclipse.rcp (3.3.1.R33x_r20070802-8y8eE8sEV3Fz0z0GlHJrXvTAUS)".
              ----- Configuration problems after the operation -----
              Eclipse RCP Patch 2 for 3.3.1 (3.3.1.v20071204_331) requires feature "org.eclipse.rcp (3.3.1.R33x_r20070802-8y8eE8sEV3Fz0z0GlHJrXvTAUS)".
              Eclipse RCP Patch 3 for 3.3.1 (3.3.1.v20080102_331) requires feature "org.eclipse.rcp (3.3.1.R33x_r20070802-8y8eE8sEV3Fz0z0GlHJrXvTAUS)".
              JST Common Core (2.0.0.v200706041905-1007w311817231426) requires plug-in "org.eclipse.wst.common.project.facet.core (1.1.1)", or compatible.
              JST Server UI (2.0.2.v200802150100-77-CT9yJXEkuiKVeQrclqTHQ3648) requires plug-in "org.eclipse.wst.server.core (1.0.103)", or equivalent.
              JST Server Core (2.0.2.v200802150100-56CQ9rC7EK_UAblGAD2537) requires plug-in "org.eclipse.wst.server.core (1.0.103)", or equivalent.
              JST Server Adapters (2.0.2.v200802150100-787KE8iDUUEF6GwKwpHEQ) requires plug-in "org.eclipse.wst.server.core (1.0.204)", or equivalent.
              JST Web UI (2.0.2.v200802150100-7B1DzCkuNa_RPevwkwB1iJ6z-0RH) requires plug-in "org.eclipse.jem.util (2.0.0)", or compatible.
              JST Web Core (2.0.300.v200802200333-7Q7AE7JEHhHeh0hI5y-QGB) requires plug-in "org.eclipse.jem.util (2.0.0)", or compatible.
              JST Enterprise UI (2.0.2.v200802150100-7b7_Es8EU6AXOV9QLJSees1SQoYQ) requires plug-in "org.eclipse.wst.command.env (1.0.101)", or equivalent.
              JST Enterprise Core (2.0.2.v200802150100-42Au_kE77c7EAgE7I7) requires plug-in "org.eclipse.wst.common.frameworks (1.1.0)", or equivalent.
              WTP Web Page Editor (1.0.1.v200709110605-3-29oA55P5V8A) requires plug-in "org.eclipse.gef (3.2.0)", or compatible.
              Java Persistence API Tools (1.0.2.v200802140100-77-7_CYQCD2CaLYCHCD) requires feature "org.eclipse.datatools.connectivity.feature".
              Graphical Modeling Framework (Europa Edition) (2.0.2.v20071124-0000-7X77_IEIn-hz0g9qNu8HVXr5ZXfv) requires plug-in "org.eclipse.draw2d (3.2.0)", or compatible.
              Graphical Modeling Framework Runtime (1.0.101.v20080114-2222-7d-EVOEYjiMWaZ4YWeu3dCypkm71) requires feature "org.eclipse.gef (3.2.0)", or compatible.
              UML2 Tools (Incubation) (0.7.101.v200802260712) requires feature "org.eclipse.gef (3.3.0)", or compatible.
              UML2 Diagramming (Incubation) (0.7.101.v200802260712) requires feature "org.eclipse.gef (3.3.0)", or compatible.

              Cairngorm installation on eclipse worked well without any problems.
              It is the Flex Builder 3 giving issues. Any clue how I can fi
              • 4. Re: Unable to install plug-in
                Community Member
                I am a Flash developer making my way through learning Flex, and now Cairngorm. In regards to Franck's comment how "You have to take another features under Europa Discovery Site," two things:

                First, this would ideally be mentioned on the Cairngorm plug-in page ( http://opensource.adobe.com/wiki/display/cairngorm/Plugin ) as part of the installation process.

                Second, I am new to Eclipse and Flex Builder and all of this; a little more detail would be greatly appreciated. For example, the installation section on the plug-in page has a nice set of steps to follow on how to go about installing it. Simply saying "there's this thing you need" -- which is essentially what Franck did -- doesn't really help those who don't know the ins and outs of Eclipse.

                No offense, Franck; at least you've provided some information which is probably useful to people other than me!
                • 5. Re: Unable to install plug-in
                  Peter T Martin
                  The Eclipse web site has a bunch of getting started material, I would have a look at that if you are interested in learning more about Eclipse: http://www.eclipse.org/resources/?category=Getting%20Started

                  In the mean time I will add some more info to the Cairngorm plugin pages.
                  • 6. Re: Unable to install plug-in
                    If this plugin is for flexbuilder, can you not include the URLs for the plugin download manager. Managed to track down where to get the 'org.eclipse.emf.codegen' plugin and when I tried to install that I then get another 'this requires plugin "org.eclipse.ocl.ecore"'.
                    A simple list of URLs would be very handy.

                    This is the URL I've used to get the EMF plugin http://download.eclipse.org/modeling/emf/updates/releases/ (this may not be right, if someone could confirm what they have used, that would be good.)

                    Thanks.
                    • 7. Re: Unable to install plug-in
                      orgicus Community Member

                      Got the same emf error.

                       

                      I'm a bit confused since this is a Flex Builder Plugin. FlexBuilder is built on Eclipse, but it deosn't have all the

                      features ( some Flex/as3 developers might not need all Java/other related plugins) and that's ok I guess.

                       

                      I'm also guessing that if I try to install the Cairngorm plugin straight into eclipse, not Flex Builder, that would work

                      because it has the right plugins.

                       

                      I tried installing the necesary plugins but I got into a vicious circle.

                      I am trying to install emf from here:

                      http://download.eclipse.org/modeling/emf/updates/releases/

                      via Help > Software Updates > Find and Install

                      but I get an error that some JET plugin is missing.

                      I'm trying to install JET ( with the whole stuff that comes with it ) from here:

                      http://download.eclipse.org/modeling/m2t/updates/releases/

                      But I can't because Jet is saying it won't install without emf and emf says it can't without jet.

                       

                      Anyone gone past that ?

                       

                      Has Adobe tried to actually install the Cairngorm Plugin into a clean FlexBuilder release?

                       

                      I'm using Flex Builder 3 Version: 3.0.214193

                      • 8. Re: Unable to install plug-in
                        Richard Dryfist

                        What is the resolution to this?  No one can install the cairngorm plugin for flex?  ...and Adobe has no answer?  WTF?

                        • 9. Re: Unable to install plug-in
                          Richard Dryfist Community Member

                          Yo Adobe....What's the deal with the Cairngorm plug-in?

                          • 10. Re: Unable to install plug-in
                            korosif

                            It was hard to find, but here is the solution to install the Cairngorm Plugin into Flex Builder (the standalone version).

                             

                            I think it would be very helpfull to add these instructions in the Plugin page, because I was close to give up...

                             

                            Summary:

                             

                            - When choosing location, check the adobe one AND the Europa Discovery Site

                            - When you select the Cairngorm plugin, the error message will appear

                            - Select the Europa Dicovery site, and click on the "Select required" button

                            - The required items will be selected and the error will disappear

                             

                            And, Voila... The installation should be successfull...