0 Replies Latest reply on Dec 8, 2008 3:33 PM by (Evtim_Georgiev)

    [svn] 4256: Fix bug http://bugs.adobe.com/jira/browse/ SDK-18230 setLayoutMatrix does not apply matrix immediately to GraphicElement with more than one DisplayObject

    Level 1
      Revision: 4256
      Author: egeorgie@adobe.com
      Date: 2008-12-08 15:33:25 -0800 (Mon, 08 Dec 2008)

      Log Message:
      -----------
      Fix bug http://bugs.adobe.com/jira/browse/SDK-18230 setLayoutMatrix does not apply matrix immediately to GraphicElement with more than one DisplayObject
      http://bugs.adobe.com/jira/browse/SDK-18231 setLayoutMatrix does not apply immediately to BitmapGraphic

      There are two problems that caused these bugs: 1 - we had an obsolete check in computeMatrix() that was returning null if the GraphicElement didn't have its display object assigned just yet. 2 - the setLayoutMatrix and setLayoutMatrix3D methods didn't invalidate properly GraphicElements that are sharing display objects.

      QE Notes: None
      Doc Notes: None
      Bugs: SDK-18230, SDK-18231
      Reviewer: Jason
      tests: checkintests, mustella (layout)

      Ticket Links:
      ------------
      http://bugs.adobe.com/jira/browse/SDK-18230
      http://bugs.adobe.com/jira/browse/SDK-18231
      http://bugs.adobe.com/jira/browse/SDK-18230
      http://bugs.adobe.com/jira/browse/SDK-18231

      Modified Paths:
      --------------
      flex/sdk/trunk/frameworks/projects/flex4/src/mx/graphics/graphicsClasses/GraphicElement.a s