0 Replies Latest reply on Jul 15, 2008 12:34 PM by (Ryan_Frishberg)

    [svn] 2494: Make DependencyChecker Java 1.4 compatible.

    Level 1
      Revision: 2494
      Author: rfrishbe@adobe.com
      Date: 2008-07-15 13:34:46 -0700 (Tue, 15 Jul 2008)

      Log Message:
      -----------
      Make DependencyChecker Java 1.4 compatible. Basically just comment out generics, switch for-loop styles from 1.5 syntax, and add some casts. Had to change the build file so it'll target java 1.4 to support asserts.

      This change should be merged to all 3.x branches but not into trunk.

      QE: No
      Doc: No
      Bugs: -
      Reviewer: Jono

      Modified Paths:
      --------------
      flex/sdk/branches/3.0.3/build.xml
      flex/sdk/branches/3.0.3/tools/dependencychecker/flex/tools/dependencychecker/DependencyCh ecker.java
      flex/sdk/branches/3.0.3/tools/dependencychecker/flex/tools/dependencychecker/FrameworkSwc DependencyRules.java
      flex/sdk/branches/3.0.3/tools/dependencychecker/flex/tools/dependencychecker/nodes/DefNod e.java
      flex/sdk/branches/3.0.3/tools/dependencychecker/flex/tools/dependencychecker/nodes/DepNod e.java
      flex/sdk/branches/3.0.3/tools/dependencychecker/flex/tools/dependencychecker/nodes/Depend encyNode.java
      flex/sdk/branches/3.0.3/tools/dependencychecker/flex/tools/dependencychecker/nodes/Librar iesNode.java
      flex/sdk/branches/3.0.3/tools/dependencychecker/flex/tools/dependencychecker/nodes/Librar yNode.java
      flex/sdk/branches/3.0.3/tools/dependencychecker/flex/tools/dependencychecker/nodes/Script Node.java