0 Replies Latest reply on Mar 7, 2008 10:47 AM by (Jono_Spiro)

    [svn] 758: Updating all modules to Java 1.5.0 and Ant 1.7.0

    Level 1
      Revision: 758
      Author: jspiro@adobe.com
      Date: 2008-03-07 10:47:56 -0800 (Fri, 07 Mar 2008)

      Log Message:
      -----------
      Updating all modules to Java 1.5.0 and Ant 1.7.0
      * Updated setup.sh to reflect this.
      * Added an Eclipse project called flex-asc; it's required to run the other compiler projects now (now you can build and debug the entire compiler, including asc, all in Eclipse; I've removed the reference to asc.jar).
      * The other Eclipse projects now specify Java 1.5.
      * Revving asc.jar for compatibility with Java 1.5; it's taken from the 3.0.x branch temporarily while mainline asc is fixed up.
      * Fixed some assertions in mainline ASC (commenting them out with comments means fixing them, in this case)
      * Fixed some in-your-face warnings in the modules when compiling.
      * This will probably break the build, so hold tight. Preemptively, I'm on it...

      Modified Paths:
      --------------
      flex/sdk/trunk/README.txt
      flex/sdk/trunk/development/eclipse/java/flex-compiler/.classpath
      flex/sdk/trunk/development/eclipse/java/flex-compiler/.settings/org.eclipse.jdt.core.pref s
      flex/sdk/trunk/development/eclipse/java/flex-compiler/.settings/org.eclipse.jdt.ui.prefs
      flex/sdk/trunk/development/eclipse/java/flex-debugger/.classpath
      flex/sdk/trunk/development/eclipse/java/flex-debugger/.settings/org.eclipse.jdt.core.pref s
      flex/sdk/trunk/development/eclipse/java/flex-debugger/.settings/org.eclipse.jdt.ui.prefs
      flex/sdk/trunk/development/eclipse/java/flex-jars/.classpath
      flex/sdk/trunk/development/eclipse/java/flex-swfutils/.classpath
      flex/sdk/trunk/development/eclipse/java/flex-swfutils/.settings/org.eclipse.jdt.core.pref s
      flex/sdk/trunk/development/eclipse/java/flex-swfutils/.settings/org.eclipse.jdt.ui.prefs
      flex/sdk/trunk/lib/asc.jar
      flex/sdk/trunk/modules/antTasks/build.xml
      flex/sdk/trunk/modules/asc/README.txt
      flex/sdk/trunk/modules/asc/build/java/build.xml
      flex/sdk/trunk/modules/asc/src/java/macromedia/asc/embedding/LintEvaluator.java
      flex/sdk/trunk/modules/asc/src/java/macromedia/asc/parser/MetaDataEvaluator.java
      flex/sdk/trunk/modules/asc/src/java/macromedia/asc/util/Context.java
      flex/sdk/trunk/modules/compiler/build.xml
      flex/sdk/trunk/modules/compiler/src/java/flex2/compiler/API.java
      flex/sdk/trunk/modules/compiler/src/java/flex2/compiler/config/ConfigurationBuffer.java
      flex/sdk/trunk/modules/compiler/src/java/flex2/compiler/swc/zip/ZipEntry.java
      flex/sdk/trunk/modules/compiler/src/java/flex2/tools/ToolsConfiguration.java
      flex/sdk/trunk/modules/compiler/src/java/flex2/tools/oem/Library.java
      flex/sdk/trunk/modules/debugger/build.xml
      flex/sdk/trunk/modules/swfutils/build.xml
      flex/sdk/trunk/modules/swfutils/src/java/flash/util/ExceptionUtil.java
      flex/sdk/trunk/setup.sh

      Added Paths:
      -----------
      flex/sdk/trunk/development/eclipse/java/flex-asc/
      flex/sdk/trunk/development/eclipse/java/flex-asc/.classpath
      flex/sdk/trunk/development/eclipse/java/flex-asc/.project
      flex/sdk/trunk/development/eclipse/java/flex-asc/.settings/
      flex/sdk/trunk/development/eclipse/java/flex-asc/.settings/org.eclipse.jdt.core.prefs
      flex/sdk/trunk/development/eclipse/java/flex-asc/.settings/org.eclipse.jdt.ui.prefs
      flex/sdk/trunk/development/eclipse/java/flex-jars/.settings/
      flex/sdk/trunk/development/eclipse/java/flex-jars/.settings/org.eclipse.jdt.core.prefs

      Property Changed:
      ----------------
      flex/sdk/trunk/development/eclipse/java/flex-compiler/
      flex/sdk/trunk/development/eclipse/java/flex-debugger/
      flex/sdk/trunk/development/eclipse/java/flex-jars/
      flex/sdk/trunk/development/eclipse/java/flex-swfutils/