10 Replies Latest reply on Feb 5, 2009 12:26 PM by projodude

    SVN 1.5 experience?

    matt_chotin Level 3
      We're considering upgrading the SVN repository to 1.5. The reason we'd do
      this is that we've heard the merging support is supposed to be much better.
      However we've heard that maybe the merging functionality isn't as great as
      it's supposed to be. Anyone have any experience or thoughts on this?

      Thanks,
      Matt
        • 1. Re: SVN 1.5 experience?
          ChivertonT Level 2
          On Monday 02 Feb 2009, Matt Chotin wrote:

          > We're considering upgrading the SVN repository to 1.5. The reason we'd do

          > this is that we've heard the merging support is supposed to be much better.

          > However we've heard that maybe the merging functionality isn't as great as

          > it's supposed to be. Anyone have any experience or thoughts on this?



          I think it would have to be a lot better to justify locking out some

          percentage of people.

          Ubuntu 8.10 still ships Eclipse 3.2, for instance, which I don't think has a

          1.5 SVN plugin - at least, I confused it with the Reactor repository for

          instance, using the command line, because Eclipse started saying 'this

          program is too old' for every directory I'd worked with outside Eclipse.



          I bet there are no stats on the number of v1.x SVN clients connecting ?



          --

          Tom Chiverton



          ****************************************************



          This email is sent for and on behalf of Halliwells LLP.



          Halliwells LLP is a limited liability partnership registered in England and Wales under registered number OC307980 whose registered office address is at Halliwells LLP, 3 Hardman Square, Spinningfields, Manchester, M3 3EB. A list of members is available for inspection at the registered office together with a list of those non members who are referred to as partners. We use the word partner to refer to a member of the LLP, or an employee or consultant with equivalent standing and qualifications. Regulated by the Solicitors Regulation Authority.



          CONFIDENTIALITY



          This email is intended only for the use of the addressee named above and may be confidential or legally privileged. If you are not the addressee you must not read it and must not use any information contained in nor copy it nor inform any person other than Halliwells LLP or the addressee of its existence or contents. If you have received this email in error please delete it and notify Halliwells LLP IT Department on 0870 365 2500.



          For more information about Halliwells LLP visit www.halliwells.com.




          • 2. Re: SVN 1.5 experience?
            matt_chotin Level 3
            Subclipse supports 1.5 and Eclipse 3.2 according to their website ( http://subclipse.tigris.org/roadmap.html).<br /><br />We don't have stats on the clients connecting, you're right.<br /><br />Matt<br /><br /><br />On 2/3/09 1:13 AM, "Tom Chiverton" <member@adobeforums.com> wrote:<br /><br />A new message was posted by Tom Chiverton in<br /><br />General Discussion --<br />  SVN 1.5 experience?<br /><br /> On Monday 02 Feb 2009, Matt Chotin wrote:<br />> We're considering upgrading the SVN repository to 1.5.  The reason we'd do<br />> this is that we've heard the merging support is supposed to be much better.<br />> However we've heard that maybe the merging functionality isn't as great as<br />> it's supposed to be.  Anyone have any experience or thoughts on this?<br /><br />I think it would have to be a lot better to justify locking out some<br />percentage of people.<br />Ubuntu 8.10 still ships Eclipse 3.2, for instance, which I don't think has a<br />1.5 SVN plugin - at least, I confused it with the Reactor repository for<br />instance, using the command line, because Eclipse started saying 'this<br />program is too old' for every directory I'd worked with outside Eclipse.<br /><br />I bet there are no stats on the number of v1.x SVN clients connecting ?
            • 3. Re: SVN 1.5 experience?
              Level 1
              >
              > We're considering upgrading the SVN repository to 1.5. The reason we'd do
              > this is that we've heard the merging support is supposed to be much better.
              > However we've heard that maybe the merging functionality isn't as great as
              > it's supposed to be. Anyone have any experience or thoughts on this?
              >

              I didn't upgraded to 1.5 for the smart merge (more for the svnsync
              which is much more stable)

              only thing I can say is using subclipse with Flex Builder and Eclipse
              the update to svn 1.5 was not that straightforward

              I would say if you guys need the 1.5 features go for it
              and devs will follow :)

              cheers,
              zwetan
              • 4. Re: SVN 1.5 experience?
                projodude
                For those who did upgrade to SVN 1.5 server/client, any bad side effects or irreversible consequences?

                Also, has anyone had problems with the SVN 1.5 client on a SVN 1.4 server?

                -eric
                • 5. Re: SVN 1.5 experience?
                  tinylion_uk Level 2
                  <div class=Section1><br /><br /><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";<br />color:black'>avoid 1.5 clients with 1.4 servers I&#8217;d say.<o:p></o:p></span></p><br /><br /><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";<br />color:black'>I got into a few problems so just went back down to 1.4 (client)<o:p></o:p></span></p><br /><br /><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";<br />color:black'>also the servers we ran were also taken back down to 1.4 (for now<br />anyway)<o:p></o:p></span></p><br /><br /><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";<br />color:black'>glenn</span><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";<br />color:black'><o:p></o:p></span></p><br /><br /><p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";<br />color:black'><o:p> </o:p></span></p><br /><br /><div style='border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt 0cm 0cm 0cm'><br /><br /><p class=MsoNormal><b><span lang=EN-US style='font-size:10.0pt;font-family:<br />"Tahoma","sans-serif"'>From:</span></b><span lang=EN-US style='font-size:10.0pt;<br />font-family:"Tahoma","sans-serif"'> eric omelian<br />[mailto:member@adobeforums.com] <br><br /><b>Sent:</b> Tuesday, February 03, 2009 7:52 PM<br><br /><b>To:</b> flexsdk-general@adobeforums.com<br><br /><b>Subject:</b> Re: SVN 1.5 experience?<o:p></o:p></span></p><br /><br /></div><br /><br /><p class=MsoNormal><o:p> </o:p></p><br /><br /><p class=MsoNormal style='margin-bottom:12.0pt'>A new message was posted by<br />eric omelian in <br><br /><br><br /><b>General Discussion</b> --<br><br />  SVN 1.5 experience?<br><br /><br><br />For those who did upgrade to SVN 1.5 server/client, any bad side effects or<br />irreversible consequences? <br><br /><br><br />Also, has anyone had problems with the SVN 1.5 client on a SVN 1.4 server? <br><br /><br><br />-eric <o:p></o:p></p><br /><br /><div class=MsoNormal><br /><br /><hr size=2 width=200 style='width:150.0pt' align=left><br /><br /></div><br /><br /><p class=MsoNormal style='margin-bottom:12.0pt'>View/reply at <a<br />href="http://www.adobeforums.com/webx?13@@.59b7c281/3">SVN 1.5 experience?</a><br><br />Replies by email are OK.<br><br />Use the <a<br />href="http://www.adobeforums.com/webx?280@@.59b7c281!folder=.3c060fa1">unsubscribe</a>< br />form to cancel your email subscription.<o:p></o:p></p><br /><br /></div>
                  • 6. Re: SVN 1.5 experience?
                    Level 1
                    >
                    > For those who did upgrade to SVN 1.5 server/client, any bad side effects or
                    > irreversible consequences?
                    >

                    well there is, it's not dramatic but still

                    cf http://subversion.tigris.org/svn_1.5_releasenotes.html
                    "The working copy format has been upgraded. This means that 1.4 and
                    older Subversion
                    clients will not be able to work with working copies produced by
                    Subversion 1.5. "
                    +
                    "Working Copy Upgrades

                    WARNING: if a Subversion 1.5 client encounters a pre-1.5 working copy,
                    it will automatically
                    upgrade the working copy format as soon as it touches it, making it
                    unreadable by older Subversion clients.
                    If you are using several versions of Subversion on your machine, be
                    careful about which version you use
                    in which working copy, to avoid accidentally upgrading a working copy.
                    (But note that this "auto upgrade"
                    behavior does not occur with the repositories, only working copies.)"


                    > Also, has anyone had problems with the SVN 1.5 client on a SVN 1.4 server?
                    >

                    no problem so far
                    I use SVN 1.5 client on 6+ google code repos, and google code is still
                    using svn 1.4 server
                    • 7. Re: SVN 1.5 experience?
                      Level 1
                      well

                      when I see google code hosting upgrading to SVN 1.5
                      http://google-opensource.blogspot.com/2009/02/updates-to-our-project-hosting-service.html
                      http://google-code-updates.blogspot.com/2009/02/project-hosting-upgraded-to-subversion.htm l

                      considering the big number of repositories they got
                      and still numerous people using SVN 1.4 clients

                      I think it should be OK to upgrade ;)

                      zwetan
                      • 8. Re: SVN 1.5 experience?
                        Nate Beck Adobe Community Professional
                        I've been using the 1.5 client for a while now... Haven't run into any issues yet. If googlecode is updating, I'm sure it's fairly safe.
                        • 9. Re: SVN 1.5 experience?
                          ChivertonT Level 2
                          On Thursday 05 Feb 2009, zwetan wrote:

                          > I see google code hosting upgrading to SVN 1.5



                          That settles it for me. If there is little risk and some chance of benefits,

                          go for it.



                          --

                          Tom Chiverton



                          ****************************************************



                          This email is sent for and on behalf of Halliwells LLP.



                          Halliwells LLP is a limited liability partnership registered in England and Wales under registered number OC307980 whose registered office address is at Halliwells LLP, 3 Hardman Square, Spinningfields, Manchester, M3 3EB. A list of members is available for inspection at the registered office together with a list of those non members who are referred to as partners. We use the word âpartnerâ to refer to a member of the LLP, or an employee or consultant with equivalent standing and qualifications. Regulated by the Solicitors Regulation Authority.



                          CONFIDENTIALITY



                          This email is intended only for the use of the addressee named above and may be confidential or legally privileged. If you are not the addressee you must not read it and must not use any information contained in nor copy it nor inform any person other than Halliwells LLP or the addressee of its existence or contents. If you have received this email in error please delete it and notify Halliwells LLP IT Department on 0870 365 2500.



                          For more information about Halliwells LLP visit www.halliwells.com.




                          • 10. Re: SVN 1.5 experience?
                            projodude Level 1
                            Thanks for all the feedback everyone! We're still thinking over a few issues and will let the community know of next steps shortly.

                            -eric