2 Replies Latest reply on Jun 6, 2006 5:50 PM by Chunick

    OCX not working on other systems :(

    AntiTRUST� Level 1
      Hi everyone,
      I am using a OCX component into my application, the app is working perfect on my system, but when i run the compiled exe into other systems i get the "Property Not Found error".

      I registered those OCX onto other systems and also copied them into the System32 folder but still not working. Why it is that?? Can anybody have any idea for making my app (which is using an ActiveX Component) run on every machine.


      Any early response will be highly appreciated.
      Thanks,
      Amir
        • 1. Re: OCX not working on other systems :(
          Gunterman
          It may be a licensing issue. If it's an OCX you paid for, it'll probably be restricted to usage on that machine.
          You got the OCX from somewhere. Find the software that installed the OCX, and run that installer on a second machine. Then try your projector. If it works, then you might need to find out from the company what it will take to distribute the OCX.

          If you wrote the OCX yourself, then you are not registering it correctly.
          • 2. Re: OCX not working on other systems :(
            Chunick Level 3
            make sure the OCX component is in the same folder as your director file. Import it... when you package it up, make sure it gets unpackaged in the same folder and register it from there. It doesn't have to be in the System32 folder in order to be registered (it can be registered from anywhere). The relative location of the OCX to your director file when it was originally imported is probably important to it being located by your director file.