19 Replies Latest reply on Jan 26, 2011 2:20 PM by descender

    Error Message - "There was not enough memory." Help!

    Dinarius Level 1
      PC/Bridge/ACR 4.3.1.

      Hi,

      I am trying to save 17 files as Jpegs using ACR4.

      I have already saved them as TIFFs and DNGs without problem.

      However, when I try to save them as size 5 Jpegs a window opens headed:

      'Camera Raw Save Status', Remaining Images to Process (and a list of all 17
      images.) Next to each file name is the line, "There was not enough memory."

      Even if I reduce the number of images to be converted to 5 or 6, I have the same problem.

      There are 4Gb RAM, plenty of HD space and no other program is open.

      ACR simply will not save Jpegs for me!

      Any idea what might be causing this?

      Thanks.

      D.
        • 1. Re: Error Message - "There was not enough memory." Help!
          Dinarius Level 1
          Update..........

          Since this was the first time I had ever tried to convert to Jpeg using ACR (I usually use Image Processor in CS3) I had the conversion settings set to 16bit by default.

          So, I set ACR to 8bit and tried a batch of 10 images. No problem. They all converted.

          Then, I tried another 10. After about 5 images, the same memory error window returned! :-(

          So, I reduced the number of images to 6. Now it wouldn't convert one before the error appeared. Since this looked like a reducing memory problem, I purged the cache in Bridge for that image folder and then closed and reopened Bridge. However, it still won't convert any images.

          I can convert any number of TIFFs or DNGs without a problem, so why not Jpegs?!

          I'm amazed that no one else has come up against this (assuming I'm not overlooking something on my own setup).

          Weirdly, the conversion works no problem with a folder of Canon images. I just ran 134 images through without a problem.

          It seems to be only my Hasselblad files that cause the problem.

          Any ideas?

          Help, please!

          Thanks.

          D.
          • 2. Re: Error Message - "There was not enough memory." Help!
            Ramón G Castañeda Level 4
            [Never mind. I see you're on a PC.]
            • 3. Re: Error Message - "There was not enough memory." Help!
              Omke Oudeman Level 5
              Dinarius

              It seems indeed related to Hasselblad, I can't reproduce your problem (even the 16 bit Raw settings saves without problems to jpeg in ACR...)

              But as Ramón, I'm on a Mac to. It looks like you have to visit a different forum or start a new topic with the Hasselblad and jpeg problem in the Topic line, it then might draw the attention of Thomas Knoll??
              • 4. Re: Error Message - "There was not enough memory." Help!
                Level 1
                Just curious.. how large are the files that you're saving as JPGs?

                There used to be out of memory issues with saving JPGs and Photoshop a while back (can't remember the version). If I remember correctly I think it was related to the MMXCore.8BX or MultiProcessor Support.8BX plugin. Though you're using ACR which does not use these. The 'workaround" for that was to save as a 'Baseline ("Standard")' JPG rather than Progressive. But that option does not exist in ACR so that's not an option.

                Some recent fixes for various ACR ills point to increasing ACRs default cache size from 1gb to 10gb. Try that.

                There's also a possibility that the memory assigned to Photoshop is too high and ACR cannot get what it needs. Try lowering it to 50% (in Photoshop Preferences) and see if that helps. If it does then you'll have to search for the sweet-spot memory setting that works.
                • 5. Re: Error Message - "There was not enough memory." Help!
                  Dinarius Level 1
                  Russell,

                  Apologies for the delay in acknowledging your reply! Mea culpa.

                  I am saving (or trying to) full size Jpegs from 39Mp Hasselblad RAW files.

                  I tried increasing the Cache size to 10Gb and had exactly the same problem. This was with a folder of only 11 images which I shot this morning and which are being saved to an entirely new folder. So, all is different from last week.

                  I then tried reducing the memory allocation in CS3 to 50%. Again, the same problem.

                  ACR just doesn't not want to convert Hasselblad files to Jpegs. It will convert them to anything else and CS3's Image Processor will convert the TIFFS to Jpegs too.

                  But, I'd like to be able to convert from ACR4 if possible.

                  Any other ideas?

                  Many thanks.

                  D.
                  • 6. Re: Error Message - "There was not enough memory." Help!
                    PECourtejoie Adobe Community Professional
                    Have you tried with ACR hosted in Bridge, rather than Photoshop? (and Photoshop being closed)
                    • 7. Re: Error Message - "There was not enough memory." Help!
                      Dinarius Level 1
                      Hi,

                      Thanks for the reply.

                      ACR is always hosted in Bridge. I only ever use CS3 after I have corrected and converted the RAW files.

                      Apologies if I gave the wrong impression.

                      Given the dearth of replies, I think I will start another thread with Hasselblad in the title. That might evoke a few more ideas.

                      Thanks.

                      D.
                      • 8. Re: Error Message - "There was not enough memory." Help!
                        I have the same problem with canon eos 40D CR2's... can't correct more than 60 raw without closing CS3.. Please HELP!!!! thanks
                        • 9. Re: Error Message - "There was not enough memory." Help!
                          JimHess-8IPblY Level 3
                          The common solution to this problem seems to be to host Camera Raw in Bridge so that you can run it without Photoshop being loaded. At least those are the type of comments that I have read from Thomas Knoll and Jeff Schewe. So the behavior you are experiencing seems to be normal.
                          • 10. Re: Error Message - "There was not enough memory." Help!
                            Dinarius Level 1
                            Jim,

                            Alas no.

                            CS3 remains firmly shut while I (always) use ACR via Bridge and the problem still occurs.

                            This happens with both TIFFs and Jpegs.

                            It is at its worst when I try saving out 220Mb Hasselblad TIFFs (that have been processed in Flexcolor) which I make adjustments to in ACR: usually just cleaning with the Retouch Tool.

                            It's like ACR caches every file rather than clearing memory when it has saved out the TIFF. The result is a breakdown very soon after starting the process.

                            I've tried experimenting with only saving out the files in threes and fours, but after two or three sets I get the memory error and I have to close and reopen Bridge. Maddening!

                            I'm hoping that CS4 and its ability to address all my 8Gb RAM (I'm running Vista Ultimate) will solve the problem, but I'm not holding my breath.

                            A friend with the same 39Mp Hasselblad, but running a Mac, never has ANY problems. He can save out any number of 220Mb files from ACR without a hitch.

                            If anyone can suggest settings changes that I might make in CS3 and Bridge that might address the problem, I'm all ears! ;-)

                            D.
                            • 11. Re: Error Message - "There was not enough memory." Help!
                              JimHess-8IPblY Level 3
                              Dinarius,

                              I guess I should've clarified that I was not responding to your dilemma, but rather to GVS. As far as your problem is concerned, I just think that those Hasselblad files are simply too big. While it's true that they are "only" 220 MB, I think it probably takes a lot more memory than that to process the files. As great and wonderful as everyone thinks Windows Vista is, I just don't believe the Windows operating system is as efficient as it should be for the type of work you are doing. I suspect you would do a lot better if you switch to a Mac with a lot of memory.

                              When I watch the tutorial videos on Adobe.tv and other websites I am amazed at how much faster the images are processed. And as I look closer I see that all of the trainers are using Mac computers. Remember, Photoshop CS3 was completely rewritten to take better advantage of the Mac and its operating system. Photoshop has been optimized to run at its best in that environment. You don't see that happening for the Windows operating system. In my opinion (yes, my opinion) the Windows operating system is so unstable and changes so dramatically from one version to the next that it is impossible to try to optimize any program for it. I do not use a Mac computer, but I realize I'm taking a major performance hit with my Photoshop work because of that choice.
                              • 12. Re: Error Message - "There was not enough memory." Help!
                                Dinarius Level 1
                                Jim,

                                You could be right.

                                Oddly, I can save out ANY number of Canon 1DsM3 16bit/120Mb files from ACR, without a memory error message.

                                Why the extra 100Mb in the Hassie files screws up everything is beyond me.

                                D.
                                • 13. Re: Error Message - "There was not enough memory." Help!
                                  descender Level 1

                                  I'm experiencing the same problem (but in 2011, several software versions later than the original post).  Is this bad form to bring up a post that old?  In some forums on the net, members want you to always reuse old topics as much as possible and curse you if you start a new thread on an old topic.  On others they frown upon reviving an old thread.  Let me know and I'll be happy to comply.

                                   

                                  So I'm using ACR 6.3, opening 18Mb images that are .PEF files from my Pentax K-5 (pentax's proprietary format similar to DNG).  I can usually open and save one at a time.  But if I open a multiple of these files, say three, in ACR and select all and try to save them as TIFF or JPEG I get the out of memory error.

                                   

                                  Windows 7 32-bit with 4Gb RAM.  I'm upgrading in a few days to 12Gb and 64-bit.  That will probably solve this.  Still, the system should technically have a huge amount of virtual memory because I have plenty of space on the ACR cache drive (I have at least 32Gb free on that drive).

                                   

                                  Photoshop is open but set to use 50% of available memory, so I don't think it's in the way...

                                  • 14. Re: Error Message - "There was not enough memory." Help!
                                    RASouthworth Level 3

                                    I have my CR preferences set for 20gb in the CR scratch file, and I have converted large numbers of files to jpegs within ACR with no problems.  Don't know if it will help, but it's worth a try.

                                     

                                    Added by edit - be sure to purge the cache.

                                     

                                    Richard Southworth

                                    • 15. Re: Error Message - "There was not enough memory." Help!
                                      Curt Y Level 6

                                      "Not enough memory" is a generic term that also includes RAM, or not enough contiguous space on HD.

                                       

                                      If you open a 18mb file and do some proceedures you could end up with a much larger file, so if you get a few 40 meg files it could tax your 1.7 gig of RAM.

                                      • 16. Re: Error Message - "There was not enough memory." Help!
                                        Noel Carboni Level 7
                                        function(){return A.apply(null,[this].concat($A(arguments)))}

                                        descender wrote:


                                        Photoshop is ... set to use 50% of available memory, so I don't think it's in the way...


                                        Have you tried changing this parameter one way or the other to see if it helps?

                                         

                                        You're on the right track moving up to an x64 operating system.  Bear in mind it will be a complete, fresh reinstall - you cannot directly upgrade a 32 bit OS to a 64 bit OS.  Microsoft does provide some tools to help, but they assume you have both systems available at the same time (e.g., if you got a new computer).

                                         

                                        Make sure you have a good external backup of all your files - everything you could possibly imagine you'll want on the new system.

                                         

                                        -Noel

                                        • 17. Re: Error Message - "There was not enough memory." Help!
                                          descender Level 1

                                          Thanks, everyone.  Yes, I have tried setting PS to use more than 50%, i've tried 60, 65, 70, 75%.

                                           

                                          Windows' virtual memory system should just provide enough disk space for whatever operation to complete (though more slowly) and I have hundreds of Gb free on my two PS scratch disks, and 32Gb free on the drive that contains my ACR cache folder.

                                           

                                          Seems like there must be some memory leakage or other programming issue with ACR if it insists it's short on memory when there's enough virtual memory to do many times more than what I'm doing.  Remember this happens sometimes even when I just freshly opened the program and nothing else is running.

                                           

                                          I know my upcoming 12Gb and 64bit will take care of it, so maybe I don't have much reason to belabor the point.  But it still "should" work as is on my 4Gb system.

                                           

                                          I forgot to mention this, too: any time ACR refuses to save a file because it's out of memory, it will still allow me to open that file (or multiple files) in Photoshop, which is then happy to save them as needed.  So it's not like the memory isn't there... hey, maybe I need to reserve even *less* than 50% for Photoshop.  I don't know.

                                           

                                          Well anyway, I will eagerly await the delivery of my new RAM

                                          • 18. Re: Error Message - "There was not enough memory." Help!
                                            RASouthworth Level 3

                                            It's not enough to have extra space on the drive that contains the ACR cache, you have to specify the maximum allowed.  Check the preferences.

                                             

                                            Richard Southworth

                                            • 19. Re: Error Message - "There was not enough memory." Help!
                                              descender Level 1

                                              Thank you, Richard, that was it.  I had simply overlooked the fact that ACR Preferences needs you to set a specific cache size.  I believe when I first saw that setting I thought of it as optional, but now I see if you don't change it, you're literally limited to 1.0Gb in the disk cache and that's tiny.

                                               

                                              I just exported 7 raw files to 16Mb TIFFs, looks like everything is working right.  Maybe my resize/zoom problem will go away too.