3 Replies Latest reply on Jul 27, 2008 2:54 PM by Ramón G Castañeda

    Recovered CR2 files won't open

      I shoot in RAW with a Canon 40D and for months have been using Elements 5.0 (under Windows XP) with the relevant Raw Converter plug in to open and process them.

      This week I had to recover some deleted files from a portable hard drive. Nothing had been added to the drive since deletion. Uneraser found loads of .CR2 files, including the ones I was looking for. The file names and numbers were identical except that they started xMG rather than IMG. Each of the files is over 10MB, which looks promising. I've saved them all to a separate drive.

      So far so good. But when I try to use Elements to open the .CR2 files, I get the message that they are "the wrong type of file". I've tried renaming them by replacing the opening "x" with "I". No good. I've tried the version of Canon DPP which came with my 40D. No good ("cannot parse the file").

      Interestingly, some of the other .CR2 files recovered will open. They seem to be earlier ones which I took with my 400D rather than the 40D, and which I deleted months ago. But I can't say whether it's exclusively the case that all the 400D files open and all the 40D ones don't. I haven't been through all the thousands of files!

      Anyone had this experience or have suggestions of what I might try next?

      Thanks

      David