20 Replies Latest reply: Apr 29, 2009 7:12 PM by countryboy007 RSS

    CS4 Install Problem

      I've read through many of the CS4 install problems already posted, but none seem to match the problem I'm having. I'm hoping someone can help.

      My System:
      HP m8100n
      Vista Home Premium (32 bit OS) w/ Service Pack 1
      AMD Athlon 2.8 GHz
      3GB RAM

      Program I currently have/use:
      Adobe CS2 (I didn't have any problem with that install)

      I have purchased CS4 Design Premium (OEM version). When I try to install the program I keep getting the following error message immediately (before the install actually begins):

      "Server Busy
      This action cannot be completed because the other program is busy. Choose 'switch to' to activate the busy program and correct the problem."

      My options from this error box are: Switch To, Retry, Cancel - however cancel is greyed out so I can only click Switch To or Retry. If I click Switch To my start menu opens up waiting for me to select something (I have no idea what). If I click retry the error box just comes back up. I can't canel (greyed out) and I can't "X" down the error box. I have to bring up the Task Manager and cancel the "Adobe Setup" process to get rid of the error box. There is no error number or any other message/warning.

      I have scanned for viruses and spyware - system clean.

      I don't have any other programs running and I have removed all unnecessary start-up programs. I don't have any anti-virus, firewall or spyware killer programs running.

      I have tried installing using autoplay, as well as trying the "setup" within the Disc 1 CS4 folder - both as Administrator - same error

      I have uninstalled Adobe Player, but I haven't yet uninstalled my CS2 (because I can't risk being left without at least that one).

      I have copied the Adobe CS4 folder from Disc 1 to my desktop and tried running the install from there (as administrator)...same error.

      I have two DVD drives with this computer and have tried the install from both - same error

      The problem isn't with OEM registration. I've done the OEM registration (done BEFORE install) and that went fine.

      I'm pulling my hair out and beginning to think I wasted my money buying this version. I don't know what else to do or try. Any ideas or help would be appreciated. Be warned, I'm not experienced at tinkering with the registry.