6 Replies Latest reply on Jun 6, 2008 2:22 PM by BWolfe [ADOBE]

    Not allowed to run old version, can't download new, with MacOS 10.3

    Level 1
      I have a Powerbook running Mac OS 10.3.9. When I start Digital Editions it tells me that there is a new version and that I must upgrade or quit. However, the new version (1.5) requires Mac OS 10.4 - and I cannot download it even if I wanted. In effect, I can no longer run Digital Editions on my computer. To put it kindly: That is somewhat irritating.
      Of course, it works if I shut down internet access, but that's quite awkward.
      How do I continue running Digital Editions?
      /Jacob