17 Replies Latest reply on Feb 20, 2012 2:25 PM by Frustrated in AZ

    Error#2038

      I'm trying to open one of the sample books.

      I click on it and Digital Editions opens and says it downloading.

      However after about 5-10 minutes the following error message appears...

      IO ERROR on NETWORK REQUEST.

      Please check your network connections and try again.

      Network path

      http://divpi.adobe.com/bookbytes/ebx_isbn_0345472160.pdf

      Event detail
      ERROR#2038

      Can anybody advise please
        • 1. Re: Error#2038
          BWolfe [ADOBE] Level 3
          This error is very generic. All it really tells us is that the Flash Player (which is part of Digital Editions) ran into a problem when contacting the server. The most common causes of these kinds of problems are some proxy or firewall that is interfering with the HTTP headers that DE needs to manage the download process. See the info here:

          http://support.adobe.com/devsup/devsup.nsf/docs/53819.htm

          Another cause can be a spam or virus checker, such as Kaspersky or McAffee, which is not set to allow Digital Editions to access the internet. You can try it again, but you'll most likely need to troubleshoot your machine to see what's blocking the download.

          Regards,

          Bentley Wolfe
          Senior Support Engineer, Flash/Flash Player/Digital Editions
          Adobe
          • 2. Re: Error#2038
            When downloading a very large ebook (13MB), I've had the same error. Simply increasing the maximum storage size that Flash could use on my machine seemed to solve the problem in my case. (Right click ADE to bring up Flash settings, choose Settings, then the Local Storage tab, and increase the local storage slider (I set it to Unlimited, and set it back down later).

            Given that Error#2308 is very generic, this will only solve the error some of the time, of course.

            Arthur Attwell
            Electric Book Works
            electricbookworks.com
            • 3. Re: Error#2038
              When I try to open any pdf doc with DE I get the following error message:

              Error during recovery after failed manifest save.
              Error deleting file: manifest.xml
              Error detail: Error #2038

              Can someone advise me on this one?
              • 4. Re: Error#2038
                Robertzear

                hey a client of mine had this problem with his computer..

                 

                he bought a ebook but when he tryed to open it with ADE it gave the famous error...

                 

                so i ran the program as a admin... i authorised his account.. ( adobe-ID )

                 

                and the download started and the book opened !!!

                 

                hope this helps some of you..

                 

                grtz Robert

                • 5. Re: Error#2038
                  luis.velazco

                  i have the same problem ...  help

                  • 6. Re: Error#2038
                    Raine M

                    I'm running Mac OS 10.6.6 I get this error message 2038-and then I can't open an epub book on my Mac--any fix for this? Is it possible that I am adding them to the library too quickly? Or is it flash related?

                    • 7. Re: Error#2038
                      deerfern

                      I got Error # 2038, too. I had tried reinstalling, rebooting, deleting folders, cleaning registry, deleting and reactivating, even more.

                       

                      However, I was finally able to fix it, so I thought I would share.

                       

                      I have found that Error # 2038 means that something is blocking ADE access to the port or server where your ebook is.

                       

                      It seems a simple thing, it was my firewall in WIN 7 giving me the problem. The firewall appears to be off but was actually still on. WIN 7 has different firewall settings. There are 2 ways that worked for me.  In Windows Control panel, System & Security, Firewall, it showed me 2 different firewalls, one called Home or Work (Private) and the other called Network. I turned them both off … but it still would not download my ebook. This is where I was stuck.

                       

                      Option 1. (safer) On the left side there’s a link for “Allow a program or feature through Windows Firewall”. I went there, where it shows a list of programs with boxes to check off for “Home/Work (Private)” and “Public”. As Digital Editions wasn’t there for me to choose, I clicked on Allow Another Program. Another pop up box still didn’t show it, so I had to browse for it. Once found, I was able to add it to the list and checked both the “Home/Private” and “Public” boxes.

                       

                      Option 2. Still in Control Panel, System & Security, Firewall, click on Advanced Settings on the left. This area showed my Firewall was still on. I clicked on “Windows Firewall Properties” which brought me to a choice of 4 tabs, Domain Profile, Private Profile, Public Profile and IPSec Settings. My Private and Public firewall was off (which showed in Control Panel) but the Domain Profile Firewall was still on (missing that little tidbit of info in Control Panel Firewall). I clicked on Firewall State: OFF.

                       

                      Bingo, I could then download my ebook. As I had done Option 2 first, I tried keeping the firewall Domain Profile ON and allowing Digital Editions access as a program. That worked, and as that’s safer, that’s where I’ve left it.

                       

                      I hope this works for someone else having trouble with this error #2038.

                      • 8. Re: Error#2038
                        brooklynirishgirl

                        No matter how many times I deleted Library books from ADE the covers remained in My Files.  If I tried to open the book I received the error 2308.  I used your solution #1 and it solved my problem.  You were the only one able to figure out why this was happening. Thanks so much! 

                        • 9. Re: Error#2038
                          Big_Jenko1967

                          HELPPPPPPPPPPPPP

                           

                          I am having the same problem... trying to download an ebook and I get the below: I have windows 7 and Norton 360....

                           

                          'IO Error on Network Request.

                          Please check your network connection and try again.

                           

                          Network Path:

                          http://acs4.ebookshipping.com:.............PDF

                           

                          Event Detail:

                          Error #2038'

                          • 10. Re: Error#2038
                            Frustrated in AZ Level 4

                            Win 7's security has given many here fits.  It appears that Win 7 will tell

                            you that ADE is allowed to go through the firewall, but if you look at the

                            settings somewhere else, it can't.  Browse some of the other threads -

                            others have posted more extensively on this issue and how to solve it.

                             

                            ===============

                            • 11. Re: Error#2038
                              ipeltier

                              I am using a Mac 10.6.8, and cannot get Adobe Digital Editions to open my ascm library downloads.  I get the error message 2038.  Does anyone have a solution for Macs?

                              • 12. Re: Error#2038
                                Squaldim

                                I am trying to download a book I just bought. Same error message... I tried every solutions I found on the board, nothing works.

                                 

                                And it seems Adobe people don't care that much about it...

                                • 13. Re: Error#2038
                                  ipeltier Level 1

                                  I have two computers--a older eMac and a newer Mac laptop.  I can't get Adobe to open any borrowed library books on the laptop, (message 2038) but they open on the older eMac.  What's that all about?  Unfortunately, I need these library books accessible on my laptop when I travel...

                                  • 14. Re: Error#2038
                                    Squaldim Level 1

                                    Still waiting for help... Thanks Adobe.

                                    • 15. Re: Error#2038
                                      itsmyrouter

                                      I've been struggling with this same problem for the past day and i've cracked it... sort-of...

                                       

                                      Recently purchased 2 books (first 2 ebook purchases ever btw) for my Wife's new PRS T1. downloaded the acsm files... wouldn't download using sony's Reader software. Just says i can't do it.... made sure all adobe liscencing was done. Registered the product with sony... still no dice.

                                      downloaded the ADE software, Got the same error message as above.. Googled all these forums. Tried every permission under the sun to let it thru windows 7 firewall. No avail.

                                      I Tried to find the firewall settings in my router but was unsuccessful.

                                       

                                      Just now I got inspired by some advice on this forum and something posted over on booksonboard.

                                       

                                      "

                                      I get the error message "IO Error on Network Request...Error #2038" when attempting to transfer to my Adobe Digital Editions software.

                                      This error message indicates that your computer is unable to connect to the Adobe Content Server. This can have several causes, all concerned with network interference:

                                      • A firewall is set up between your computer and the Internet. This is often the case when attempting to download from a work computer.
                                      • Popup blocking software or a web accelerator is similarly interfering with network activity.
                                      • Regional interference.

                                      The solution is to temporarily disable any software you think may be blocking the download, and reattempt.

                                      "

                                       

                                      I decided to bypass my router. Used my 3G phone as a modem for the PC instead and lo-and behold! it worked!!! (took a little while tho)

                                      I'm using a Dynalink RTA1025W modem. It's caused me grief in the past with P2P stuff so i'm guessing that this is a simmilar issue.... unfortunately solutions to that involved making ports available on the router and such that i've not found adequate information for. Does anybody know what ports etc need to be open/available and other details to allow the download of ePUB files from the server?

                                       

                                      Anyway, at least I have a temporary solution.... I could just go and buy a faster router.... that'd be a nice excuse since its for my wife's christmas present and all.....

                                      • 16. Re: Error#2038
                                        j_khill_61

                                        I came across this error recently. I can see from this thread as well as on threads outside of Adobe that there are different solutions to this condition. Here is my solution. Hopefully this will help others suffering through their pain.

                                         

                                        The system with the problem is running Windows Vista and IE9. The error 2038 was a network path issue rather than a local path issue. As well this was the first time the program was insatlled and in use. So in other words it failed straight away..it never worked.

                                        The following steps were tried, none of which solved the problem;

                                        1. Disabled Windows Firewall

                                        2. Disabled AVG

                                        3. Disabled both  the Windows Firewall and AVG

                                        4. Reset Internet Options to default

                                        5. Upgraded AVG to AVG 2012

                                        6. Removed several suspicious freeware / potential virus programs

                                        7. Reinstalled Adobe Digital Editions

                                        8. Changed the Flash configuration to unlimited memory usage

                                         

                                        Note that a reboot was executed between most of the steps. Clearly this error was unrelated to conflicting network programs or configurations. My next step was to investigate potential conficts with the router and ISP and mentioned by itsmyrouter. However this seemed ridiculous as the sytstem in question is owned by my 90 year old parents. The fact is that programs like this need to work as is, without tuning of network gear. So I took a diferent path.

                                         

                                        The installation of Adobe's Digital Editions v 1.8 preview 3 from Adobe labs solved the problem. After installation it ran as advertised and loaded the ePUB file. Hopefully this beta version is stable enough from now to its release date.

                                         

                                        Best of luck.

                                        John

                                        • 17. Re: Error#2038
                                          Frustrated in AZ Level 4

                                          I've also found out that there are more than one cause for this error.  If

                                          working the problem as you said doesn't resolve the conflict, try clicking

                                          HERE

                                          <http://technology.myblogzone.info/2011/01/how-to-solve-the-error-getting-license-message-i n-adobe-digital-editions/>and

                                          see if the information in this message is helpful.

                                           

                                          =============