1 Reply Latest reply on Oct 15, 2008 8:05 AM by Beth Bakeman

    MAC LEOPARD OS X "E_ADEPT_REQUEST_EXPIRED

      When I activate Adobe Digital Editions 1.5, I experience the following error:

      "E_ADEPT_REQUEST_EXPIRED http://adeactivate.adobe.com/adept/Activate"

      I have double checked my time zone, clock and time, reinstalled the software and restarted my laptop to no avail. The error keeps occurring.

      I use MAC Leopard OS X.