20 Replies Latest reply on Sep 18, 2011 6:13 PM by bfreem

    ERROR #2038?

      I'm downloading books from a library and I can't seem to get them to load on digital editions. :(

      I normally dl. the book and then click the link on my desktop which opens the file. I can dl fine but when digital editions tries to open the book it doesn't work and gives me an error.

      Then I click the book in the shelf to open it and it gives me this:

      Caitlin''s Cowboy:
      IO Error on local file open

      C:\Documents and Settings\Administrator\My Documents\My Digital Editions\Caitlins_Cowboy.pdf

      Event Detail:
      Error #2038
      --- end ---
        • 1. Re: ERROR #2038?

          am facing the same problem too...any help????? please????

          • 2. Re: ERROR #2038?
            lindab8728 Level 1

            I responded to another post regarding this error message earlier - thought I would post this to yours as well - maybe it might help


            The error message that you are receiving goes along with a couple of issues that can occur -  We've seen this one and were able to recreate it on a compuiter - troubleshoot it and repair the issue


            1)  Usually when you receive this error message you can check the following items:


                 Open the My Documents / My Digital Editions directory - click on the "Restore" folder  - open the TASK folder and remove any "outstanding' tasks

                 Open the My Documents / My Digital Editions directory - click on the "Restore" folder  - open the FAIL  folder and remove any "outstanding' tasks


            2)  Make sure that you don't have a Proxy Server / Firewall or Anti-virus application halting your machine from communicating to the Internet -  This is one of the big issues -  when you try to download - if the machine is not getting the full "URLLINK" file which is the core component loaded down to your machine - then the book cannot open - Thus resulting in your IOAdept Error message - 2038.


            3)  If you are clicking "Open" on the document for download and Adobe Digital Editions is not opening the file - try to complete a "SAVE" instead to the My Digital Editions directory -  this will place the "URLLINK" in the folder -  Once the item is downloaded - open the My Digital Editions directory and right click on the URLLINK -  choose "OPEN WITH" - Adobe Digital Editions -  You will need to give it a minute or two - in most cases the document opens up immediately and can be utilized from there on out without any issues.


            Hope some of this helps, if not I will keep my eyes out and see if we run across any other issues with this same error message.

            • 3. Re: ERROR #2038?

              I am having the same problem (IO error on local file open, #2038), except I successfully downloaded the book, added bookmarks, etc.  Then I closed the Digitial Editions for a while.  When I reopened it, the book now say 'missing', tells me my download is incomplete, and generates the IO error.  I removed the extraneous files from resore/fail and restore/tasks as per previous posts, but it still does not work. I don't quite understand the reference to "complete a save" from previous post- I do not see a save option of any kind in the program.  Thanks for any help....

              • 4. Re: ERROR #2038?

                Hello everyone, I had the same problem and would suggest the following:


                (1) Close My Digital Editions


                (2) Go the the "My Documents", then "My Digital Editions" directory.


                (3) If there is anything in the following directores delete it:


                     "Restore" including all subdirectories

                     " Thumbnails"

                (4) Now Open and re-add all files to the library and see if you can open them.


                Good luck, let me know if this helps.



                • 5. Re: ERROR #2038?
                  Hein Kleinveld

                  I had the problem when my directory was named something with a / in it.

                  • 6. Re: ERROR #2038?

                    Not sure if any of you are using a Macintosh computer - I am.


                    I had the same issue, and requesting support from OverDrive (my library's purveyor of eBooks) didn't get any sane responses. So I did some digging via Google - and voila, here's an answer that worked for me.


                    - Open up your "Documents" folder, using the Open in Finder option.

                    - Navigate to Digital Editions

                    - Make a copy of this folder with another name (that's your back-up, just in case this attempt fails)

                    - Expand the tree to show you sub-folders

                    - Navigate to the "restore" folder

                    - Expand the tree to show you sub-folders

                    - Drag ALL subfolders (the books and tasks) folders to the trash

                    - Empty trash

                    - Quit (Cmd-Q) Adobe Digital Editions

                    - Double-click on one of your file links


                    If your issue was the same as mine, you'll find that ALL books now open just fine!


                    Hope this helps!



                    • 7. Re: ERROR #2038?

                      I am having the same problem! I cannot get public library books to download to ADE. The book tries to download and then ADE error message 2038 comes up telling me to check the network connectivity....what does that mean? I tried following the suggestion of removing tasks, restore, etc. and even tried to download without my firewall to see if that was the problem...nothing works. any suggestions please? I am disabled and bought a nook so I could check out library books from home. The NOOK works great..I just can't get library books to download to the ADE!!!

                      • 8. Re: ERROR #2038?

                        I've read through your suggestion and still nothing, my message is reading a little different telling me that ADE has stop working, a problem caused it to stop working correctly window will close the program and notify me if a solution is available. This happens when I try to add books to ADE

                        • 9. Re: ERROR #2038?
                          lindab8728 Level 1

                          What version of Operating system are you using?  Are you using Windows,

                          Mac?  Have you tried to uninstall ADE completely, remove it from the

                          Registry and reinstall?

                          • 10. Re: ERROR #2038?

                            Glad I'm not the only one having problems with this! I've tried uninstalling and reinstalling ADE (most recent attempt about an hour ago). I've tried deleting the digital editions folders from my Nook to force ADE into reauthorizing it. I've tried emptying all those folders someone suggested (annotations, etc). Still no resolution. I've had this problem ever since I got my Nook and it's frustrating me since a big part of why i got the Nook was for ADE capability. I also use Netgalley.com a lot since I'm a book reviewer and it also used ADE. Every time i try to download from library OR NetGalley, it starts to download the file, then a pop up window message appears saying "verifying document." and it never advances beyond that. I have to close and reopen ADE and when I do, the "verifying document" message window comes up and of course, keeps freezin up my ADE. Help please? I am using Windows Vista. Oh yeah, and if I manage to right click ont eh partial file before the "verifying document" window comes up, it says "error 2038." An internet search on the error brought me to this forum.

                            • 11. Re: ERROR #2038?

                              If you click on it, you will see that it generates further download attempts and populates failed folder in ADE if the download fails.


                              Watch out for the partially succesful downloads: I had the problem with the book failing to open because it downloaded 1MB less the full PDF file size (it was 1MB out of 28.739 MB, so 0.004% was missing).


                              It would help if ebook sellers provided at leat files size for the book, so people could see what download size they can expect.


                              If someone has slow network and/or overloaded web filters and Antivirus checking the downloading the large book can result in failure because of timeout issues, but it should not be an issues for PDFs of even large books (the one I refered to above had 1151 pages with diagrams and screen shots and was still less the 30MB) on corporate networks in 2011.


                              When Adobe can not fix their download process or at least provide decent troubleshooting guidelines for their customers is beyond me.


                              Maybe that is why so many people strip DRM from ebooks, so they can use easily what they bought.


                              But, as they say, it is another story :-)


                              Good news is that many publishers are going away from (not very secure) DRM systems in favour of watermarking of ebooks (with visible and hidden signitures of the purchaser). Then you can use your ebook as you please and even print it if you want to.


                              Seems much better (enlightened?) approach to protecting intelectual property rights of the author and publisher.




                              frustrated ADE user

                              • 12. Re: ERROR #2038?
                                skitennis Level 1

                                Some of my posting got lost while submitting.


                                So Adobe has both upload and download issues :-)


                                The gist of what I wrote before is that I bought 5 books DRMed by ADE abd ALL had download issues.


                                I work in Computer Security, so I have full control of both my PC and firewall on it. Even shutting down the firewall (I tried all other less drastic steps first like allowing Adobe Content Server to initiate sessions etc) would not allow the download the way Adobe claims it should work.


                                It is a bug in their software and/or download script which they can not be bothered to fix.


                                However after few attempts I use the process below to download ebooks (all PDFs from CiscoPress, so I am not claiming it will work for other sites and/or file types)


                                You should go to My Digital Edition/restore folder and delete content of the failed folder and then click on the latest file in the task folder to attempt the download of the ebook.


                                In my case, the ADE window opens and the download bar increments slowly. It takes 5-15 minutes to download 20MB PDF file.


                                After download finishes, you can open the ebook in ADE.


                                After you close and open ADE again, you are asked to complete unfinished tasks. If you track it in ADE task folders, you will see that task files are deleted after each succesful download of the book.


                                So the first download kicks the previous failed downloads into life. I ended up with 5 copies of the book, I bough today.


                                I think it will only work if you succesfully downloaded the "nameofthebookyoubought.acsm" file when clicking on the download link.


                                If this acsm file is not on ypur PC, you might not be able to download. I wonder if Adobe could provide it via email to their customers?


                                Lets hope it works for you guys.




                                frustrated ADE user

                                • 13. Re: ERROR #2038?

                                  I have a Mac. After a lot of trial and error, I trashed the entire restore file as well as the the import.log and the manifest.xml Since I only use the program for library books, I had nothing to lose. Once I emptied the trash the books opened immediately.

                                  • 14. Re: ERROR #2038?

                                    MY library's ebooks won't download. Tried ALL of above solutions. Must conclude that ADE is simply a pile of ******. I use Firefox .epub add-on to read books from the Google store. Works great. Unfortunately my library (New York Public Library) unaccountably requires Adobe Digital Edition to read their ebooks. So they are effectively unavailable to me, given the shoddiness of ADE.

                                    • 15. Re: ERROR #2038?
                                      carrington1844 Level 1

                                      Don't give up yet!  I know it is frustrating because Adobe Tech wont help you with a "free" software, but somewhere along these forums (or maybe it was the Barnes and Noble site for my Nook) I found a Tech who knew what he was speaking about.  MY situation was that the library would download to Digital Editions, but ADE would not transfer the book to my Nook.  The Techie told me that ADE/library could read each other's language BUT the "proxy" server of my service provider (Hughes Net Satellite) could not read the ADE! I didn't know what any of this meant so I called Hughes Net (my service provider) and when we checked my Internet options set up, sure enough, Hughes Net was listed as my Proxy server (they told me they weren't).  When we deleted that, we checked to make sure I could still browse, etc.  and everything downloaded fine ever since.  I also made sure that my firewall was not blocking the download (its risky but I turned off the fire wall and tried to download the book) and when that made no difference, then I did the proxy thing  I tried ALL of these other suggestions, they didn't fix my particular cause of the problem and I really missed up my Nook and had to have BN do a factory Hard Restore.  So be careful about doing all of this stuff without a Techie on the end of the phone!

                                      • 16. Re: ERROR #2038?
                                        Level 4

                                        The unfortunate truth is that Adobe, has been adopted as one of the standard

                                        software suppliers to the digital document community, probably because of

                                        its preeminent position in the electronic document processing.  So, it's not

                                        unaccountable that NYPL uses ADE.  Most major epublishers do so, in part

                                        because it meets the requirements of the Digital Millenium Copyright Act of

                                        2000 by design.  NYPL would not have selected ADE if it were a 'pile of....'

                                        because its reputation rides on the transfer of materials via the software,

                                        and they're smart enough to have vetted it beforehand.  Simon & Shuster,

                                        Doubleday and others have adopted ADE also.


                                        The bottom line: it's not an inherently bad product.  And your problems are

                                        not the result of bad software - just a glitch.  That's bad enough, but you

                                        and the rest of us deserve better customer support that can get to the

                                        bottom of a problem like this and you're not getting it.  It's also possible

                                        that the error is caused by something that ADE wasn't designed to handle,

                                        and it's not ADE that's the problem.  It could be as simple as tweaking some

                                        features of your antivirus/firewall software (check the FAQ section of ADE's

                                        website for an example).  Unless you get someone who wants to and can dig

                                        into the situation, you're going to be frustrated, and you may be better off

                                        using Firefox.....



                                        • 17. Re: ERROR #2038?


                                          I am having the same problem because every time i try to download my book (on my MAC OS X version 10.6.7) i go to digital editions then i click library and then click add item to library but then when i click the book i want to download (file:///Users/bodeakin/Downloads/URLLink-8.acsm) all that pops up is URLLink-9.acsm:

                                          IO Error on local file open





                                          Event Detail:

                                          Error #2038

                                          --- end ---

                                          Does anyone of you have any idea what is going on?




                                          • 18. Re: ERROR #2038?

                                            I tried your steps of deleting tasks and fail but this did not solve the problem. I was still unable to load books to ADE.I also tried to delete the Restore folder as another user suggested. Still no luck. I have many, many books on ADE so I did not want to reinstall it or delete my book files. Luckily I found a simple solution which made this unnecessary. As I stated first I emptied the tasks and fail folders and then deleted the restore folder altogether. Then I opened digital editions and went through all of my books, deleting those with an error banner. I closed Digital Editions and re-opened it and Eureka! I can now load books. Hope this simple solution helps.

                                            • 19. Re: ERROR #2038?

                                              I am getting this dreaded error, too.


                                              I have tried all the above attempts, even called the ISP to make sure there was nothing blocking incoming or outgoing.  I've uninstalled my antivirus, firewall and turned off BitDefender. I am on WIN 7.  Everything works perfectly except ADE.


                                              I have installed and reinstalled and rebooted.  I have stopped all add ons and popups. I stopped all antimalware.  I ran ADE in admin mode.  I uninstalled it, deleted folders, etc., and went into my registry and cleared everything about ADE that I could locate.  I deactivated ADE and reactived it. I redownloaded the ACSM file numerous times.


                                              It just doesn't work.


                                              Any and all suggestions welcome.


                                              Regards, Carol

                                              • 20. Re: ERROR #2038?

                                                I was having major problems/frustrations transferring books into ADE......error messages galore. Lots of reinstalling ADE, repeated downloads of book, etc to no avail. Close to giving up and going to another laptop. But I did try suggested housecleaning of My Digital Edions file and AV disable. Suddenly, books appeared fully downloaded. Magical! Thanks!