5 Replies Latest reply on Aug 20, 2009 6:01 AM by bt-t

    ebx.etd does nothing

      Hi,

      I bought an ebook from ebooks.com in DE format. They let me download a file called ebx.etd that is supposed to make DE download the actual ebook. I've checked that the firewall (Zone Alarm) will let it through and DE is allowed Internet access, but to no avail.

      I even got more downloads from ebooks for this book, but as I open DE and download the little download program, nothing happens. Have I wasted my money??

      Five days have gone by at trial and error. Should I ask for another format?
        • 1. Re: ebx.etd does nothing
          I am having the same problem. I have only been successful twice now with this and its starting to drive me crazy. I really cannot believe its this hard. I am sick of trying to figure this out but this is the only option I have when downloading library books because I dont have mobi or anything like that.

          I keep downloading the ebx.etd file or and then it will download but then cant connect or authenticate or something nothing happens automatically either. I have to find the find on my hard drive then double click it to get it to open DE then it does as I said earlier but just says error...your ebook is broke! (well not like that but basically!) I really need some help here.

          I have tried many browsers:

          Explorer
          Google chrome
          Firefox

          all current and updated.

          SOMEONE PLEASE HELP!!!! I am getting f-r-u-s-t-r-a-t-e-d

          Thank you from a writer who needs to download her research material in order to correctly write her books!

          Kerri Erickson
          • 2. Re: ebx.etd does nothing
            Level 1
            I installed mobipocket and asked the seller to change format. It worked at once!
            • 3. Re: ebx.etd does nothing
              I've posted this on another question but I've just had the same problem and sorted it out having read http://www.winvistaclub.com/t19.html

              I went to control panel and clicked on default programs, I then clicked on "Associate a file type" and scrolled down to ".etd" I then clicked on "change program" - the association was with Adobe 8 so I clicked browse and added Adobe Digital Edition. It loaded. I then went back to my purchase and it downloaded immediately.

              I hope this helps

              Mark
              • 4. Re: ebx.etd does nothing
                VikkiMillichamp
                Hi,
                I raised the same issue on the previous thread. I have now solved the problem. Simply uninstall ADE, then move or delete (but remember to move your epub & pdf books somewhere else first!!!) the 'My Digital Editions' folder located in in 'your documents' folder.
                Then reinstall ADE. The new installation will recreate the 'My Digital Editions' folder, downloading books worked again for me.
                Thanks
                Tom
                • 5. Re: ebx.etd does nothing
                  bt-t

                  If you follow Vikki's advice I think you will solve the problem. at least I did and I could open my books. Thanks guys :-)

                   

                  http://www.alutec.no/produkter/marina/