2 Replies Latest reply on Mar 3, 2009 5:38 AM by VikkiMillichamp

    Cant download purchased books

    VikkiMillichamp
      Hi, I have upgraded to Digital Editions 1.7
      I have bought a book at waterstones online and now I can't download the book.
      I can download the ebx.etd file (the xml file with the link & licence embedded etc) but when I open or drag the .etd file into Adobe Digital Ed 1.7 nothing happens - no dialog boxes, no book appears or downloads (I've searched the computer - nothing)
      Nothing happens at all.
      I've tried uninstalling, downloding the standalone installer & installing again, but same result, I cannot download books I have paid for from Waterstones.
      Please help

      Further to above, I have now: Installed Acrobat reader 9, Flash Player 10 in case they are dependent. Cleared my IE7 temporary files, Uninstalled ADE then reinstalled it, made sure it is authorized, bought a different book from WHSmith this time! (so a new .etd file) but still nothing. I can download the .etd file, but ADE wont download the book when I open the .etd file - no messages - nothing! I have also now tried this on 2 laptops - same problem. I'm using Windows XP SP3, IE7, ADE 1.7.1079.
      This is very frustrating as I phoned Adobe & they say it is not supported as it is a free app. I phoned Waterstones but they don't know one end of a computer to another. Please help...
        • 1. Re: Cant download purchased books
          I've just had the same problem and sorted it out having read http://www.winvistaclub.com/t19.html

          I went to control panel and clicked on default programs, I then clicked on "Associate a file type" and scrolled down to ".etd" I then clicked on "change program" - the association was with Adobe 8 so I clicked browse and added Adobe Digital Edition. It loaded. I then went back to my purchase and it downloaded immediately.

          I hope this helps

          Mark
          • 2. Re: Cant download purchased books
            VikkiMillichamp Level 1
            Thanks Mark,
            I've now fixed the problem. It seems that I had a corrupt file in the 'My Digital Editions' folder in My documents folder. Once I deleted this & reinstalled ADE everything worked fine again.
            For anyone else having the same problem, this is what I did:

            Simply uninstall ADE, then move or delete (but remember to move your epub & pdf books somewhere else first!!!) the 'My Digital Editions' folder located in in 'your documents' folder.
            Then reinstall ADE. The new installation will recreate the 'My Digital Editions' folder, downloading books worked again for me.
            You can then copy your epub & pdf books back into the folder.