3 Replies Latest reply on Dec 17, 2007 6:21 PM by Arnis Gubins

    Can't display the Structure View window

    Russ Ward Level 4
      A post from Jerry Casher 12/17/07, typical of this problem:

      I'm working with FrameMaker 7.0 windows XP and for some reason can no longer display the structure view with a document open. The buttons at the upper right of the screen all work fine, except the "Display structure view" button. I've tried the shortcut also (Esc+F i v), but that doesn't work either. I've minimized the active window to see if the Structure view window is underneath it, but it is not there.
        • 1. Re: Can't display the Structure View window
          Russ Ward Level 4
          From Thomas Michanek;

          The window is probably "displayed" off the screen, due to a change in screen resolution.

          Three solutions:

          1. When you click the "display structure view" button, immediately press Alt+Spacebar followed by "M", and then hit the left or up arrow keys (don't move the mouse) until the windows starts appearing.
          This will move the active window by using the keyboard arrow keys. If the wrong window is moved, press Esc and try using Ctrl+Tab or Alt+Tab to make FM select the (invisible) structure view window. (I don't have FM running so I don't know if that will work)

          2. Close FM and open the maker.ini file in the FM installation folder. Scroll down to "[StructureView]" and change the line "Position=..." to some reasonable numbers, e.g. "Position=0, 0, 376, 272" (the order is X, Y, width, height in pixels, I think)
          Then restart FM and try again.

          3. Temporarily increase your screen resolution to its maximum, open the structure view window, move it to a better place, and change the screen resolution back.
          • 2. Re: Can't display the Structure View window
            Russ Ward Level 4
            One clarification from me... on Windows, FrameMaker maintains a duplicate maker.ini file for each user in the Documents and Settings area, under something like Application Data/Adobe/FrameMaker. Something to do with personal settings on a user-by-user basis. If the change to maker.ini in the FM installation area doesn't work, try changing this other maker.ini instead. Thomas' suggested settings would work fine, or more simply, something like:

            [StructureView]
            Position=0, 0, 500, 500

            Russ
            • 3. Re: Can't display the Structure View window
              Arnis Gubins Adobe Community Professional & MVP
              Addendum:

              The individual user-specific maker.ini files are typically located in:

              C:\Documents and Settings\[username]\Application
              Data\Adobe\FrameMaker\[version]\maker.ini

              where the [username] is your login and the [version] is the FM
              specific version on your system.