3 Replies Latest reply on May 19, 2006 8:19 AM by Newsgroup_User

    Dreamweaver pics

    Sibbs'
      I am a newbie to this website lark and I am having a problem with the graphics on my site. When I preview the site in DW the pics are there, when I look at the site on the net from my own computer the pics are there. When I look from another computer they are gone and the dreaded red X is in their place. Can anyone help me.

      Getting really hacked off with this

      Cheers
      Sibbs
        • 1. Re: Dreamweaver pivs
          Level 7
          >I am a newbie to this website lark and I am having a problem with the
          >graphics
          > on my site. When I preview the site in DW the pics are there, when I look
          > at
          > the site on the net from my own computer the pics are there. When I look
          > from
          > another computer they are gone and the dreaded red X is in their place.
          > Can
          > anyone help me.

          You likely linked your images to your hard drive:

          <img src="C:\your\folders\on\your\machine\image.gif">

          Obviously, only people that have that file saved in the exact same spot on
          their own machine would be able to load that image.

          The fix is to link to the images in relation to your site and/or relative to
          your folders:

          <img src="/your/site/folders/image.gif">

          The reason that the images are linked to your hard drive is that you
          probably were linking to images outside of your site's root folder in DW.

          -Darrel


          • 2. Re: Dreamweaver pics
            nhavfx
            What I suggest you do is...

            on any computer other than yours, right click on the missing picture, and click properties... look at the address that the site is using to searvh for the image... write it down, now check ur ftp webspace, to make sure that the photos are indeed in the same directory structure.

            The problem is that on your local machine, you can preview a site locally without having to check a online directory (webspace) however any other computer will have to ... so really its all about making sure your paths/directories are accurate for others to view (your best bet is to set the site up remotely and uploading the pages and photos straight from within dreamweaver!

            • 3. Re: Dreamweaver pivs
              Level 7
              darrel wrote:
              > You likely linked your images to your hard drive:
              >
              > <img src="C:\your\folders\on\your\machine\image.gif">
              >
              > Obviously, only people that have that file saved in the exact same spot on
              > their own machine would be able to load that image.
              >
              > The fix is to link to the images in relation to your site and/or relative to
              > your folders:
              >
              > <img src="/your/site/folders/image.gif">
              >
              > The reason that the images are linked to your hard drive is that you
              > probably were linking to images outside of your site's root folder in DW.
              >
              > -Darrel
              >
              >
              Another reason for this to happen is failing to define the site in
              Dreamweaver.

              --
              Bonnie in California
              kroko at
              pixelplum dot com
              http://www.theanimalrescuesite.com/cgi-bin/WebObjects/CTDSites.woa