3 Replies Latest reply on Nov 3, 2008 7:19 AM by Newsgroup_User

    Grouping data and mx_internal_uid

    EdwinvD
      Hi,

      I request data from a SQLite-database (AIR-application), convert the array I get this way to an ArrayCollection and try to display this as a grouped collection in an Advanced DataGrid. For some reason this does not work. If I use the AdvanceDataGrid withour grouping everything is fine. If I replicate the datastructure to an ArrayCollection I type out myself everything is also fine, including the grouping. The only difference between the ArrayCollection is that the ones that work have a mx:internal_uid added to every object. Information on this in the manuals does not help me resolve this problem.

      Anyone?

      Edwin
        • 1. Re: Grouping data and mx_internal_uid
          Level 7

          "EdwinvD" <webforumsuser@macromedia.com> wrote in message
          news:gel516$mug$1@forums.macromedia.com...
          > Hi,
          >
          > I request data from a SQLite-database (AIR-application), convert the array
          > I
          > get this way to an ArrayCollection and try to display this as a grouped
          > collection in an Advanced DataGrid. For some reason this does not work. If
          > I
          > use the AdvanceDataGrid withour grouping everything is fine. If I
          > replicate the
          > datastructure to an ArrayCollection I type out myself everything is also
          > fine,
          > including the grouping. The only difference between the ArrayCollection is
          > that
          > the ones that work have a mx:internal_uid added to every object.
          > Information on
          > this in the manuals does not help me resolve this problem.

          Implement IUID on your typed objects.

          HTH;

          Amy


          • 2. Re: Grouping data and mx_internal_uid
            EdwinvD Level 1
            Does not help. I added a mx_internal_uid to all objects in the ArrayCollection with the UIDUtil but for some reason the datagrid remains blank as soon as I want to display the ArrayCollection grouped. If I display it straight (so without any hierarchy or grouping) everything is displayed.
            • 3. Re: Grouping data and mx_internal_uid
              Level 7

              "EdwinvD" <webforumsuser@macromedia.com> wrote in message
              news:gemubl$5cr$1@forums.macromedia.com...
              > Does not help. I added a mx_internal_uid to all objects in the
              > ArrayCollection
              > with the UIDUtil but for some reason the datagrid remains blank as soon as
              > I
              > want to display the ArrayCollection grouped. If I display it straight (so
              > without any hierarchy or grouping) everything is displayed.

              Without seeing what's going on in your code, it's difficult to imagine what
              the problem is. I didn't implement IUID in my GroupingFunction example, and
              it works fine. But then again, I'm not using it with ADG.

              Have you tried displaying your grouped data in other ways to see if the
              problem is specific to ADG?