10 Replies Latest reply on Nov 11, 2008 12:49 AM by Peter Grainge

    RoboHelp acting weird--flickering hour glass

    RHGrace
      Here's a great Monday a.m. problem for you: I've imported a project from RH4Word into RH HTML. I'm now importing individual topics into a project I created in RH HTML. I opened both projects today, and the cursor appears as a pointer but, as soon as I move it, it becomes a flickering hour glass. Even stranger things happen when I try to scroll down the list of topics in the Project Manager pane...As soon as I release the left mouse button after scrolling, the cursor turns into an hour glass again, both vertical and horizontal scroll bars "flicker" (change in size, small to large to small, back and forth), and the project list goes back to the top. I cannot select a topic unless it's one of the first ten or so on the list (anything I can see without scrolling)!

      The scrolling problem only occurs with projects. I can scroll through the list of folders (Images, Multimedia, Style Sheets, etc.) just fine. These projects are large; one is about 300 topics now and the other is 1000. Is RH HTML having a problem with the project sizes? What size should the topics be? Any other ideas about what might be causing this?

      Lacona
        • 1. Re: RoboHelp acting weird--flickering hour glass
          lmarden Level 2
          it's just a hunch, but I think RH is still working through the conversion, and even though it looks like it might be ready for you to work with, it really isn't.

          I would open the project, and leave it alone for a while - let it work through the process. can't predict how long, but my project took almost an hour to convert from RH5 to RH7, and I saw the same behavior until it was done.
          • 2. Re: RoboHelp acting weird--flickering hour glass
            RHGrace Level 1
            Thanks for the idea. Unfortunately, I converted the files Thursday and worked in the projects several hours after that. I took off Friday-Sunday. Now, quite awhile after converting the files, I find the projects acting quirky.

            However, I've noticed that the converted project seems more unstable than the other one. If I close that project, the new project seems okay. I hope it continues to act well, even if I import most of the topics from the unstable project.

            I know there is a limit to number of topics in RH4Word. Is there one in RH HTML also? Or a file size limit?
            • 3. Re: RoboHelp acting weird--flickering hour glass
              RoboColum(n) Level 5
              Hi Lacona.

              There is no limit to the size of a project as so much depends on the content. I had a project that was over 2000 topics and contained fairly normal content that operated perfectly. Another had only 500 topics but loads of links and DHTML and was an absolute pig to work on. Other factors can also come into play. If you are having problems you may want to try splitting the large project into two and see if that makes a difference.
              • 4. Re: RoboHelp acting weird--flickering hour glass
                jimpr
                I have been having this problem for the last week with two of our projects. This has also happened previously in the last two months. I really believe for us the problem started when we decided to use RoboSource so two of us can work on the same project. RoboSource is not too great and caused us to loose work and have crashes a lot. Anyway, after we were convinced that the problem was RoboSource, we removed the projects from RS control. This created a new set of problems because RS did not release all the files.

                Long story short, with the projects out of RS, we had issues ranging from a project taking up to 30 minutes to load or not load at all, to once loaded every time you move the mouse the pointer turned into an hour glass and nothing could be worked on. Usually forcing us to Force Quit RoboHelp.

                After weeks of searching for solutions and not finding any, and weeks attempting to replace backed up files like the XPJ file and others. If we were lucky, we would leave it with the hour glass overnight and it might start working the next day. But after a few days the problem came back.

                Yesterday it occurred to me that it looked like the project opened but the hour glass was probably because it was looking for files it couldn't find. So I had this bright idea. I made a backup copy of the XPJ file and then I opened it using the Windows Notepad application. I noticed that the XPJ file called for 20 RH specific files to open. I checked to see if all these 20 files were available on the project folder. I found 17 of them but there was three that did not exist in the project folder. So I removed the lines asking for the three missing files and then closed and saved it. IF YOU DON'T KNOW WHAT YOU ARE DOING I WOULD NOT RECOMMEND DELETING ANYTHING FROM THESE FILES!!! YOU MUST BE SURE YOU ARE NOT ERASING IMPORTANT INFO.

                After closing and saving the file I opened the project again, it loaded in 45 seconds and it did the hourglass for about a minute or two, which I think it was updating the files. Then the hourglass went away and never came back. I closed the project and opened it again to confirm that it would work properly. It opened in 34 seconds and no hourglass came up to delay anything. The issue is now gone on all our projects and they are working better than ever.

                I hope this helps anyone having this problem. REMEMBER TO BACKUP THE PROJECT BEFORE ATTEMPTING THIS...just in case it doesn't work as good for you...I only know of me doing this...
                • 5. Re: RoboHelp acting weird--flickering hour glass
                  jimpr Level 1
                  I posted the previous solution suggestion but i wanted to add one more point. The project I mentioned above is a very large project that has close to 550 topics and about another 500 graphics. So I don't think the size was the problem.
                  • 6. Re: RoboHelp acting weird--flickering hour glass
                    Peter Grainge Adobe Community Professional (Moderator)
                    jimpr

                    The only danger I see in that is RH uses those files to rebuild the CPD if you ever have to trash it. It might be those files have been created at that point but if excluded from the XPJ it could be RH does not recognise them.

                    For what it is worth, I have 21 files listed but only 17 in the project and it works without issue. The project has 4,000 files.

                    My thinking is this was more to do with source control.

                    Are you checking the XPJ in? You shouldn't.

                    • 7. Re: RoboHelp acting weird--flickering hour glass
                      jimpr Level 1
                      No I didn't have to check-in the XPJ file. RoboSource was a total disaster for us so i'm glad we don't use it anymore. I have no idea what made the difference on editing the XPJ file. All I know it's the only thing that made the projects work right and are still working beautifully was editing that XPJ file. I do have a backup for that file just in case. The lines that were removed called for rhextern.apj, rhframeset.apj and rhmhelp.apj. I wonder why this made a difference? I don't know much to figure it out...all I know is after attempting so many other fixes, this one did it immediately.
                      • 8. Re: RoboHelp acting weird--flickering hour glass
                        Amebr-ke0mH4 Level 2
                        Hi Peter,

                        Can you clarify why you don't think the xpj should be in source control?

                        Amber
                        • 9. RoboHelp acting weird--flickering hour glass
                          way_knot_tower
                          I had the same problem start up on me this week. Try jumping from the Design view to HTML in any topic. Click in there anywhere and then go back to Design. This got rid of my flickering hour glass. Hopefully it won't come back tomorrow!
                          • 10. Re: RoboHelp acting weird--flickering hour glass
                            Peter Grainge Adobe Community Professional (Moderator)
                            Amebr

                            I need to correct myself. Sometime back MergeThis posted a list of files that don't need to be checked in. As you can see, it does not include the XPJ. Sorry.

                            CPD
                            LDB
                            HHP
                            PSS