2 Replies Latest reply on Oct 30, 2008 12:21 PM by Reed Powell

    CFCHART & Developer Edition Watermark

    Reed Powell Level 3
      [This might sound similar to postingings for CFDOCUMENT, but it's not]

      I have servers that were originally installed with the trial edition of CF8 and
      then changed to standard edition by entering our valid license numbers within the
      30 day period. That all worked fine, and the edition changed from Enterprise to
      Standard.

      At the time we hadn't been doing much with CFCHART, although we did have one page
      in production with a CFCHART on it. We've recently started doing development of
      more charting pages, using both the CFCHART tag directly as well as using
      calls via Java to the underlying engine so that we can get the more advanced
      charts.

      All of the charts are coming out with the "Adobe ColdFusion 8 Developer Edition Not
      for Production Use" watermark on them. Note that this is not from the
      ColdFusion8\lib\watermark.png file because that image's content says "Adobe
      ColdFusion Developer/Trial Edition Not for Production Use". So this is being
      triggered from somewhere else. The first question is "where & why?" but the more
      important second question is "how do I fix this?"

      I did a clean install where I entered the SN on the installation screen (instead
      of letting it start out as a Trial Edition) on a PC that has never had CF on it,
      ran my CFCHART script, and it DID NOT have the watermark.

      Here's more info: On that PC that I did the fresh install of CF8, I was able to
      run my script with "standard" CFCHARTs in it just fine. As soon as I ran the
      FIRST script that did calls to the java objects to create undocumented Webcharts
      charts, the watermark began showing up not only on those charts, but also on all
      charts that are generated from the "standard" CFCHART tags. Apparently the
      Webcharts engine thinks that I have violated the license, and is somehow tracking
      that fact across restarts, reboots, etc. I reinstalled CF on that test PC, and the watermark went away, but
      reinstalling on the production servers is a lot more hassle.

      I ran a directory/file compare utility (ADCS) against the clean test PC and one of the unclean servers, for the entire ColdFusion8 directory tree, but nothing jumped out.

      I've searched through the Registry, cannot find any tracks there. Cannot find
      any files with new dates on them.

      Any ideas?

      This is getting to be a hassle, because I have pages that clients see on the
      server where I first noticed this problem, and don't want them thinking that I'm
      running bootleg software!

      thanks everyone,
      Reed