6 Replies Latest reply on Aug 20, 2007 5:43 AM by (Stefan_Schneifer)

    License Manager won't start

      After some hunting I found this error in the debug log:

      2007-02-05 15:18:07,326 DEBUG [agent.actions] [PoolThread-8] In BaseAction.getEvent() : Event to be performed is :start
      2007-02-05 15:18:07,326 DEBUG [agent.actions] [PoolThread-8] In SystemConfigAction.localExecute : Event to be handled is : start
      2007-02-05 15:18:07,326 DEBUG [flexnet.agent] [PoolThread-8] Discovering license servers
      2007-02-05 15:18:07,326 DEBUG [flexnet.agent] [PoolThread-8] Discovering license server: NPU - Adobe Licensing Server
      2007-02-05 15:18:09,607 FATAL [agent.actions] [PoolThread-8] SystemConfigAction.start() : Unableto start the license server :
      java.rmi.RemoteException: This FLEXnet Agent supports more than one license server. Some license server(s) use default port number "ANY". Please change them to other port numbers.
      at com.macrovision.flexnet.agent.Licens eDiscovery.getLmgrdInfo(LicenseDiscovery .java:1860)
      at com.macrovision.flexnet.agent.Licens eDiscovery.createLicenseServer(LicenseDi scovery.java:557)
      at com.macrovision.flexnet.agent.Licens eDiscovery.discoverLicenseServers(Licens eDiscovery.java:439)
      at com.macrovision.flexnet.web.agent.ac tions.SystemConfigAction.start(SystemCon figAction.java:471)
      at com.macrovision.flexnet.web.agent.ac tions.SystemConfigAction.localExecute(Sy stemConfigAction.java:88)
      at com.macrovision.flexnet.web.agent.ac tions.BaseAction.execute(BaseAction.java :77)
      at org.apache.struts.action.RequestProc essor.processActionPerform(RequestProces sor.java:484)
      at org.apache.struts.action.RequestProc essor.process(RequestProcessor.java:274)
      at org.apache.struts.action.ActionServl et.process(ActionServlet.java:1482)
      at org.apache.struts.action.ActionServl et.doPost(ActionServlet.java:525)
      at javax.servlet.http.HttpServlet.servi ce(HttpServlet.java:760)
      at javax.servlet.http.HttpServlet.servi ce(HttpServlet.java:853)
      at org.mortbay.jetty.servlet.ServletHol der.handle(ServletHolder.java:358)
      at org.mortbay.jetty.servlet.WebApplica tionHandler$Chain.doFilter(WebApplicatio nHandler.java:342)
      at com.macrovision.flexnet.web.platform .filters.SetCharacterEncodingFilter.doFi lter(SetCharacterEncodingFilter.java:108 )
      at org.mortbay.jetty.servlet.WebApplica tionHandler$Chain.doFilter(WebApplicatio nHandler.java:334)
      at org.mortbay.jetty.servlet.WebApplica tionHandler.dispatch(WebApplicationHandl er.java:286)
      at org.mortbay.jetty.servlet.ServletHan dler.handle(ServletHandler.java:567)
      at org.mortbay.http.HttpContext.handle( HttpContext.java:1807)
      at org.mortbay.jetty.servlet.WebApplica tionContext.handle(WebApplicationContext .java:525)
      at org.mortbay.http.HttpContext.handle( HttpContext.java:1757)
      at org.mortbay.jetty.plus.PlusWebAppCon text.handle(PlusWebAppContext.java:218)
      at org.mortbay.http.HttpServer.service( HttpServer.java:879)
      at org.mortbay.http.HttpConnection.serv ice(HttpConnection.java:790)
      at org.mortbay.http.HttpConnection.hand leNext(HttpConnection.java:961)
      at org.mortbay.http.HttpConnection.hand le(HttpConnection.java:807)
      at org.mortbay.http.SocketListener.hand leConnection(SocketListener.java:197)
      at org.mortbay.util.ThreadedServer.hand le(ThreadedServer.java:276)
      at org.mortbay.util.ThreadPool$PoolThre ad.run(ThreadPool.java:511)

      WTF does this mean? Docs don't cover this? Thought the product mapping file might provide more info, but it doesn't seem to exist?

      Is this some half baked product or what?
        • 1. Re: License Manager won't start
          Level 1
          Mr. Gurtz,

          According to the log:

          "2007-02-05 15:18:09,607 FATAL [agent.actions] [PoolThread-8] SystemConfigAction.start() : Unableto start the license server :
          java.rmi.RemoteException: This FLEXnet Agent supports more than one license server. Some license server(s) use default port number "ANY". Please change them to other port numbers."

          It seems you already have a FLEXnet server already running on your machine. Can you verify that this is the case? One way to verify is to go to the directory where the License Server is installed (the default is "C:\Program Files\Adobe\License Server Tools\bin") and type "lmutil lmdown". This will list all the vendor daemons that are currently running on your machine. If you already have a FLEXnet license server running, note the port number. Macrovision FLEXnet by default uses port 27000-20009, so if you have more than one vendor daemon running one one machine, you should explicitly declare a port for each vendor daemon (so there won't be a port conflict). Page 8 of the Server Tools user guide explains how to do this.
          • 2. Re: License Manager won't start
            Level 1
            Once you get it running you might want to see your license usage. We use License Statistics for our other products: http://www.x-formation.com/license_statistics/index.html

            Good luck!
            • 3. Re: License Manager won't start
              Level 1
              Oh great we have a ******* spamming a support forum with his commercial product.

              Let's keep marketing in the marketing channels please.

              After spending about 45min being transfered around I finally got on the phone with a tech. After over an hour on the phone with him we were unable to get any farther. It is indeed a conflict problem with the license manager from esri corp. (also the macrovision product) We tried all manner of changing ports in the adobe license manager but it still won't work.

              It seems like it would be helpful to get Macrovision support on the phone since it seems like the adobe implementation doesn't "take" manually entered port numbers. I'm sure they won't talk to me since I'm just an end user but I'm sure they would talk to adobe support or development.

              I'm not sure if I'll waste more time working on this since my copy of Acrobat seemed to download some type of "grace" activation or something. At least I can view PDFs now and do my job. I can guarantee no one else at this Co. will be getting 8 until this gets some radical help.
              • 4. Re: License Manager won't start
                It appears from the log, Adobe Console is not able to communicate with the Adobe License Server, because it detects two or more Flexnet/Flexlm license servers are running. The solution is to run flexlm servers on fixed ports.
                For example, to run Adobe License Server on fixed port say 27000, modify adobe.lic file. First stop the Adobe License service, Open the adobe.lic file in notepad (any text editor) and change the first line to SERVER this_host ANY 27000. Save and close the file and start the Adobe License Service.
                Similarly, you may specifiy the fixed port in other flexlm servers. Adobe Console by default assumes the license server is running on default ports i.e. 27000-27009, you may specify the license server port where the Console should talk to the Adobe License Server (via Admin Tab->License Server configuration web page).
                • 5. Re: License Manager won't start
                  Level 1
                  thanks...
                  http://www.economycard.net
                  http://www.5579021.com
                  http://www.kurtoglunakliyat.com
                  • 6. Re: License Manager won't start
                    Level 1
                    Yes it seems that the console is unable to get to the right server. As pointed out you should likely see if the configuration is correct.

                    ---
                    Stefan

                    Track your flexlm licenses with License Statistics and reduce your costs.

                    Protect your software with LM-X License Manager.