27 Replies Latest reply on May 10, 2010 10:32 AM by ron.touchstone

    EPIC_APP Error on Startup

    Jeremy TMCC Level 1
      I used the Adobe 8 Customization Wizard to create a transform for our college so that I can get a silent install with the Serial No. pre populated. I used the files I received via the FTP site for the Opt-out option. The install is pushed via Zenworks without error. Every time I run the app though after about 5 seconds I get an EPIC_APP error and it closes. I keep thinking it has something to do with the Opt-Out, but that is just a guess. I checked the XML file and the one on the hard drive seems to be the correct one.

      If I manually install via setup.exe everything seems to work just fine, but pushing via Zenworks with only the acropro.msi has worked before in previous versions. The push I created for Reader 8 works with no problems whatever.
        • 1. Re: EPIC_APP Error on Startup
          Hi Jeremy,

          It doesn't sound like an ALM-specific issue since everything works fine when running the installer via setup.exe. You should check http://www.adobe.com/products/acrobat/solutions/it/ for specific information regarding deploying Acrobat within your enterprise and contact technical support if this information is insufficient.

          Best,

          -Marcel
          • 2. Re: EPIC_APP Error on Startup
            Hi Jeremy

            I want you to know that I suffer the same. Deploying Adobe Acrobat 8.0 Professional using ZENworks 4.01.
            I'm always getting the EPIC_APP error!

            Any news about that?

            Thanks
            Roland
            • 3. Re: EPIC_APP Error on Startup
              Jeremy TMCC Level 1
              Still not working for me. I even created a Zen Push that simply pushes the AcroPro.msi and nothing else. I still get EPIC_APP error on run. Though after the License Agreement page. Interesting thing is that on a hand install the next page after the License Agreement is the E-License page.
              • 4. Re: EPIC_APP Error on Startup
                Hi Jeremy,

                Does Acrobat run okay after getting EPIC_APP error?
                • 5. Re: EPIC_APP Error on Startup
                  Jeremy TMCC Level 1
                  No. it closes. If I run it again it stays open for about 5 seconds before the same error appears.
                  • 6. Re: EPIC_APP Error on Startup
                    Hey,
                    Does anyone have any solution to the problem with the Epic App error?

                    /Gustav
                    • 7. Re: EPIC_APP Error on Startup
                      I am running ZEN 7 and getting this error. The only way I can get the app installed is to be logged in as a user that has admintrator rights to the local machine. (Not really a solution for my environment!)
                      • 8. Re: EPIC_APP Error on Startup
                        My guess is the application is trying to update a registry key to which it does not have sufficient rights. I would suggest running Regmon to identify what it's trying to do, and either modifying the msi to apply the right permissions to those keys, or deploying a new app object to account for that if you're not comfortable with modifying the msi.

                        Let me know how it turns out.

                        BMV
                        • 9. Re: EPIC_APP Error on Startup
                          Level 1
                          It turns out it's not registry permissions, but...

                          If you are using user extensible policies, you need to add FNPLicensingService.exe to the list of "Only run allowed Windows applications". The application is trying to launch this executable for the licensing process and it doesn't have the proper security context.

                          BMV
                          • 10. Re: EPIC_APP Error on Startup
                            The same for me, using ZEN 7 SP1. Trying to distribute Acrobat 8 Professional Corporate License as MSI-Installation with MST file.
                            When installing with local administrator rights it runs fine. Without there is the EPIC_APP error.
                            Furthermore, when I try to start Acrobat Distiller I'm getting "Acrobat Distiller cannot continue because Acrobat is not activated".

                            But: When I login with a local administrator after the distribution and then start the applications, these errors are gone for all users on this machine.

                            So it seems to be a permission problem while processing activation data. For testing purposes I gave everyone full access to folder "%PROGRAMFILES%\Adobe" and registry "HKLM\SOFTWARE\Adobe" after the installation but without success, the error remains.

                            Still no solution.
                            • 11. Re: EPIC_APP Error on Startup
                              Level 1
                              Does Acrobat run okay after getting EPIC_APP error?
                              http://www.economycard.net
                              http://www.5579021.com
                              http://www.kurtoglunakliyat.com
                              bys
                              • 12. Re: EPIC_APP Error on Startup
                                Level 1
                                No, after confirming the EPIC_APP window, the application closes.
                                • 13. Re: EPIC_APP Error on Startup
                                  I used CustWiz.exe from ADOBE to create a MST and for the things I couldn't do with this tools I then modyfied the MST with WISE Package Studio (or some thing else).

                                  For Softwaredistribution and -installation on the WXP-Clients we are using SMS 2003 and if I install the MST with Userrights I had the same problem with EPIC_APP. But if I install in a other Context, e.g. Adminrights, all works fine!
                                  • 14. Re: EPIC_APP Error on Startup
                                    Level 1
                                    Found a solution for ZENworks 7, SP1:

                                    Do not import the MSI into Zenworks. Instead create an unattended setup with the Adobe Customization Wizard and in ZENworks create a simple application which only runs [PathToYourSetupFiles]\Setup.exe as secured or unsecured systemuser. Do not forget to check for system requirements (e.g. WinXP SP2 and ~1400 harddisk space for Acrobat Professional) in the availability tab in ZENworks.
                                    • 15. Re: EPIC_APP Error on Startup
                                      did anyone find a solution to this issue?
                                      • 16. Re: EPIC_APP Error on Startup
                                        Level 1
                                        The application needs write/modify access to the mpr folder deployed by the msi and also to shell32.dll in the system folder during the launching of the application in order to extract the licensing support files. Assigning rights to the shell32.dll is a bit tricky being it is a protected file and changing the rights to its copy in the dllcache folder doesn't do the trick because the file does not need repair - only the permissions on it change.

                                        There are several ways one can approach this. You could create a run once registry key or a custom action which deletes the initial shell32.ddl and apply the permissions to the one in dllcache and that would ensure self healing. However, you'd probably want another custom action to reset the permissions afterwards to leave the file protected after it extracts the licensing files.

                                        Alternatively, although I have not tested this solutions yet, you could package the process during the first time the application launches to the point it presents you with the first licensing screen and include the respective files and registry changes in the vendor's msi, or create a chained msi application object to run after the vendor's.
                                        • 17. Re: EPIC_APP Error on Startup
                                          I've been struggling with this. The way I got round it was to set Zenworks to launch a .cmd script as an unsecure user which installs Acrobat then runs it, so that the first time it's launched it can make the changes needed. When the user runs it in future they don't get the EPIC_APP error message.
                                          • 18. Re: EPIC_APP Error on Startup
                                            I've had the same problem with this error and I've tried un-installing and re installing which didn't work, i've tried installing version 7 again which didn't work either....I've read through these messages and not being a computer buff myself I'm still unsure of how to solve it? or whether anyone else has managed it? any ideas or solutions would be greatly appreciated!

                                            Thanks
                                            • 19. Re: EPIC_APP Error on Startup
                                              The exact same problem existed for Symantec, leading me to believe that there is more than one connection between the licensing and installation procedures of Acrobat and other Adobe products and Symantec products.

                                              Allowing Adobe code to operate outside of a protected environment periodically permits short-term use. However, over the space of two weeks (and seven weeks or so for Symantec), these programs did not run without licensing problems no matter how many licenses I own.

                                              I run Vista 64 bit, and originally excluded both DEP and UAC in order to complete the Acrobat 8 installation after getting my first EPIC license error. The error did not include until I tried a trial version of CS3.

                                              I signed off of another forum because I thought I had cured the problem, but am again getting the same EPIC error due to other factors.

                                              This should be approached much more directly with Adobe, and hopefully some of you have done so. Unfortunately, the response of Symantec support was eventually to give me some of my money back. While there are many other security solutions, including some interesting beta solutions, I cannot give up Acrobat 8.

                                              Incredibly, despite the fact that these problems are clearly licensing based problems, one response to this issue was that licensing was too complex and most did not understand it. I believe that licensing is the bedrock of this problem, and that the software used by two or more software vendors is not doing the right job, violating everyone's licensed rights.
                                              • 20. Re: EPIC_APP Error on Startup
                                                this message shows that your adobe products havn't been activated.
                                                • 21. Re: EPIC_APP Error on Startup
                                                  Found a solution in Vista.

                                                  No need to reinstall, just locate the acrobat.exe file, and run as administrator at least once, so it can "activate" the license. After that it all works.
                                                  • 22. Re: EPIC_APP Error on Startup
                                                    Hey,

                                                    I am trying to solve the above mentioned problem for a client of mine as well.

                                                    The install was completed with the MSI from the local PC logged in as a Local Admin.

                                                    Install completed ok, all apps in CS3 run ok apart from Acrobat.exe
                                                    Remoted in this morning, ran the acrobat.exe as a domain admin. To my dismay the error still occurs.

                                                    Ive also reinstalled the entire suite with no luck.

                                                    This is on XP Pro by the way.
                                                    Any help would be appreciated.
                                                    • 23. Re: EPIC_APP Error on Startup
                                                      Hi There I do get the same error but it is on a stand alone pc with no network connection or internet connection any suggestions on fixing this problem at home?
                                                      Thanks a mill
                                                      • 24. Re: EPIC_APP Error on Startup
                                                        I got the same problem as Jeremy's(for Acrobat8 Pro). And I don't want to correct the problem manually by visiting each machine(suggested by Tariq), since we're in an enterprise environment. Is there anything we can do on the zen application object to fix the problem? I thought by checking "unsecured system user" would be the solution, but apparently not.
                                                        Any help would be greatly appreciated.
                                                        • 25. Re: EPIC_APP Error on Startup
                                                          I received this Epic_App error on a home network running Windows Vista Ultimate and Adobe CS3 Web Premium. I also was unable to open any of the other Adobe apps - I got an error that said "Licencing for this product has stopped working". I called Adobe Technical Support and now everything is working. The solution was to open Services (Run > services.msc), locate FLEXnet Licensing Service (startup type was "Disabled") double click on it to open the dialog and change startup to "Manual".
                                                          • 26. Re: EPIC_APP Error on Startup
                                                            Yo listen up,

                                                            Using the Mary Hardy solution provides no joy here. FLEXnet was already set to Manual. The problem still exists.

                                                            Note: http://www.adobe.com/support/downloads/detail.jsp?ftpID=3750

                                                            Went there, did that, rebooted and the problem STILL EXISTS.
                                                            • 27. Re: EPIC_APP Error on Startup
                                                              ron.touchstone

                                                              That's a great answer Mr. Wizard, but HOW DO YOU DO THAT?