5 Replies Latest reply on Feb 22, 2013 3:44 AM by Telemam

    Error Converting PDF to TIFF

    Level 1
      I'm trying to use the toImage service in Common/Convert PDF and I'm getting errors saying my input PDF is not flattened. So, I added a transformPDF step before my toImage. When I write the output from the transformPDF step to the file system and open it with reader it seems to be flattened (i.e. no fields everything is static). However, when I take that output and run it through the toImage service I still get this exception:

      com.adobe.livecycle.convertpdfservice.exception.ConvertPdfException: Input Document is not a flattened PDF Document

      Anybody have any ideas how to get this conversion to work?

      Thanks,
      Bryan
        • 1. Re: Error Converting PDF to TIFF
          Level 1
          Are you invoking this operation through an API call or using a process defined in Workbench ES?
          • 2. Re: Error Converting PDF to TIFF
            Level 1
            Through a process in workbench.
            • 3. Re: Error Converting PDF to TIFF
              Level 1
              I have the same issue, except that I'm trying to convert to a PostScript file. I need a PS file because the printer can only print PS or PCL.

              Does anyone have any suggestion? If it's a known issue in Beta, then will it be fixed in the release version?
              • 4. Re: Error Converting PDF to TIFF
                Level 1
                If you are trying to print - you should use the Output service. It supports printing workflows. You can create a PostScript or a PCL print stream. These other issues seem like Beta issues because there is no problem with converting a PDF to an image.
                • 5. Re: Error Converting PDF to TIFF
                  Telemam

                  Hi we were having the same problem. The errors were randomly, so it wasn't from one specific file or files. Although the sizes of the TIFF files were large, but we had done this before with three times the size and number of TIFF files. I suspected it might be some of the TIFF files, so I started randomly to open the TIFF files in Photoshop and save and replace the old ones. ( didn't make any changes, just Save AS).. The files were 160, so I wasn't about to do the whole thing, so I did the first 10 set, somewhere in the middle, some of the large files and the last 6 files.. I tried the Acrobat Combine files, and IT worked..  I suspected some kind of glitch in the TIFF files, something similar to trying to open a tiff file in Photoshop and you get an error and when you open it from another computer with a different application it works, and when you save it, then you can open it in Photoshop..  Try it, I hope it works with you guy, and maybe Adobe support can look into this and let us know the reason..