1 Reply Latest reply on Aug 7, 2009 12:28 AM by Ward_Loockx

    [Flex] RTMP-Server on port: 2038 failed to start up.

      Hello. I looked everywhere and i couldn't find any solution for my problem. I installed LiveCycle Data Services ES with J2EE and i have a flex application that use only the messaging part.<br />Everything works great until the lcds crash down. In the lcds.log I get the next errors:<br />[Flex] RTMP-Server on port: 2038 failed to start up.<br />java.io.IOException: Too many open files<br />     at sun.nio.ch.ServerSocketChannelImpl.accept0(Native Method)<br />     at sun.nio.ch.ServerSocketChannelImpl.accept(Unknown Source)<br />     at flex.messaging.endpoints.rtmp.BaseNIORTMPServer.run(BaseNIORTMPServer.java:276)<br />     at java.lang.Thread.run(Unknown Source)<br /><br />flex.messaging.endpoints.rtmp.RTMPException: The RTMP server has encountered a fatal exception starting up: Too many open files<br />     at flex.messaging.endpoints.rtmp.BaseNIORTMPServer.run(BaseNIORTMPServer.java:317)<br />     at java.lang.Thread.run(Unknown Source)<br />Caused by: java.io.IOException: Too many open files<br />     at sun.nio.ch.ServerSocketChannelImpl.accept0(Native Method)<br />     at sun.nio.ch.ServerSocketChannelImpl.accept(Unknown Source)<br />     at flex.messaging.endpoints.rtmp.BaseNIORTMPServer.run(BaseNIORTMPServer.java:276)<br />     ... 1 more<br />10/23 18:40:10 error Too many open files<br />java.net.SocketException: Too many open files<br />     at java.net.PlainSocketImpl.socketAccept(Native Method)<br />     at java.net.PlainSocketImpl.accept(Unknown Source)<br />     at java.net.ServerSocket.implAccept(Unknown Source)<br />     at java.net.ServerSocket.accept(Unknown Source)<br />     at jrun.servlet.network.NetworkService.accept(NetworkService.java:356)<br />     at jrun.servlet.http.WebService.createRunnable(WebService.java:104)<br />     at jrunx.scheduler.ThreadPool$ThreadThrottle.createRunnable(ThreadPool.java:349)<br />     at jrunx.scheduler.WorkerThread.run(WorkerThread.java:62)<br /><br />10/23 18:40:10 error <br />java.lang.NullPointerException<br />     at jrun.servlet.file.FileServlet.format(FileServlet.java:570)<br />     at jrun.servlet.file.FileServlet.processDirectory(FileServlet.java:406)<br />     at jrun.servlet.file.FileServlet.service(FileServlet.java:343)<br />     at jrun.servlet.ServletInvoker.invoke(ServletInvoker.java:91)<br />     at jrun.servlet.JRunInvokerChain.invokeNext(JRunInvokerChain.java:42)<br />     at jrun.servlet.JRunRequestDispatcher.invoke(JRunRequestDispatcher.java:259)<br />     at jrun.servlet.ServletEngineService.dispatch(ServletEngineService.java:541)<br />     at jrun.servlet.http.WebService.invokeRunnable(WebService.java:172)<br />     at jrunx.scheduler.ThreadPool$ThreadThrottle.invokeRunnable(ThreadPool.java:428)<br />     at jrunx.scheduler.WorkerThread.run(WorkerThread.java:66)<br /><br />10/23 18:40:10 error Too many open files<br />java.net.SocketException: Too many open files<br />     at java.net.PlainSocketImpl.socketAccept(Native Method)<br />     at java.net.PlainSocketImpl.accept(Unknown Source)<br />     at java.net.ServerSocket.implAccept(Unknown Source)<br />     at java.net.ServerSocket.accept(Unknown Source)<br />     at jrun.servlet.network.NetworkService.accept(NetworkService.java:356)<br />     at jrun.servlet.http.WebService.createRunnable(WebService.java:104)<br />     at jrunx.scheduler.ThreadPool$ThreadThrottle.createRunnable(ThreadPool.java:349)<br />     at jrunx.scheduler.WorkerThread.run(WorkerThread.java:62) <br /><br />The last error it repeats over and over again. I tried the same application on tomcat, the same thing happen. Is there any settings that I made in the application that crash LCDS? <br />If I restart LCDS it's working, but after a while it happens again. <br />My messaging-config.xml looks like this:<br /><br />     <adapters><br />             <adapter-definition id="actionscript" class="flex.messaging.services.messaging.adapters.ActionScriptAdapter" /><br />           </adapters><br /><br />     <destination id="commands"><br /><br />             <properties><br />                      <network><br />                          <session-timeout>0</session-timeout><br />                     </network><br /><br />                      <server><br />                          <max-cache-size>1000</max-cache-size><br />                          <message-time-to-live>0</message-time-to-live><br />                          <durable>false</durable><br />                          <allow-subtopics>true</allow-subtopics>