1 Reply Latest reply on Jul 28, 2007 12:18 PM by Peter Farland

    anyone success?

      i read the article in(http://www.adobe.com/devnet/flex/articles/intro_fms.html)<br /><br />i try my best to fulfill subscribe&producer messaging,but<br />i got error like below:<br /><br />[Error: (mx.messaging.messages::ErrorMessage)#0<br />  body = (Object)#1<br />  clientId = (null)<br />  correlationId = "4221D052-7C52-65EA-57A5-0DFE13BFA45A"<br />  destination = ""<br />  extendedData = (null)<br />  faultCode = "Client.Error.MessageSend"<br />  faultDetail = "Channel.Connect.Failed error undefined url:'rtmp://localhost:2038'"<br />  faultString = "Send failed"<br />  headers = (Object)#2<br />  messageId = "FC9D68EA-9C92-BCEE-AAD0-0DFE1E1FFC91"<br />  rootCause = (Object)#3<br />    code = "NetConnection.Connect.Failed"<br />    level = "error"<br />  timestamp = 0<br />  timeToLive = 0]<br /><br />i add message services config.xml with:<br /><br /><!-- In the MessageService destination configuration file: --><br /><destination id="MyTopic"><br />    <!-- other destination properties snipped --><br />          <properties><br />            <server><br />                <durable>false</durable><br />            </server><br />        </properties><br />        <channels><br />            <channel ref="my-rtmp"/><br />        </channels><br /></destination><br /><br />anyone know what's wrong with the error? how to correct it,plz help.
        • 1. Re: anyone success?
          Peter Farland Level 3
          I'd check the server logs (or simply the server console depending on how
          you started the app server) for configuration errors.

          Remember that RTMP ports must be unique across all web applications deployed
          on a server.

          Did you remember to compile with the mxmlc command line argument -services
          pointing to your /WEB-INF/flex/services-config.xml file?