3 Replies Latest reply on Nov 13, 2008 6:56 PM by Newsgroup_User

    CircleItemRenderer & seriesInterpolate in LineSeries Chart.

    Sailor_Sea
      Hi everyone,
      my itemRenderer="mx.charts.renderers.CircleItemRenderer" is disabled when I add a seriesInterpolate effect to my chart... Any reason why this happens??

      Thanks.
        • 1. Re: CircleItemRenderer & seriesInterpolate in LineSeries Chart.
          Level 7

          "Sailor_Sea" <webforumsuser@macromedia.com> wrote in message
          news:gfhg45$8sf$1@forums.macromedia.com...
          > Hi everyone,
          > my itemRenderer="mx.charts.renderers.CircleItemRenderer" is disabled when
          > I add a seriesInterpolate effect to my chart... Any reason why this
          > happens??
          >

          Works fine for me...


          • 2. Re: CircleItemRenderer &amp; seriesInterpolate in LineSeries Chart.
            Sailor_Sea Level 1
            I attached my script. My CircleItemRenderer and DiamondItemRenderer disappear when I and the seriesInterpolate.
            Can you tell if I have something wrong with my code?

            Thanks

            -David
            • 3. Re: CircleItemRenderer &amp; seriesInterpolate in LineSeries Chart.
              Level 7

              "Sailor_Sea" <webforumsuser@macromedia.com> wrote in message
              news:gfi1fr$2dg$1@forums.macromedia.com...
              >I attached my script. My CircleItemRenderer and DiamondItemRenderer
              >disappear
              > when I and the seriesInterpolate.
              > Can you tell if I have something wrong with my code?
              >
              > Thanks
              >
              > -David
              >
              > <mx:SeriesInterpolate id="seriesInterpolate" duration="1500"/>
              >
              > <mx:ColumnChart id="CC_Panel_SonRes" type="overlaid"
              > dataProvider="{test}">
              >
              > <mx:horizontalAxis>
              > <mx:CategoryAxis id="H_Panel_SonRes" dataProvider="{test}"
              > categoryField="test"/>
              > </mx:horizontalAxis>
              >
              > <mx:horizontalAxisRenderers>
              > <mx:AxisRenderer placement="bottom" axis="{test}"/>
              > </mx:horizontalAxisRenderers>

              The axis property of the AxisRenderer should be referring to an axis, such
              as H_Panel_SonRes.



              > <mx:series>
              >
              > <mx:ColumnSeries showDataEffect="{seriesInterpolate}" yField="test001"/>
              >
              >
              > <mx:ColumnSeries showDataEffect="{seriesInterpolate}" yField="test002"/>
              >
              >
              > <mx:LineSeries showDataEffect="{seriesInterpolate}"
              > itemRenderer="mx.charts.renderers.CircleItemRenderer" yField="test003"/>
              >
              > <mx:LineSeries showDataEffect="{seriesInterpolate}"
              > itemRenderer="mx.charts.renderers.CircleItemRenderer" yField="test004"/>
              >
              > </mx:series>
              > </mx:ColumnChart>

              I set the interpolation and itemRenderers on my charts in actionscript, but
              the above looks right.

              HTH;

              Amy