1 Reply Latest reply on May 7, 2008 1:54 AM by (Sylvan_Lobo)

    email-component: Error during component installation

    Level 1
      I have been trying to create a custom component in LiveCycle ES. So i've been looking at<br />the email sample that is available in LiveCycle ES (LiveCycle_ES_SDK\samples\Foundation\CustomComponents\Email)<br /><br />I have followed the steps i the readme and have successfuly created email.jar<br /><br />Now, when I try to deploy the component: In workbench's Components panel, <br />I right click and click on InstallComponent, and select email.jar.<br />But as it tries to install, it gives an error. This is what the log says:<br /><br />!ENTRY com.adobe.DSC_Admin_UI 4 4 2008-05-06 14:38:18.419<br />!MESSAGE install of C:\Documents and Settings\190536\workspace\email-component\deploy\email.jar failed<br />!STACK 0<br />java.lang.NoClassDefFoundError: com.sun.activation.registries.LogSupport<br />     at javax.activation.MimetypesFileTypeMap.<init>(MimetypesFileTypeMap.java:73)<br />     at javax.activation.FileTypeMap.getDefaultFileTypeMap(FileTypeMap.java:98)<br />     at com.adobe.idp.Document.init(Document.java:455)<br />     at com.adobe.idp.Document.<init>(Document.java:366)<br />     at com.adobe.dsc.views.RegistryTreeViewer$InstallWithProgress.run(RegistryTreeViewer.java:12 08)<br />     at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:113)<br /><br />Envt Configuration:<br />Windows XP<br />Jboss Turnkey Installation<br /><br />We also tried deploying other existing components (avoka) but it gives the same error <br /><br />What could be wrong?
        • 1. Re: email-component: Error during component installation
          Level 1
          There's this folder C:\Program Files\Adobe\LiveCycle ES\Workbench ES\Workbench\configuration\org.eclipse.osgi\bundles\8\1\.cp\lib-soap\lib
          where a set of jar files are created each time we start workbench.
          activation.jar included. It creates the old version (with LogSupport missing), and i can't replace with a new version (with the LogSupport class present) while Workbench is running.
          And if i stop Workbench and replace it(or even delete it), on restarting WB the old version reappears.
          I guess this is something to do with osgi/eclipse equinox bundles
          I have a feeling that if I could get the right version of activation.jar there, then things might work right.