4 Replies Latest reply on Jul 7, 2008 6:46 AM by (jerome_dinnat)

    Mapping problems

    (jerome_dinnat) Level 1
      Hi,

      I posted this thread in Designer section but I think this place is more appropriate.

      I have a mapping problem. In my process I have two forms with the same xml schema binding to this forms.

      The first form is prefill with his informations (name, division, email etc ...), his superior informations and he can choose and fill a new superior.

      Once the form is fill and send, the new superior received the form with the completed informations.

      I use a setValue to extract the name of the superior and to associate it with an Assign Task and map the data of the first form into the second form and it works.

      After the second form is approved, I need to exctract some other informations but whatever I can do, all the values are null. However when I extract data from the form with the function xfa.host.exportData(); the data xml is fill with the correct information.

      In my first setValues I map the field login of my form with this xpath :

      location expression

      /process_data/@nplusun /process_data/FormInit/object/data/xdp/datasets/data/FormulaireA/Nouveau/login

      and the data

      /process_data/FormEtape2/object/data/xdp/datasets/data /process_data/FormInit/object/data/xdp/datasets/data

      It works.

      In my second setValues I do :

      location

      /process_data/@name /process_data/FormEtape2/object/data/xdp/datasets/data/FormulaireA/Ancien/NomPrenom

      I try with serializable, with an xml variable associated to the same schema than my form.

      Thank You for helping me
        • 1. Re: Mapping problems
          (jerome_dinnat) Level 1
          Ok,

          I create a new process with only my second form to the previous process (the form who makes me problem to retrieve data).

          The form the process and I retrieve the radio button with a setValue, that's all.

          It works.

          In my previous process, the first form and this one are rendered by different ways. I use the render PDF form for this form and a customize render for the first form.

          I have no problems for retrieve informations about the first form and use them but I can't do this for the second.

          Is it a problem of rendering ? Can you explain me ?

          Thanks
          • 2. Re: Mapping problems
            (jerome_dinnat) Level 1
            Hi,

            Nobody have an idea ? No clues ?

            I don't know what to do.

            Thanks

            Edit : If I use the setValue service to mapp the field form the second form in a third form for a new assign task it works :(

            Therefore the values are there ... I'm totally lost :(
            • 3. Re: Mapping problems
              (jerome_dinnat) Level 1
              Hi,

              In my log file, I have this sentence :

              INFO: Event with id 205 is already inactive.Event instance with id 205 is inactive for TaskFormDataSaved

              and in the workbench help I can read this :

              TaskFormDataSaved : An asynchronous message event indicating that the form data for a task has been saved.

              I suppose my data are not saved but why ? Any help would be appreciated.

              Thanks

              Edit : If I use the same xfaform variable all the process, I can access my data.

              What I want to do is to use two or more different xfaform variables and retrieve the data of eachone.
              • 4. Re: Mapping problems
                (jerome_dinnat) Level 1
                Ok I find the answer to my problem. It seems that I need to map the field one by one because if I map like this <br /><br />/process_data/FormInit/object/data/xdp/datasets/data <br /><br />to <br /><br />/process_data/Form2/object/data/xdp/datasets/data<br /><br />when I export data from the form2 I have this : <br /><br />/><FSFORMQUERY_<br />>/Jeudi26/Formulaires/FAWSv2.pdf</FSFORMQUERY_  (form A)<br /><br />and this<br /><br />/><FSFORMQUERY_<br />>/Jeudi26/Formulaires/FAWSv2Etape2.pdf</FSFORMQUERY_ (form B) <br /><br />I don't understand why. Mapping field one by one works.<br /><br />If someone can explain it to me, I thank you.