1 Reply Latest reply on Jul 28, 2008 3:39 AM by Stephane Gervais

    Documents disappear in repository (?)

    Level 1
      Hi at all!<br /><br />The error message of my problem sounds excatcly like the one described in the thread http://www.adobeforums.com/webx?128@@.3c05650b. The error message is like: <i>'The Document is not available on the sending side anymore. Make sure that it is not disposed or garbage collected too early.'</i>.<br /><br />Although the error is the same like in the other thread, my context is an other one. My process: I load a static PDF document from the repository which subsequently will be used as one of the input parameters of assembler component. This process works fine for hours and even days, but then - out of the blue - the 'Read Resource Content' component throws the mentioned exception:<br /><br /><i><br />com.adobe.idp.DocumentError: The Document is not available on the sending side anymore. Make sure that it is not disposed or garbage collected too early.<br />     at com.adobe.idp.DocumentManagerClient.requestRemotePassivation(DocumentManagerClient.java:3 19)<br />     at com.adobe.idp.Document.passivate(Document.java:748)<br />     at com.adobe.idp.Document.<init>(Document.java:429)<br />     at com.adobe.idp.DocumentStorage.persist(DocumentStorage.java:37)<br />     at com.adobe.workflow.pat.service.PATExecutionContextImpl.setProcessDataValue(PATExecutionCo ntextImpl.java:570)</i><br /><br />I can still see the document in the repository view of LC Workbench, but the 'Read Resource Content' component doesn't. I can resolve this problem only if I re-deploy the specific document to the repository again. Afterwards it works fine until the story recurs after      a non-deterministic period. I'm helpless.... <br /><br />Any idea? Would be cool!<br />Thanks,<br />Nico