10 Replies Latest reply on Dec 31, 2008 5:07 AM by (jerome_dinnat)

    XPath

    (jerome_dinnat)
      Hi,

      I have an issue with my xsd schema.

      Here is my xsd schema bind with a form :


          
              
          

           .
           .
           .


      It works well for a long time and now my process doesn't work anymore.

      In the xpath builder I can always go to process_data/my_form/data/datasets/data/FormulaireD/...

      I put process_data/my_form/data/ in an xml variable and I saw that the element doesn't appear

      There is just
      .

      I don't modify the pdf, the schema or the process since it works.

      I just upgrade livecycle from 8.0.1 SP3 to 8.2.

      The other process and forms doesn't have this issue.

      I don't understand.

      Thanks for any helps.
        • 1. Re: XPath
          Jasmin Charbonneau Level 4
          Can you try to put /process_data/my_form/data/datasets/data in your xml variable and see if that makes any difference?

          Jasmin
          • 2. Re: XPath
            (jerome_dinnat) Level 1
            I did it and if I well remember the element was not in the xml. I check it when I'll be front of the computer.
            • 3. Re: XPath
              (jerome_dinnat) Level 1
              Hi, <br /><br />I check the xml. The root node is <FSFIELDS_>. There is no <FormulaireD>(my xml root node). The rest of the xml is ok.<br /><br /><FSFIELDS_><br />    <xfdf:field xmlns:xfdf="http://ns.adobe.com/xfdf/" xmlns:xfdfi="http://ns.adobe.com/xfdf-transition/" xfdfi:original="FSAPPLICATIONDATA_">H4sIAAAAAAAAAKWSXWuDMBSG7wf7D8X75rjBoIhNcVO3Qr+WKmNXk mpapdVIYmf775fEru3YxWC7CJyTvM+Dx8QdHcpd74MJWfBqaN0h2+qxKuVZUW2GVhyF/YE1wu4hqx21eipcSV0Nrbx pagegkohmfMVQyktQB2Cp9Jo6GW2oZI38Qtb0jLRti1SPuNiATHNWUlBtXxOgPuDagN2Qi3K/o4VgPuDbGzdcRsF0M fGiIDn14ZxMX+OAvCcYLmkJLwUTVKR5oepri659VGdrF77BnZx4M7PpReP5bOwneOGHmtDhn4cd45HnIIrJJMGnCWV r2w/3qM6PEtU03ToDe2BDy8VWqpb1JRPql4Pcr8qiMeaLwii9N/J3mYGN5leLnmxpeA2euScSk3GCBau5LBoujkqgA 6d9k3n0lsG/Zj4LlA4uFw7Xr0e33dPDn4varLGqAgAA</xfdf:field><br />    <xfdf:field xmlns:xfdf="http://ns.adobe.com/xfdf/" xmlns:xfdfi="http://ns.adobe.com/xfdf-transition/" xfdfi:original="FSTARGETURL_">http://sw0052.phys.pack:8080/workspace-server/submit</xfdf: field><br />    <InfosOPA><br />        <nomPrenom>jeje</nomPrenom><br />    </InfosOPA><br />    <ListeN><br />        <InfosN><br />            <login>login1</login><br />            <nomPrenom>name1</nomPrenom><br />            <email>email1</email><br />            <division>div1</division><br />            <perid>perid1 </perid><br />        </InfosN><br />        <InfosNPlusUn><br />            <login>login2</login><br />            <nomPrenom>name2</nomPrenom><br />            <email>email2</email><br />            <division>div2</division><br />            <perid>perid2</perid><br />        </InfosNPlusUn><br />    </ListeN><br />    <ListeNPlusUn><br />        <InfosNPlusUn><br />            <login/><br />            <nomPrenom/><br />            <email/><br />            <division/><br />            <perid/><br />        </InfosNPlusUn><br />        <InfosN><br />            <login/><br />            <coche>0</coche><br />            <nomPrenom/><br />            <email/><br />            <division/><br />            <perid/><br />        </InfosN><br />    </ListeNPlusUn><br />    <AWS_ACTION/><br />    <AWS_PROCESSTYPE/><br />    <AWS_ASSIGNED_ID/><br />    <AWS_TASKID/><br />    <AWS_CHOICE/><br />    <AWS_MAILTO/><br /></FSFIELDS_>
              • 4. Re: XPath
                (jerome_dinnat) Level 1
                If I used on old version of the process it works well.

                The difference between the process is that after the migration to 8.0.1 SP3 to 8.2, all my xfaform variable in all process appears in red in the xpath builder with the Error:java.lang.reflect.Invocation.TargetException.

                The process well worked for all that. In some cases clicking "reload schema from file" solves the problem, in other I just needed rebounding the schema to the file before.

                I did that for all the process with no issue except for this one.

                If I don't touch the variable the process well works but if fix the variable the process doesn't work anymore.

                The two version use the same PDF.

                I hope to be clear enough.

                The xml I have when it works fine :


                   
                        fef
                   

                   
                       
                            login1
                            name1
                            mail1
                            div1
                           
                            perid1
                       

                       
                            login2
                            name2
                            mail2
                            div2
                            perid2
                       

                   

                   
                       
                           
                           
                           
                           
                           
                           
                       

                       
                           
                           
                           
                           
                           
                       

                   

                    H4sIAAAAAAAAAM2TwW6jMBCG7yvtO0Tcw9BKlaKIuKIN7EZKE0pAVU/IBSexCjaySWnffseQEKoeWm0vPYBnxv//MU Ye9/q1LEYvTGkuxcy6sB1rxEQmcy52MyuJg/HEuibua15N8RmhWGgTzax9XVdTAKFtmssnZmeyBNwAC9VbOs1pTTWr 9cmypb2laRobc1uqHehsz0oKmI6NA7CBIYG4gVTloaBcsTlxF2Ir9Tr0iCtkGSqGbyAunMtLrmu2OgpxLeSOC3gvx+ /xAtecv3BzagwziW30pN4fFgediC9T4L0LTs1066n8g1rr0+FP/v3LDTaxfxcuvdhPocuDdXR3n/jRY0oGYg1/OVNU ZXuO8QDSxnO7yrfIHpo7eOSt2qIXL9arxTwl4TwwDiP+uNl5vOiPHyfRMiXHW6Qbx7m6tKv9m7Yrmj1PJ87EgUaqZ4 0pG2um8FqDPjyVvG7JZ0SL9B6i/4e15hbzKcWcbNP6jbH33UZJtEiJYpXUvJbqDQFGcKy3mhtv43/rzD0AcXAeKhhO qEm78Sb/ALA+iasOBAAA
                    http://sw0052.phys.pack:8080/workspace-server/submit
                • 5. Re: XPath
                  (jerome_dinnat) Level 1
                  I try to create a new process to test :

                  A setvalue is used to put the data in a xml variable and a variable logger.

                  I try with the form and the default schema. The problem is still there.

                  I try to use a schema who works fine in another process. The problem is still there, exactly same issue.

                  If I use the exportdata() script on the form when I filled it, I can see the root open tag is missing.
                  • 6. Re: XPath
                    Level 1
                    Hi Jerome,

                    Were you able to solve the above mentioned problem you had? Missing of Root tag?

                    Regards,
                    Nadir
                    • 7. Re: XPath
                      (jerome_dinnat) Level 1
                      No, I still have the problem. Do you have the same issue ?
                      • 8. Re: XPath
                        (jerome_dinnat) Level 1
                        Hi,

                        It seems the render I used(default render and a modify version of it) was the source of the problem.

                        There is a new PDF render in Process Management "Render PDF form ES update1 " who fix the issue.

                        I didn't notice the issue in my other process because I use Jdbc services in the render to populate the pdf with an xml file who match the xml schema of the form.

                        So I need to change all my rendering process to match the new PDF render.

                        I hope it could help you too Nadir.
                        • 9. Re: XPath
                          Level 1
                          Hi Jerome,

                          I tried the new PDF Renderer as well but it has no affect. The root tag of the xml changes to FSFIELDS_.

                          Thanks for the response though.
                          • 10. Re: XPath
                            (jerome_dinnat) Level 1
                            Hi,

                            Explain me what you are doing and what is the problem.