1 Reply Latest reply on Jan 23, 2009 12:56 AM by (Michael_Feichtegger)

    ClassNotFoundException for custom component

      I have created a custom component and am trying to use it in a process I am creating. This custom component exposes a Bean-type business object. One of the properties of this object is a List<OtherBusinessObject>. I am trying to output this List<OtherBusinessObject> into a process variable, but I get an exception: ClassNotFoundException: OtherBusinessObject. From the stack trace it looks like this is happening during the deserialization of the List<OtherBusinessObject>. <br /><br />OtherBusinessObject implements Serializable...I have no idea why the process cannot find my OtherBusinessObject class. I have configured it in the component.xml as:<br /><br /><data-types><br /><data-type id="com.mycompany.mylibrary.OtherBusinessObject" title="OtherBusinessObject"/><br /></data-types><br /><br />This seems to be fine as I can select my class type from the list of types in the "variable" form.<br /><br />Help!
        • 1. Re: ClassNotFoundException for custom component
          (Michael_Feichtegger) Level 1
          Hi Mike,

          I think we have the exact same problem.
          As far as I could interpret the stacktrace, the problem occurs when LC is trying to deserialize the variables of an long-lived process. So do you have a long-lived or a short-lived process?

          We've put the part with the custom object into an short-lived subprocess to work around that problem.

          But the core problem still exists - How can you make the LC classloader to find your custom object?

          kind regards
          Michael