12 Replies Latest reply on Nov 29, 2010 12:56 PM by FrankEFuss

    Issue with Events

    JoshDBoyle Level 1
      All

      I am attempting to build a simple orchestration that is kicked off via the TaskCreated event. As of now, I don't care about using a filter - I just want the orchestration to run any time the TaskCreated event is fired.

      I've created such an orchestration. First I placed a start point TaskCreated event on the canvas. I followed this with a SetValue operation that assigns some random sentence to a String variable. I've saved and activated this service.

      Now, when I go into Workspace and launch a workflow, I can see in my log that the TaskCreated event seems to be firing properly but that something is definitely wrong. The following errors can be found in the server.log:

      2009-02-20 17:21:55,491 ERROR [org.jboss.ejb.plugins.LogInterceptor] RuntimeException in method: public abstract java.lang.Object com.adobe.idp.dsc.transaction.impl.ejb.adapter.EjbTransactionCMTAdapterLocal.doSupports(c om.adobe.idp.dsc.transaction.TransactionDefinition,com.adobe.idp.dsc.transaction.Transacti onCallback) throws com.adobe.idp.dsc.DSCException:
      com.adobe.workflow.template.document.TemplateNodeNotFoundException: Template object: STRT_ER1235167537085 not found.

      I have Recording and Playback set for my orchestration with the event and a new instance of this orchestration is being fired whenever I create a task but it can't seem to actually make it past the event start point because of the above error.

      Any ideas?
        • 1. Re: Issue with Events
          $Nith$ Level 4

          Hi Josh,

           

          I am getting the same exception now in ES2. Did you find any solution for this issue?

           

          Thanks,

          Nith

          • 2. Re: Issue with Events
            bonpb

            I am having the same issue.  Did anyone get this resolved?

             

            Thanks

            • 3. Re: Issue with Events
              Jasmin Charbonneau Level 4

              If you remove the event start point do you get the error in the log?

               

              Are you using an xdp or a pdf on the user step?

               

              Is the form specified in a variable or you browse and select it from the repository?

               

              Jasmin

              • 4. Re: Issue with Events
                bonpb Level 1

                When I remove the start point the process still fails.  It seem to be when I add an event to a user block that causes the issue.  I simply want to call an activity that writes to a log when the task is claimed.

                 

                To answer your other questions, I am using a xpd and it is specified in a variable.

                 

                Thanks for your help.

                • 5. Re: Issue with Events
                  Jasmin Charbonneau Level 4

                  " It seem to be when I add an event to a user block that causes the issue."

                   

                  What do you mean by that? Are you trying to add an event catch to an actual user step.

                   

                  I don't think you want to do that. What are you trying to do?

                   

                  Jasmin

                  • 6. Re: Issue with Events
                    bonpb Level 1

                    What I want to do is use an activity to write to a log when a task is claimed from a group.  I would like to have the name of who claimed the task but at this point that is just for bonus points.

                     

                    I have an activity that will write to my log (we use copies of this on several other steps).  I want to use that activity to write a message to our log when a task is claimed. We create our reports and assign them to a group.  I want to use our log writer activity when the report is claimed from that group.  Here are a few of the things I have tried:

                     

                       

                    • I placed an event on the corner of the user group

                          

                      • I wired this to a throw event thinking the startpoint process would catch it and write to the log but the process died

                          

                      • I wired this to the activity that writes to our log but the process died

                          

                      • I wired this to the activity that writes to our log and then back to the user but that caused issues

                       

                    • I placed a throw event on the process and did not link it to anything but it never fired

                       

                    • I placed an activity on the process and placed an even in the corner thinking it would catch the task claimed event but it didn't

                     

                    Thank you for your help,

                    Parker

                    • 7. Re: Issue with Events
                      $Nith$ Level 4

                      The predefined events such as TaskCreated, TaskClaimed, TaskCompleted etc are always thrown automatically.

                       

                      Which means, you need not drag those events into the corners of User activity.

                       

                      It is just a matter of receiving those event (through event start points) by applying appropriate filters.

                       

                      For a quick test,

                           Create a simple (short-lived) process and add a event start point (say TaskCreated).

                           Enable process recording.

                           Initiate any process which has an user activity.

                           You must be able to see the process recording if a task is assign to a user.

                       

                       

                      I faced Template Not Found exception. After a long research, I scraped my database and re-initialized. Because its just a TEST environment.

                       

                      Nith

                      • 8. Re: Issue with Events
                        bonpb Level 1

                        Thanks $Nith$, I got that to work.  Sorry for the delayed response, I took a fews days vacation.

                         

                        I am now trying to pass data, specifially the reportName and the user that claimed it.  I am just starting to look at that and have not search the help or forums yet.

                        • 9. Re: Issue with Events
                          Jasmin Charbonneau Level 4

                          Make sure the variable you use to pass the data are input variable.

                           

                          This is a common mistake people make when trying to map data from the event to the process variables.

                           

                          Jasmin

                          • 10. Re: Issue with Events
                            bonpb Level 1

                            I have gotten the username by using the findUser function but I am not able to get the report name.  This information is held in a string variable named ... wait for it ... ReportName.  How do I access that variable from the taskClaimed process? 

                             

                             

                            Thanks for all the help

                            • 11. Re: Issue with Events
                              Jasmin Charbonneau Level 4

                              The only info you get from the process that triggers the event is what you get from the Event Data section.

                               

                              You can't pass variable values in the event data unless you use your own event.

                               

                              Jasmin

                              • 12. Re: Issue with Events
                                FrankEFuss

                                I am also experiencing many errors that are filling up the log file and making it difficult to find what I am looking for in the log.  The culprit is:

                                 

                                2010-11-29 11:21:21,151 INFO (STDOUT:206) - 2010-11-29 11:21:21,150 ERROR(org.jboss.ejb.plugins.jms.JMSContainerInvoker:1462) - Exception in JMSCI message listener

                                javax.ejb.TransactionRolledbackLocalException: RuntimeException

                                at org.jboss.ejb.plugins.AbstractTxInterceptor.invokeNext(AbstractTxInterceptor.java:262)

                                at org.jboss.ejb.plugins.TxInterceptorCMT.runWithTransactions(TxInterceptorCMT.java:350)

                                at org.jboss.ejb.plugins.TxInterceptorCMT.invoke(TxInterceptorCMT.java:181)

                                at org.jboss.ejb.plugins.RunAsSecurityInterceptor.invoke(RunAsSecurityInterceptor.java:109)

                                at org.jboss.ejb.plugins.LogInterceptor.invoke(LogInterceptor.java:205)

                                at org.jboss.ejb.MessageDrivenContainer.internalInvoke(MessageDrivenContainer.java:399)

                                at org.jboss.ejb.Container.invoke(Container.java:960)

                                at org.jboss.ejb.plugins.jms.JMSContainerInvoker.invoke(JMSContainerInvoker.java:1139)

                                at org.jboss.ejb.plugins.jms.JMSContainerInvoker$MessageListenerImpl.onMessage(JMSContainerI nvoker.java:1452)

                                at org.jboss.jms.asf.StdServerSession.onMessage(StdServerSession.java:266)

                                at org.jboss.mq.SpyMessageConsumer.sessionConsumerProcessMessage(SpyMessageConsumer.java:891 )

                                at org.jboss.mq.SpyMessageConsumer.addMessage(SpyMessageConsumer.java:170)

                                at org.jboss.mq.SpySession.run(SpySession.java:323)

                                at org.jboss.jms.asf.StdServerSession.run(StdServerSession.java:194)

                                at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(PooledExecutor.java:761)

                                at java.lang.Thread.run(Thread.java:595)

                                Caused by: javax.ejb.EJBException: RuntimeException

                                at com.adobe.workflow.engine.ProcessCommandControllerBean.doOnMessage(ProcessCommandControll erBean.java:206)

                                at com.adobe.workflow.engine.ProcessCommandControllerBean.onMessage(ProcessCommandController Bean.java:99)

                                at sun.reflect.GeneratedMethodAccessor352.invoke(Unknown Source)

                                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

                                at java.lang.reflect.Method.invoke(Method.java:592)

                                at org.jboss.invocation.Invocation.performCall(Invocation.java:359)

                                at org.jboss.ejb.MessageDrivenContainer$ContainerInterceptor.invoke(MessageDrivenContainer.j ava:492)

                                at org.jboss.resource.connectionmanager.CachedConnectionInterceptor.invoke(CachedConnectionI nterceptor.java:158)

                                at org.jboss.ejb.plugins.MessageDrivenInstanceInterceptor.invoke(MessageDrivenInstanceInterc eptor.java:116)

                                at org.jboss.ejb.plugins.AbstractTxInterceptor.invokeNext(AbstractTxInterceptor.java:121)

                                ... 15 more

                                Caused by: javax.ejb.EJBException: RuntimeException

                                at org.jboss.ejb.plugins.LogInterceptor.handleException(LogInterceptor.java:417)

                                at org.jboss.ejb.plugins.LogInterceptor.invoke(LogInterceptor.java:209)

                                at org.jboss.ejb.plugins.ProxyFactoryFinderInterceptor.invoke(ProxyFactoryFinderInterceptor. java:138)

                                at org.jboss.ejb.SessionContainer.internalInvoke(SessionContainer.java:648)

                                at org.jboss.ejb.Container.invoke(Container.java:960)

                                at org.jboss.ejb.plugins.local.BaseLocalProxyFactory.invoke(BaseLocalProxyFactory.java:430)

                                at org.jboss.ejb.plugins.local.StatelessSessionProxy.invoke(StatelessSessionProxy.java:103)

                                at $Proxy214.asyncTerminateActionCommand(Unknown Source)

                                at com.adobe.workflow.engine.ProcessCommandControllerBean.doOnMessage(ProcessCommandControll erBean.java:177)

                                ... 24 more

                                Caused by: com.adobe.workflow.template.document.TemplateNodeNotFoundException: Template object: A1284756038469 not found.

                                at com.adobe.workflow.engine.ProcessEngineBMTBean.asyncTerminateActionCommand(ProcessEngineB MTBean.java:1028)

                                at sun.reflect.GeneratedMethodAccessor354.invoke(Unknown Source)

                                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

                                at java.lang.reflect.Method.invoke(Method.java:592)

                                at org.jboss.invocation.Invocation.performCall(Invocation.java:359)

                                at org.jboss.ejb.StatelessSessionContainer$ContainerInterceptor.invoke(StatelessSessionConta iner.java:237)

                                at org.jboss.resource.connectionmanager.CachedConnectionInterceptor.invoke(CachedConnectionI nterceptor.java:158)

                                at org.jboss.ejb.plugins.CallValidationInterceptor.invoke(CallValidationInterceptor.java:63)

                                at org.jboss.ejb.plugins.AbstractTxInterceptor.invokeNext(AbstractTxInterceptor.java:121)

                                at org.jboss.ejb.plugins.AbstractTxInterceptorBMT.invokeNext(AbstractTxInterceptorBMT.java:1 73)

                                at org.jboss.ejb.plugins.TxInterceptorBMT.invoke(TxInterceptorBMT.java:77)

                                at org.jboss.ejb.plugins.StatelessSessionInstanceInterceptor.invoke(StatelessSessionInstance Interceptor.java:169)

                                at org.jboss.ejb.plugins.SecurityInterceptor.invoke(SecurityInterceptor.java:168)

                                at org.jboss.ejb.plugins.LogInterceptor.invoke(LogInterceptor.java:205)

                                ... 31 more

                                Caused by: com.adobe.workflow.template.document.TemplateNodeNotFoundException: Template object: A1284756038469 not found.

                                at com.adobe.workflow.template.document.DefaultAbstractTemplateDocument.getTemplateNodeById( DefaultAbstractTemplateDocument.java:84)

                                at com.adobe.workflow.engine.ProcessEngineBMTBean.asyncTerminateActionCommand(ProcessEngineB MTBean.java:998)

                                ... 44 more

                                 

                                Has anyone found a solution beyond scrapping (I am assuming that is intent of the reference to scraping) the database.  We don't have that kind of time now.

                                 

                                 

                                For your issue with reporting assignments in the log file, have you tried to read the adobe.tb_assignment joined with the adobe.EDCPRINCIPALENTITY tables for that information?  LiveCycle is tracking and storing that information already.