5 Replies Latest reply on Mar 11, 2009 6:21 AM by Steffen Kuhnt

    Error in user task

    Steffen Kuhnt Level 1
      Hello all,

      in a customer project, we have run into an issue while trying to assign a task to an user (synchronized from the customers LDAP).

      The server log file gives the following message:

      A non-retryable Exception has occured: Attribute: out_of_office_user_id on object: workflow_user:[1AF8AB1E-8254-323F-81E4-606D7FF392C1] has not been loaded.

      The "allow out of office designation" options are turned OFF in the user task. Is there anyone who knows what this error REALLY means?

      Thank you very much,

      Steffen.
        • 1. Re: Error in user task
          Jasmin Charbonneau Level 4
          I remember a bug with the user step when using xPath to assign the user dynamic ally and using Oracle for the DB.

          Is this similar to your environment?

          Jasmin
          • 2. Re: Error in user task
            Steffen Kuhnt Level 1
            Amazing, this is EXACTLY the case with our environment. I think we'd be glad to hear anything you can still remember regarding that bug ;-)

            Thanks a million,

            Steffen.
            • 3. Re: Error in user task
              Jasmin Charbonneau Level 4
              Support created a patch and I beleive it was rolled out as part of service pack 1 (SP1).

              Your best bet is to contact support to get the appropriate patch to fix the issue.

              Jasmin
              • 4. Re: Error in user task
                Level 1
                Steffen,
                The temporary work around is to have (each) user to login to workspace client at least once for now.

                Thanks
                Yog
                • 5. Re: Error in user task
                  Steffen Kuhnt Level 1
                  Thank you all for your quick responses!

                  After playing around for a while, I noticed that the issue really only occurs with one specific user account. When I directly assigned the task to this account everything worked just fine. After that, the xPath option worked as well. It really looks like if something is being synchronized into the LC database when a user account has it's first contact with a workflow. If that step could be completed the issue never occurs again - which sounds pretty much in line with what Yog said.

                  The only difference with the "erroneous" user account seems to be that the family name contains a whitespace - I have no idea if this is relevant.

                  I'm not able to apply the service pack immediately for some reason, but we'll soon be able to see if that fixes the issue.

                  Thanks again,

                  S.