10 Replies Latest reply on Mar 17, 2009 12:57 AM by alukyro

    Warnings in LCServer.log

    alukyro Level 1
        • 1. Re: Warnings in LCServer.log
          alukyro Level 1
          I get the following warnings in the LCServer1 log file:

          (4) ALC-XTG-102-001: {0} # [5944] Invalid version: The current version of the XFA template model exceeds the capability of Acrobat / Adobe Reader 6.
          (4) ALC-XTG-102-001: {0} # [5944] ApronInstitutionName 'access' attribute should explicitly be set to 'nonInteractive'. Field will be drawn as a boilerplate.

          ...and more like the above.

          I'm not getting any warnings in the Workbench/Designer and all fields are set to read only.

          What might be the cause of this and how can theese warnings be resolved?

          Kind regards

          Lars
          • 2. Re: Warnings in LCServer.log
            pguerett Level 6
            Those are warnings that appear when the form is being rendered on the server. The 1st one is because you have functionality on the form that is beyond Reader 6 capability. If you change the target version to a higher value then that message will go away.

            The errors are being reportred in Designer it is just not visisble to you. Look under the Reports/Log palette. You can activate it from the Windows menu.
            • 3. Re: Warnings in LCServer.log
              alukyro Level 1
              Thats the funny thing.. The target version is already set to 8.1. Look at the following snippet from the xml:<br /><br /><template xmlns="http://www.xfa.org/schema/xfa-template/2.6/"><br />   <?formServer defaultPDFRenderFormat acrobat8.1static?><br />   <?formServer allowRenderCaching 0?><br />   <?formServer formModel both?><br /><br />The Report palette is already enabled too and it says when Previewing form:<br /><br />Generating PDF Document...<br />PDF generated successfully.<br /><br />0 warnings/errors reported.<br /><br />However I still get the described warnings in the Log file. Is it possible that theres some "garbage" in the xml, which is first "discovered" when rendering the form through renderPdfService or AssembleService?<br /><br />Fragments are included in the in the xdp but they are also set to version 8.1 and I get no warnings here either.
              • 4. Re: Warnings in LCServer.log
                pguerett Level 6
                There is a cache on the server ....could the cache have an old form in it? You can clear the cache through the adminui.
                • 5. Re: Warnings in LCServer.log
                  alukyro Level 1
                  Tried clearing the cache - same warnings appear in the log file. I have a feeling that the xml may contain some "garbage" that the Designer can't "see". Is there a way to verify this xml?

                  Another thing, would it be possible not to have warnings logged to the log file - but info only? We already have this in production and this means that logs are flooded with these warnings.

                  Kind regards

                  Lars
                  • 6. Re: Warnings in LCServer.log
                    alukyro Level 1
                    I have been looking thorugh the xml source. I've found the following: <?originalXFAVersion http://www.xfa.org/schema/xci/2.8/?><br /><br />Is this a problem when the template is this version?: <br /><template xmlns="http://www.xfa.org/schema/xfa-template/2.6/">
                    • 7. Re: Warnings in LCServer.log
                      pguerett Level 6
                      No ..no problem there.
                      • 8. Re: Warnings in LCServer.log
                        alukyro Level 1
                        Still strugling with this.

                        Any idea what below line from the log means?

                        (7) ALC-XTG-104-000: {0} # ::Get() have dmResource
                        • 9. Re: Warnings in LCServer.log
                          alukyro Level 1
                          Grasping for straws here...

                          I only see the warnings in the log, not in the Designer. Could it be something in my process causing the warnings in the log?

                          In my RenderPdfForm I have the following

                          Acrobat version: Auto
                          PDF Version: 1.5
                          etc.
                          • 10. Re: Warnings in LCServer.log
                            alukyro Level 1
                            Yep, that seemed to do it!

                            After setting the PDF version to auto, the warnings disappeared.

                            Hurray. :)