8 Replies Latest reply on Sep 7, 2010 9:17 PM by Leialandy

    What would cause intermittant "unable to find service"?

    Pinecone28
      We have a process that does a render form in the first step and we are getting intermittant failures: ALC-FRM-001-004 Unable to find service XMLFormService. connection to failed service.

      This operations fails approx 20-50% of the time. We have many other processes that render forms with no issues. The error code says to ensure that the service is running properly. I've modified some of the service settings - with no change in behavior.

      We are running on a WebSphere cluster. This same process works fine in our JBoss turnkey environment.
        • 1. Re: What would cause intermittant "unable to find service"?
          Jasmin Charbonneau Level 4
          Is it possible that is fails when it hits a particular machine in your cluster? Do you get the error in all app server error logs?

          Jasmin
          • 2. Re: What would cause intermittant "unable to find service"?
            Pinecone28 Level 1
            FYI - we are invoking this process via SOAP. I also should have specified - we do not currently run more than 1 leg of the app server cluster at a time. our web servers are clustered, so just now I redirected the web service call to one specific web server - same result. :( More detail is available on 180821755 - someone else here sent the issue to JP. I also sent the LCA for this to CK.
            • 3. Re: What would cause intermittant "unable to find service"?
              HowardTreisman Level 1
              Have you tried shutting down the machine and restarting?
              LiveCycle uses a set of external executables (XMLFormService.exe). It may be that one of them has become "hung" in some way.
              Howard
              http://www.avoka.com
              • 4. Re: What would cause intermittant "unable to find service"?
                Pinecone28 Level 1
                We have seen the failure in all app servers in the cluster. the actual XMLForm process fails after it starts running in Unix. analysis of the trace file from the core dump shows that a device driver is loading a font when it fails with a C++ segmentation error (invalid memory address) sometimes the error only occurs on one app server - and when it does it's usually consistant on that server for a few days - then magically it "fixes" itself. we have restarted the JVM's and also the cell, but not the actual unix box as there are other apps running. no other application is experiencing failures.
                • 5. Re: What would cause intermittant "unable to find service"?
                  HowardTreisman Level 1

                  Is it possible that it's failing when it tries to render a particular form that has a certain font in it?

                  Howard

                  • 6. Re: What would cause intermittant "unable to find service"?
                    Pinecone28 Level 1

                    That's a very good question!    unfortunately, the problem "fixed" itself and worked fine for 6 days.    This week it has returned, being "broken" for 1-2 hours each day - at different times.     The problem (always) appears first in a large (490k) form that has 410 fields and uses primarily Arial. I have converted most of the fields in that form to MyriadPro and got that form to still fail.   I have totally converted it to MuriadPro but now I need to wait until the system is "broken" again before I can test.   Sometimes that is the only form that fails.   other times that one fails and so will another form   (200k).     There have been times when even the IVS sample forms fail.    Once again, there is no consistency here - other than generally the problem is repeatable for the duration that the system is broken   ie:  for the 1-2 hours that it's broken I can consistently fail forms - although not all forms.

                     

                    We are running this is a WebSphere cluster with other activity going on - yet we are unable to identify or isolate any other potential influence.

                     

                    And yes, we are going crazy trying to determine the root cause of this!   We are also unable to move this to production until we have either identified root cause or run for a long time without form render failures.

                    • 7. Re: What would cause intermittant "unable to find service"?
                      HowardTreisman Level 1

                      Hi

                      It sounds to me like one of the instances of Forms executable is dying due to invalid font, and is then failing for subsequent renders. The reason that it's intermittent may be that you have multiple instances of the Forms executable, and one of them has failed, and the other(s) are okay.

                       

                      One thing to try is to check your fonts in the underlying XML for each of your forms, because sometimes it's hard to locate all the instances of font usage. Search for:

                      typeface="xxx"

                      and

                         <psMap>
                            <font typeface="Nyala" psName="Nyala-Regular" weight="normal" posture="normal"/>
                         </psMap>

                       

                      We have some internal tools that will go through a set of forms, and extract all this information - if you're interested in us running these tools against your forms, please email info-at-avoka.com.

                       

                      Howard

                      • 8. Re: What would cause intermittant "unable to find service"?
                        Leialandy

                        Hi,

                         

                        I've the almost exact same issue.. (same error code ALC-FRM-001-004 but different error msg as highlight in red below)

                         

                        <Sep 8, 2010 10:32:15 AM SGT> <Error>  <com.adobe.formServer.PA.XMLFormAgentWrapper> <BEA-000000>  <ALC-FRM-001-004: Unable to find service: XMLFormService, error: Bad  transaction status 4>
                        <Sep 8, 2010 10:32:16 AM SGT> <Error>  <com.adobe.idp.workflow.dsc.invoker.WorkflowDSCInvoker> <BEA-000000>  <An exception was thrown with name  com.adobe.livecycle.formsservice.exception.RenderFormException  message:java.lang.IllegalStateException: Bad transaction status 4 while invoking  service FormsService and operation renderPDFForm and no fault routes were found  to be configured.>
                        Anyone has any idea..?
                        Cheers,
                        Leia