3 Replies Latest reply on Feb 15, 2008 4:21 AM by kc@dafolo.dk

    Getting data from document to xfaform

    kc@dafolo.dk Level 1
      Hi all,<br /><br />I send mails with a pdf attached to an email endpoint and my process is kicked of nicely.<br /><br />Also I use the exportData-service to get the xml data out of the pdf file which also works fine. I get a structure like this:<br /><br /><xfa:data><br /> <form1><br />   <more fields with data><br /> </form1><br /></xfa:data><br /><br />Now my problem is that I need to add this data to an xfaform which can be processed and viewed by Users in my process.<br /><br />I have tried with a "Set Value" with the following:<br /><br />/process_data/myXFAForm/object/data/xdp/datasets/data = /process_data/myXMLdata<br /><br />But unfortunately this does not do the trick...<br /><br />Can anyone help me here?<br /><br />Sincerely<br />Kim
        • 1. Re: Getting data from document to xfaform
          Jasmin Charbonneau Level 4
          Try
          /process_data/myXFAForm/object/data/xdp/datasets/data = /process_data/myXMLdata/xfa:data/*

          This should put all the code under xfa:data under the data node of the form variable.

          Make sure to add the xfa namespace to your process under Process/Properties/Advanced.

          Jasmin
          • 2. Re: Getting data from document to xfaform
            kc@dafolo.dk Level 1
            Hi again,

            I still have the problem...

            Besides the xfa:data namespace my XML-variable (populated with the export service) contains information on a number of datadescriptions (my dataconnections from the designer) and the schema...

            When I do as you suggest I get the error:

            at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
            at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
            at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
            at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
            at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11P rotocol.java:744)
            at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
            at org.apache.tomcat.util.net.MasterSlaveWorkerThread.run(MasterSlaveWorkerThread.java:112)
            at java.lang.Thread.run(Thread.java:595)
            Caused by: java.lang.Exception: More than one data node found....

            However I don't seem to be able to find more than one data node in my XML.

            What could I do to make t his work?

            Sincerely
            Kim
            • 3. Re: Getting data from document to xfaform
              kc@dafolo.dk Level 1
              Problem solved...

              I just needed to add a dataset to my expression, like this:

              /process_data/myXFAForm/object/data/xdp/datasets/data = /process_data/myXMLdata/xfa:datasets/xfa:data/*

              and everything went smooth...

              Thank you for helping me so far anyway.

              Sincerely
              Kim