3 Replies Latest reply on Sep 25, 2008 1:16 PM by (Eric_Crone)

    URL to a Workflow Initial form

    Level 1
      Hi,

      Does anyone know of a URL that loads an initial form of a process?

      For example say I have a process defined in ES called called MyProcess. Is there a workspace URL we can use to load the initial form of MyProcess?

      I am looking for something along the lines of: http://servername:8080/workspace?load=InitialForm&processName=MyProcess

      Thanks and regards,

      Lachlan
        • 1. Re: URL to a Workflow Initial form
          This capability doesn't exist in the currently shipping LiveCycle ES, but it is in the upcoming release (ES Update 1, aka version 8.2.1).

          In ES Update 1, in order to do what you are asking you would need a TaskManagerEndpoint defined for your MyProcess service, so let's presume that you created one and called it MyEndpoint.

          The url to immediately invoke this (after a login prompt) would be:
          http://servername/workspace?startEndpoint=MyProcess.MyEndpoint
          • 2. Re: URL to a Workflow Initial form
            Level 1
            Hi Jon,

            i just tried this and it does not seem to work. http://servername/workspace?startEndpoint=MyProcess.MyEndpoint

            It takes me into Workspace and under my favorites folder, but no form shows up in the window. I also try to navigate around to other categories and no "cards" show up for the forms I should have access to. I have to close the browser out and come in again.

            I should also note that both my process name and endpoint name have spaces in them. So the URL is actually:
            http://servername/workspace?startEndpoint=My Process.My Endpoint which gets converted to: http://servername/workspace?startEndpoint=My%20Process.My%20Endpoint

            Could that be part of the problem?
            • 3. Re: URL to a Workflow Initial form
              Level 1
              More info in LiveDocs: http://livedocs.adobe.com/livecycle/8.2/wb_help/wwhelp/wwhimpl/common/html/wwhelp.htm?con text=Workbench_ES&file=001330.html

              It's not working, even for processes and endpoints without spaces in the name.