7 Replies Latest reply on Aug 20, 2008 4:13 AM by (James_J_Gallagher)

    Custom Workspace UI

    (James_J_Gallagher) Level 1
      Hi,

      I have followed all the steps in the "Customizing the LiveCycle Workspace ES User Interface" document and am stuck on page 22, point #8 for those of you that might have the document to hand.

      I have created my custom ear file but cannot find the correct location to deploy it to. I am using WebSphere as the web app and have tried to deploy my ear file to the following location: \\MyServer\Adobe\LiveCycle8\deploy

      The above directory contains "adobe-workspace-runtime.ear" so I thought it was the correct location to deploy my custom ear, but when I try navigate to my custom workspace http://server:port/myCustomWorkspace it's not being located.

      Hope someone can help.

      Thanks,
      James
        • 1. Re: Custom Workspace UI
          (flexairlr1) Level 1
          For a Websphere installation, I believe you install using the Websphere, not copying to a folder like the JBoss application server. You may need to consult your version of the Websphere Application server Documentation.

          The LiveCycle ES docs provides some information but it may not be exact as it is a custom EAR you deploying. Refer to http://help.adobe.com/en_US/livecycle/es/install_websphere.pdf and the section entitled "Deploying to WebSphere".

          Hope that helps!
          • 2. Re: Custom Workspace UI
            (James_J_Gallagher) Level 1
            Hey Flex thanks for that.

            I followed the instructions in that document and have deployed my custom ear file.

            In the final part of chapter 5 it says I must run LiveCycle Configuration Manager to configure and deploy LiveCycle ES. When I attempt to run ConfigurationManager.bat I'm getting an error.

            The error is:
            Java Virtual Machine Launcher - Could not find the main class. Program will exit.

            The command that the batch file is running is:

            ...>"javaw" -Xms128m -Xmx512m com.adobe.livecycle.lcm.gui.LCMGUI

            I followed the steps in "Configuring the JVM arguments and properties".

            Any ideas what could be wrong ?
            • 3. Re: Custom Workspace UI
              JohnFait Level 2
              Re: Custom EAR deployment

              LCM will only deploy LC EARs. You can deploy your customer EARs using the application server's administration console.
              • 4. Re: Custom Workspace UI
                JohnFait Level 2
                Re: LCM launch error

                What JDK vendor and version are you using?

                Rather then double clicking the bat file can you try running it from a dos prompt to get some addition output about the issue.
                • 5. Re: Custom Workspace UI
                  (James_J_Gallagher) Level 1
                  Hi John,

                  Thanks for the reply.

                  The App Server is Websphere and the java version is as follows:

                  U:\Program Files\IBM\WebSphere\AppServer\java\bin>java -version

                  ----------------------------------------------------------------------
                  java version "1.5.0"
                  Java(TM) 2 Runtime Environment, Standard Edition (build pwi32dev-20060511 (SR2))

                  IBM J9 VM (build 2.3, J2RE 1.5.0 IBM J9 2.3 Windows XP x86-32 j9vmwi3223-2006050
                  4 (JIT enabled)
                  J9VM - 20060501_06428_lHdSMR
                  JIT - 20060428_1800_r8
                  GC - 20060501_AA)
                  JCL - 20060511a

                  ----------------------------------------------------------------------

                  When I run the ConfigurationManager.bat from the command line I get the following:

                  ----------------------------------------------------------------------
                  U:\Adobe\LiveCycle8\configurationManager\bin>ConfigurationManager.bat

                  ######################################################
                  GUI Launcher

                  ######################################################

                  JAVA_HOME is not set. Unexpected results may occur.
                  The filename, directory name, or volume label syntax is incorrect.

                  ===============================================================================

                  ConfigurationManager Environment

                  JAVA: javaw

                  JAVA_OPTS: -Xms128m -Xmx512m

                  CLASSPATH: ..\lib\adobe-lcm.jar;..\lib\xalan.jar;..\lib\xercesImpl.jar;..\lib\co
                  mmons-io-1.2.jar;..\lib\adobe-bootstrapper-client.jar;..\lib\adobe-truststore-ap
                  i.jar;..\lib\jsafe.jar;..\lib\certj.jar;..\lib\ant\ant.jar;..\lib\ant\ant-launch
                  er.jar;..\lib\ant\ant-trax.jar;..\lib\ant\ant-xalan1.jar;..\..\LiveCycle_ES_SDK\
                  client-libs\common\adobe-livecycle-client.jar;..\..\LiveCycle_ES_SDK\client-libs
                  \common\adobe-applicationmanager-client-sdk.jar;..\..\LiveCycle_ES_SDK\client-li
                  bs\common\adobe-usermanager-client.jar;..\..\LiveCycle_ES_SDK\client-libs\common
                  \adobe-truststore-client.jar;..\..\LiveCycle_ES_SDK\client-libs\thirdparty\axis.
                  jar;..\..\LiveCycle_ES_SDK\client-libs\thirdparty\jaxrpc.jar;..\..\LiveCycle_ES_
                  SDK\client-libs\thirdparty\saaj.jar;..\..\LiveCycle_ES_SDK\client-libs\thirdpart
                  y\xercesImpl.jar;..\..\LiveCycle_ES_SDK\client-libs\thirdparty\activation.jar;..
                  \..\LiveCycle_ES_SDK\client-libs\thirdparty\commons-codec-1.3.jar;..\..\LiveCycl
                  e_ES_SDK\client-libs\thirdparty\commons-collections-3.1.jar;..\..\LiveCycle_ES_S
                  DK\client-libs\thirdparty\commons-discovery.jar;..\..\LiveCycle_ES_SDK\client-li
                  bs\thirdparty\commons-logging.jar;..\..\LiveCycle_ES_SDK\client-libs\thirdparty\
                  dom3-xml-apis-2.5.0.jar;..\..\LiveCycle_ES_SDK\client-libs\thirdparty\jaxen-1.1-
                  beta-9.jar;..\..\LiveCycle_ES_SDK\client-libs\thirdparty\log4j.jar;..\..\LiveCyc
                  le_ES_SDK\client-libs\thirdparty\mail.jar;..\..\LiveCycle_ES_SDK\client-libs\thi
                  rdparty\wsdl4j.jar;..\..\LiveCycle_ES_SDK\client-libs\thirdparty\xalan.jar;..\..
                  \LiveCycle_ES_SDK\client-libs\thirdparty\xbean.jar;

                  ===============================================================================

                  U:\Adobe\LiveCycle8\configurationManager\bin>"javaw" -Xms128m -Xmx512m com.ado
                  be.livecycle.lcm.gui.LCMGUI

                  U:\Adobe\LiveCycle8\configurationManager\bin>

                  ----------------------------------------------------------------------
                  • 6. Re: Custom Workspace UI
                    (James_J_Gallagher) Level 1
                    Ok I have it now.

                    What I was doing wrong was tring to run ConfigurationManager.bat from a Mapped network drive.I went onto the server itself that its installed on and ran the same bat file and it worked.

                    ----------------------------------------------------------------------

                    I have already deployed and started my custom workspace ear file using the application server's administration console but when I try navigate to it, it's not displaying anything for me.

                    Basically what I did was took adobe-workspace-client.ear and made my own custom one, just changing an image (in lc.css) to test it and called it my-customworkspace-client.ear

                    Within my ear I changed the application.xml file:
                    myworkspace

                    So when I try to navigate to:

                    Adobe Version: http://server:9080/workspace/     - This works
                    My Version: http://server:9080/myworkspace/      - This doesn't

                    Hope this makes sense and someone can help!
                    • 7. Re: Custom Workspace UI
                      (James_J_Gallagher) Level 1
                      Finally figured out what I was doing wrong.

                      It the documentation the command it gives to package up the war file is as follows:

                      "-cvf my-customworkspace-client.war METAINF\MANIFEST.MF *."

                      Whats wrong with the above command? Yes, the full stop at the end of the command. I removed this ran through the steps, deployed my ear file and I'm good to go.