3 Replies Latest reply on Oct 30, 2008 9:23 AM by (flexairlr1)

    Localization of Workspace in LC 8.2

    kc@dafolo.dk Level 1
      Hi all,

      I have been trying to localize the workspace to danish (da_DK), and I have followed the guide in the documentation:

      http://help.adobe.com/en_US/livecycle/8.2/customizeworkspaceui.pdf

      However when I copy my newly created ear file to Jboss I keep getting the english locale.

      I have tried to run a debug, but here I get an error which states:

      An internal error occurred during: "Launching debugWS".
      protocol = http host = null

      and under the pane Problems i have the following error:

      Unable to locate specified base class 'lc.core.AuthenticatingApplication' for component class 'Main'.

      Can anyone help me here?

      Thanks in advance

      Sincerely
      Kim
        • 1. Re: Localization of Workspace in LC 8.2
          (flexairlr1)
          When you try your customization out, did you compile it and create a new EAR file ? In 8.2, the development environment setup is different from before.
          • 2. Re: Localization of Workspace in LC 8.2
            kc@dafolo.dk Level 1
            Yes I believe that I did what the documentation describes.

            I setup the environment as described in the documentation and run the build all script, after that I copy the ear file to the deploy library and I can access the workspace, but it is still in english. I am not sure why this happens...

            Can anyone give me a short description of what the minimum procedure of localizing the workspce looks like?

            Thanks in advance

            Sincerely
            Kim
            • 3. Re: Localization of Workspace in LC 8.2
              (flexairlr1) Level 1
              Hi Kim,

              You will need to set up Flex SDK, ant, import the New Workspace ES project, and then modify your build.xml file. You will need the LiveCycle_ES_SDK folder from LiveCycle server (also accessible from Workbench ES after you connect to the LiveCycle server. When you import the new Workspace project (Flex project), it should be pointing to the Flex SDK in the default location. You may need to modify the build.xml file for your environment. When you access your Workspace, are you using the new URL? I'm presuming that your browser settings for locale are set to Danish as well?

              If you want, you can send a ZIP of the project to flexairlr1@gmail.com