3 Replies Latest reply on Mar 1, 2009 11:19 PM by (Songvit_Itthiphisit)

    How to enable SSO on SSL

      I already configured SSO and SSL. <br /><br />I can't auto login to workspace via HTTPS://<server_name:port>/workspace (it has error message on login page "an error occurred while initializing work space"). It can auto login to workspace when I press F5 button.<br /><br />How to fixed this case?
        • 1. Re: How to enable SSO on SSL
          Level 1
          Which Browser are you using? Which version of LC and what is the app. server?

          If you have configured SSL on LC and if you are using IE browser there are known issues - Check out - Configuring SSL for use with Internet Explorer - section of the Administering LC Guide located @
          http://help.adobe.com/en_US/livecycle/8.2/admin_guide.pdf

          Configuring SSO should not be any different because of SSL on LC. Hope this helps.
          • 2. Re: How to enable SSO on SSL
            Level 1
            I using IE7 and LC version is 8.2.1 (JBoss)<br />But admin_guide.pdf is configured SSL IE for WebLogic or Websphare. And I try add this section for weblogic-application.xlm on adobe-livecycle-jboss\META-INF (repackage and redeploy)<br /><br /><session-descriptor><br /><a href=http-proxy-caching-of-cookies>true</http-proxy-caching-of-cookies><br /></session-descriptor><br /><br />2009-03-02 12:18:04,719 INFO  [org.jboss.deployment.EARDeployer] Init J2EE application: file:/C:/Adobe/LiveCycle8.2/jboss/server/all/deploy/adobe-livecycle-jboss.ear<br />2009-03-02 12:18:04,719 ERROR [org.jboss.deployment.MainDeployer] Could not initialise deployment: file:/C:/Adobe/LiveCycle8.2/jboss/server/all/deploy/adobe-livecycle-jboss.ear<br />org.jboss.deployment.DeploymentException: No META-INF/application.xml found<br />     at org.jboss.deployment.EARDeployer.init(EARDeployer.java:118)<br />     at org.jboss.deployment.MainDeployer.init(MainDeployer.java:843)<br />     at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:780)<br />     at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:753)<br />     at sun.reflect.GeneratedMethodAccessor20.invoke(Unknown Source)<br />     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)<br />     at java.lang.reflect.Method.invoke(Method.java:585)<br />     at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:141)<br />     at org.jboss.mx.server.Invocation.dispatch(Invocation.java:80)<br />     at org.jboss.mx.interceptor.AbstractInterceptor.invoke(AbstractInterceptor.java:118)<br />     at org.jboss.mx.server.Invocation.invoke(Invocation.java:74)<br />     at org.jboss.mx.interceptor.ModelMBeanOperationInterceptor.invoke(ModelMBeanOperationInterce ptor.java:127)<br />     at org.jboss.mx.server.Invocation.invoke(Invocation.java:74)<br />     at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:245)<br />     at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:644)<br />     at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:176)<br />     at $Proxy9.deploy(Unknown Source)<br />     at org.jboss.deployment.scanner.URLDeploymentScanner.deploy(URLDeploymentScanner.java:319)<b r />     at org.jboss.deployment.scanner.URLDeploymentScanner.scan(URLDeploymentScanner.java:507)<br />     at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.doScan(AbstractDeplo ymentScanner.java:192)<br />     at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.loop(AbstractDeploym entScanner.java:203)<br />     at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.run(AbstractDeployme ntScanner.java:182)
            • 3. Re: How to enable SSO on SSL
              Level 1
              I configured SSO by SPNEGO.