6 Replies Latest reply on Jan 10, 2008 11:00 AM by (Roland_Lopez)

    Error when submitting any form  (ALC-WKS-007-043)

      I am getting the following error any time I submit a form using the "Complete" button inside the workspace.

      An error occurred submitting the form (task xxx, form {1}). (ALC-WKS-007-043)

      I have restarted the server and still get the same error!

      Any idea?
        • 1. Re: Error when submitting any form  (ALC-WKS-007-043)
          Level 1
          By the way, I am getting this same error on processes that previously worked just fine.
          • 2. Re: Error when submitting any form  (ALC-WKS-007-043)
            Hodmi Level 4
            Do you have access to the server log? There may be more information about what is causing the error in the log.
            • 3. Re: Error when submitting any form  (ALC-WKS-007-043)
              Level 1
              2008-01-08 13:17:14,625 INFO [org.jboss.ejb.plugins.jms.JMSContainerInvoker] Trying to reconnect to JMS provider
              2008-01-08 13:17:14,625 ERROR [org.jboss.ejb.plugins.jms.JMSContainerInvoker] Reconnect failed: JMS provider failure detected:
              javax.naming.NameNotFoundException: XAConnectionFactory
              at org.jboss.ha.jndi.TreeHead.lookup(TreeHead.java:223)
              at org.jboss.ha.jndi.HAJNDI.lookup(HAJNDI.java:134)
              at sun.reflect.GeneratedMethodAccessor247.invoke(Unknown Source)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
              at java.lang.reflect.Method.invoke(Method.java:585)
              at org.jboss.ha.framework.interfaces.HARMIClient.invoke(HARMIClient.java:229)
              at $Proxy275.lookup(Unknown Source)
              at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:610)
              at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:572)
              at javax.naming.InitialContext.lookup(InitialContext.java:351)
              at org.jboss.ejb.plugins.jms.DLQHandler.createService(DLQHandler.java:151)
              at org.jboss.system.ServiceMBeanSupport.jbossInternalCreate(ServiceMBeanSupport.java:245)
              at org.jboss.system.ServiceMBeanSupport.create(ServiceMBeanSupport.java:173)
              at org.jboss.ejb.plugins.jms.JMSContainerInvoker.innerStartDelivery(JMSContainerInvoker.java :605)
              at org.jboss.ejb.plugins.jms.JMSContainerInvoker$ExceptionListenerImpl.run(JMSContainerInvok er.java:1471)
              at java.lang.Thread.run(Thread.java:595)
              2008-01-08 13:17:14,625 INFO [org.jboss.ejb.plugins.jms.JMSContainerInvoker] Trying to reconnect to JMS provider
              2008-01-08 13:17:14,625 INFO [org.jboss.ejb.plugins.jms.JMSContainerInvoker] Trying to reconnect to JMS provider
              2008-01-08 13:17:14,625 ERROR [org.jboss.ejb.plugins.jms.JMSContainerInvoker] Reconnect failed: JMS provider failure detected:
              javax.naming.NameNotFoundException: XAConnectionFactory
              at org.jboss.ha.jndi.TreeHead.lookup(TreeHead.java:223)
              at org.jboss.ha.jndi.HAJNDI.lookup(HAJNDI.java:134)
              at sun.reflect.GeneratedMethodAccessor247.invoke(Unknown Source)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
              at java.lang.reflect.Method.invoke(Method.java:585)
              at org.jboss.ha.framework.interfaces.HARMIClient.invoke(HARMIClient.java:229)
              at $Proxy275.lookup(Unknown Source)
              at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:610)
              at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:572)
              at javax.naming.InitialContext.lookup(InitialContext.java:351)
              at org.jboss.ejb.plugins.jms.DLQHandler.createService(DLQHandler.java:151)
              at org.jboss.system.ServiceMBeanSupport.jbossInternalCreate(ServiceMBeanSupport.java:245)
              at org.jboss.system.ServiceMBeanSupport.create(ServiceMBeanSupport.java:173)
              at org.jboss.ejb.plugins.jms.JMSContainerInvoker.innerStartDelivery(JMSContainerInvoker.java :605)
              at org.jboss.ejb.plugins.jms.JMSContainerInvoker$ExceptionListenerImpl.run(JMSContainerInvok er.java:1471)
              at java.lang.Thread.run(Thread.java:595)
              2008-01-08 13:17:14,625 ERROR [org.jboss.ejb.plugins.jms.JMSContainerInvoker] Reconnect failed: JMS provider failure detected:
              javax.naming.NameNotFoundException: XAConnectionFactory
              at org.jboss.ha.jndi.TreeHead.lookup(TreeHead.java:223)
              at org.jboss.ha.jndi.HAJNDI.lookup(HAJNDI.java:134)
              at sun.reflect.GeneratedMethodAccessor247.invoke(Unknown Source)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
              at java.lang.reflect.Method.invoke(Method.java:585)
              at org.jboss.ha.framework.interfaces.HARMIClient.invoke(HARMIClient.java:229)
              at $Proxy275.lookup(Unknown Source)
              at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:610)
              at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:572)
              at javax.naming.InitialContext.lookup(InitialContext.java:351)
              at org.jboss.ejb.plugins.jms.DLQHandler.createService(DLQHandler.java:151)
              at org.jboss.system.ServiceMBeanSupport.jbossInternalCreate(ServiceMBeanSupport.java:245)
              at org.jboss.system.ServiceMBeanSupport.create(ServiceMBeanSupport.java:173)
              at org.jboss.ejb.plugins.jms.JMSContainerInvoker.innerStartDelivery(JMSContainerInvoker.java :605)
              at org.jboss.ejb.plugins.jms.JMSContainerInvoker$ExceptionListenerImpl.run(JMSContainerInvok er.java:1471)
              at java.lang.Thread.run(Thread.java:595)
              • 4. Re: Error when submitting any form  (ALC-WKS-007-043)
                Hodmi Level 4
                Looks like there is a problem in accessing the JMS.

                Usually this means that there is a problem connecting to the database for one reason or another.

                Assuming that you did a turnkey installation, the first thing to check is that the MySQL service is running.

                If that is okay, check that the C:\Adobe\LiveCycle8\jboss\server\all\deploy\adobe-ds.xml file has the right information.
                • 5. Re: Error when submitting any form  (ALC-WKS-007-043)
                  Level 1
                  Michael, thank you very much for your help! Yes, this is a turnkey setup.

                  I did check the MySQL service and is running fine I can login to the workspace without any problems so I don't think is in the adobe-ds file.

                  I also setup another datasource in the mysql-ds.xml, but using the
                  workspace I created a new process and added a JDBC service, ran the "Test" after adding a query to the service and got results back, so that seems to be working fine too.

                  There was a mssql-ds that I tried to setup with SQL Express 2005 that never worked so I removed it, but the error still showing up.

                  The log gets updated every 5 seconds or so with the same error so whatever it is, is constantly trying to reconnect.

                  any ideas?
                  Thanks again for your help.
                  • 6. Re: Error when submitting any form  (ALC-WKS-007-043)
                    Level 1
                    I've finally solved the problem.

                    I had renamed the DefaultDS in the mysql-ds.xml file. Ignorant to the Fact that by default JBOSS uses that DS and is referenced everywhere!  So if you want to rename that then you have to make the changes on MANY places (see file login-config.xml and all the files inside the Deploy folder). There is a document from Adobe where it explains how to upgrade from LiveCycle 7.x to ES and it explicitly says that there most be a DS with the name of "DefaultDS".  If they mention this anywhere else, I've never seen it though.

                    Anyways now I modified the mysql-ds.xml to include the original DefaultDS jndi and added my owns too.  So my file looks more like this:


                     
                        MySqlDS
                        jdbc:mysql://localhost:3306/myownDb
                        com.mysql.jdbc.Driver
                        myUser
                        myPwd
                        org.jboss.resource.adapter.jdbc.vendor.MySQLExceptionSorter

                       
                       
                           mySQL
                       

                     

                     
                      
                          DefaultDS
                          jdbc:mysql://localhost:3306/adobe
                          com.mysql.jdbc.Driver
                          adobe
                          pwd
                          org.jboss.resource.adapter.jdbc.vendor.MySQLExceptionSorter
                               
                         
                             mySQL
                         

                     



                    I hope this help anyone out there with the same error.