3 Replies Latest reply on Feb 4, 2008 7:23 AM by (jeffrowell)

    Manage Queues doesn't work

      I have a turnkey installation with patch 1b and am attempting to use the Manage Queues facility to share a users ToDo list. According to the documentation the user who has been granted access to the queue will see any tasks that are subsequently assigned - this is, however, not happening. When I logon as the user who has been granted share access I see the To Do list, but it contains no tasks - even though new tasks have been assigned. Can anyone tell me why this would not work as per the documentation?
        • 1. Re: Manage Queues doesn't work
          Level 1
          In your process, select the user service operation, the click the Task Access Control List (ACL) editor, then click "Add ACL for shared Queue". This setting must be selected as a way to add security measures.
          • 2. Re: Manage Queues doesn't work
            Level 1
            I tried this but it still doesn't work. Here's what I did:

            1. I used workbench to select the assignment step where the queue sharing will occur.
            2. I selected the "Task ACLs" tab.
            3. I selected the <default ACL> in the "User List" and then clicked on the "Add ACL for shared Queue".
            4. I then tested by creating another task that gets assigned via this workflow step. I logged in as the user who I've granted access to the queue via the "Manage Queues" facility. Unfortunately I still don't see any tasks in the queue.

            I looked at the documentation available in the help facility and it doesn't make it clear whether I need to do anything else... i.e. do I need to explicitly add each user that I want to have shared access to the "User List" before adding the "ACL for shared queue" to each one - I hope this isn't required - but please clarify.
            • 3. Re: Manage Queues doesn't work
              Level 1
              Sorry, I made a mistake in selecting the user to whome that task is assigned - I actually does work! Thanks for your help.