7 Replies Latest reply on Nov 11, 2004 1:51 AM by (Stephen_Ironmonger)

    Error in test with Central Output Pro Server 5.5

      I am getting the following error,
      when I testing the Central Output Pro Server.

      I begin with a Central Output Pro Server Vers. 5.5 (demonstration version)
      some is the example which I use, I always have the same message in the logs:
      [313]*** Spawn of agent may have failed ***
      [306]Processing file 'exmpl1.dat', '^job exmpl1 "d:\Program Files\Adobe\
      [307]Launching task '"jftrans" "C:\Program Files\Adobe\Central\Server\Data\exmpl1.dat"
      [314]Agent exit message: [313]*** Spawn of agent may have failed ***
      [375]Skipping event because infile A is missing.

      It is probaly a configuration problem? but that to make.
        • 1. Re: Error in test with Central Output Pro Server 5.5
          Level 1
          After I changed the job to print to a defined printer that sample works for me. When I rename the jftrans.exe program it fails just like yours. From that I suspect that the program isn't where Central thinks it is. The first item within double quotes on the line with error # 306 is the program being ran. Check that folder for that program. If it doesn't exist, then that is the problem. Why it would be missing is the next question.

          The transformation agent is an optional part of the installation. Do you know that it was installed?
          • 2. Re: Error in test with Central Output Pro Server 5.5
            Level 1
            I am changing the path just the disk was wrong,
            actualy the new paths are good but the error message is the same.

            >The transformation agent is an optional part of the installation. Do >you know that it was installed?
            No, how to make to check if it is installed.

            Pascal from france

            [313]*** Spawn of agent may have failed ***
            [306]Processing file 'exmpl1.dat', '^job exmpl1 "c:\Program Files\Adobe\Central\Samples\Extrans\tdf\exmpl1.tdf" -afp"c:\Program Files\Adobe\Central\Samples\Extrans\forms"'.
            [307]Launching task '"jftrans" "C:\Program Files\Adobe\Central\Server\Data\exmpl1.dat" "C:\Program Files\Adobe\Central\Server\Data\JfServer.TFA" -asl1 -aii"" "c:\Program Files\Adobe\Central\Samples\Extrans\tdf\exmpl1.tdf" -afp"c:\Program Files\Adobe\Central\Samples\Extrans\forms"'.
            [314]Agent exit message: [313]*** Spawn of agent may have failed ***
            [375]Skipping event because infile A is missing.
            • 3. Re: Error in test with Central Output Pro Server 5.5
              Level 1
              Upon further review, particularly now that you have included all of the text from the log entries, and after comparing them to the ones from my earlier testing, I can tell that I was somewhat wrong in my first response.

              It isn't the 306 log entry that contains the executable name, but the 307 entry. Your log shows "jftrans" is being ran. That is the correct program name but in my log file the complete path to the program is included. The path should be being supplied by Central because it comes from an entry in the jfserver.ini file. The [Paths] section should include several entries, including 'ExePath=c:\xxxxxxx'. Check to see if this section is present.

              The following are the log entries from my successful test:

              >[306]Processing file 'exmpl1.dat', '^job exmpl1 "C:\JetForm\Central\Samples\Extrans\tdf\JFCNTRL.tdf" -afp"C:\JetForm\Central\Samples\Extrans\forms"'.
              [307]Launching task '"c:\jetform\central\Bin\jftrans" C:\JetForm\Central\Server\Data\exmpl1.dat C:\JetForm\Central\Server\Data\JfServer.TFA -asl1 -aiic:\jetform\central\Server\jftrans.ini "C:\JetForm\Central\Samples\Extrans\tdf\exmpl1.tdf" -afp"C:\JetForm\Central\Samples\Extrans\forms"'.
              [500]C:\JetForm\Central\Server\Data\exmpl1.dat successfully transformed as C:\JetForm\Central\Server\Data\JfServer.TFA.
              JFTRANS:
              [307]Launching task '"c:\jetform\central\Bin\jfmerge" exmpl1.mdf "C:\JetForm\Central\Server\Data\JfServer.TFA" -l -apr -allC:\JetForm\Central\Server\jfserver.log -asl1 -amq0 -ams -m1T -z"\\server-name\HQDCS_LX3455_Q1" "C:\JetForm\Central\Samples\Extrans\tdf\exmpl1.tdf" -afp"C:\JetForm\Central\Samples\Extrans\forms" -aiic:\jetform\central\Server\jfmerge.ini -apfon'.
              [289]MDF file `C:\JetForm\Central\Samples\Extrans\forms\exmpl1.mdf' opened.
              c:\jetform\central\Bin\jfmerge: [208]3 surfaces were printed.
              • 4. Re: Error in test with Central Output Pro Server 5.5
                Level 1
                My jfserver.ini was ok ?
                C:\Program Files\Adobe\Central\Server\jfserver.ini
                [Paths]
                ExePath=C:\Program Files\Adobe\Central\Bin
                MSTPath=C:\Program Files\Adobe\Central\Server\Mst
                ControlPath=C:\Program Files\Adobe\Central\Server\Control
                DataPath=C:\Program Files\Adobe\Central\Server\Data
                BackupPath=C:\Program Files\Adobe\Central\Server\Backup
                ErrorPath=C:\Program Files\Adobe\Central\Server\Error
                EtcPath=C:\Program Files\Adobe\Central\Server\Publish

                I also tried to change directly in EDIT TASK menu
                Program name :jftrans
                by
                C:\Program Files\Adobe\Central\Bin\jftrans

                But always error log is wrong ?
                [307]Launching task '"jftrans" "C:\Program Files\Adobe\Central\Server\Data\exmpl1.dat"
                • 5. Re: Error in test with Central Output Pro Server 5.5
                  Level 1
                  I was checking my log file and I noticed an anomoly between some of the "launching" log entries. That got me to looking further into my jfserver.ini file. I think I know what your problem is.

                  Every program (agent) that Central can launch has to have entries in the jfserver.ini file. This includes the agents that come with Central as well as any custom agents that are added later (we have several that we've written for our application). These entries include an EXEPATH statement that is specific to the agent. Apparently this is separate and in addition to the entry in the [Paths] section.

                  For your specific problem look for a section with a [jftrans] header. It may be missing, or it may just be missing the ExePath entry or that entry may be blank.

                  If one is fouled up, look for others. If all options of Central were checked when it was installed you should have entries like the following. These are all in my file as a result of the installation. Of course the actual location would be different.

                  [JFSTARTUP]
                  ExePath=C:\JetForm\Central\Bin
                  IniFileName=C:\JetForm\Central\Server\JFSTARTUP.ini
                  LogFileName=C:\JetForm\Central\Server\jfserver.log
                  EditCfgRtn=notepad %s

                  [JFSHUTDN]
                  ExePath=C:\JetForm\Central\Bin
                  IniFileName=C:\JetForm\Central\Server\JFSHUTDN.ini
                  LogFileName=C:\JetForm\Central\Server\jfserver.log
                  EditCfgRtn=notepad %s

                  [JFERROR]
                  ExePath=C:\JetForm\Central\Bin
                  IniFileName=C:\JetForm\Central\Server\PrtErrorCheck.ini
                  LogFileName=C:\JetForm\Central\Server\jfserver.log
                  EditCfgRtn=notepad %s

                  [DEFAULT]
                  ExePath=c:\jetform\central\Bin
                  IniFileName=c:\jetform\central\Server\jfmerge.ini

                  [JFNOJOB]
                  ExePath=c:\jetform\central\Bin
                  IniFileName=c:\jetform\central\Server\jfnojob.ini

                  [JFEMSEND]
                  ExePath=c:\jetform\central\Bin
                  IniFileName=c:\jetform\central\Server\jfemsend.ini
                  EditCfgRtn=notepad c:\jetform\central\Server\jfemsend.ini

                  [JFMERGE]
                  ExePath=c:\jetform\central\Bin
                  IniFileName=c:\jetform\central\Server\jfmerge.ini

                  [JFPVAGENT]
                  ExePath=c:\jetform\central\Bin
                  IniFileName=c:\jetform\central\Server\jfpvagent.ini
                  EditCfgRtn=Notepad c:\jetform\central\Server\jfpvagent.ini

                  [JFTRANS]
                  ExePath=c:\jetform\central\Bin
                  IniFileName=c:\jetform\central\Server\jftrans.ini
                  EditCfgRtn=notepad c:\jetform\central\Server\jftrans.ini

                  [XMLIMPORT]
                  ExePath=c:\jetform\central\Bin
                  EditCfgRtn=Notepad c:\jetform\central\Bin\xmlimport.xci
                  IniFileName=c:\jetform\central\Bin\xmlimport.xci
                  • 6. Re: Error in test with Central Output Pro Server 5.5
                    Level 1
                    Yes thank you it's the good solution.
                    • 7. Re: Error in test with Central Output Pro Server 5.5
                      I remember when I first installed v5.5, I had to edit the shipped .JMD file. The install path at v5.5 is moved to the progams files folder. In order to cope with the space character in the folder name, I needed to add extra quoation marks on the Task entries in the .JMD file.