4 Replies Latest reply on May 24, 2007 7:11 AM by (Tom_Warfield)

    ADD FILE

      Plaese help me,

      i've insert the file in PREAMBLE / NOT IN DATASTREAM as following:
      (THE DATASTREAM may not be changed, because it is used by many different location)

      PREAMBLE:
      ^file /DATA/SHR/PEAR_01.TXT (UNIX)

      This file contents some fields definded in the template.
      It works local without problems (test without compilation) . The fields of this file appear in OUTPUT.

      The template was compiled and ran in the production environment . On the Output the fields did'nt appears.
      How can i do ?
      Many thanks for your help in advance .
      Soraja
        • 1. Re: ADD FILE
          Is the path to your preamble file appropriate for the production machine?

          Could you put the preamble script in the JFPREAMBLE inside the template?
          • 2. Re: ADD FILE
            Level 1
            Hello Mr. Jeffries,

            yes the path is the same for the production .
            Our main problem, as written, we may not change the datastream , because
            it is used by many countries . Therefore for our location , I've tried
            to modify JFPREAMBLE. I've inserted this statement
            ^file /DATA/SHR/PEAR_01.TXT
            in the JFPREAMBLE
            It worked by test, but not , after complitaion , in the production environment.
            Mnay thanks for your help and hope you have a solution to resolve this
            problem
            • 3. Re: ADD FILE
              Level 1
              I don't have a solution for you but I can suggest some more troubleshooting.

              I would like you to run the test in Designer and then production with a greater verbosity on the log files.

              For the test, in the Designer go to menu item Tools/Options and select the Test Presentment tag. In the Print Options box enter -n0

              Also on the Test Presentment tab be sure that you have an entry in the Log Files for Print, and I suggest that you check the box Empty First. This will give you a new log for only the latest test.

              Select OK and run your test.

              When you review the log file you will see that all the preamble script is listed. Ensure that your ^file text has been included.

              For your test using Central you can add the -n0 to the job statement in the data file (I recommend this) OR add it to the merge task. If the merge task is used by other jobs do not make the change here.

              After running the test review the log file and see if your ^file text was included.

              If it is included then you can compare the log from your test presentment with the log from your Central run to see what happens when this data is processed.

              If it is not included there should be an error message indicating why it couldn't include it.
              • 4. Re: ADD FILE
                Level 1
                Just a note regarding adding parameters like -n0 to the job statement...

                The
                b @OtherJobTokens
                reference needs to be included for the task in question or the parameter on the job statement won't accomplish much.