6 Replies Latest reply on Nov 11, 2008 4:05 PM by Captiv8r

    Can the Show link for Table of Contents be changed in RoboHelp?

    jwhitsett
      Can the text for the Table of Contents link in context-sensitive help topics be modified in RoboHelp? It defaults to "Show." I would like to have our help content author change it to something more meaningful to our Users, like, "Show Table of Contents", but she has not been able to find a way in RoboHelp to do this. I accomplished this by editing whtopic.js in the generated FlashHelp directory, but it seems to me, there *should* be a way to do this through the RoboHelp UI.
        • 1. Re: Can the Show link for Table of Contents be changed in RoboHelp?
          Ben Minson Level 2
          There's a "Show" item in the LNG file (editable through File > Project Settings > Advanced button > LNG file tab). However, I experimented with this when we had a similar question a while back, and editing that text doesn't affect what's in whtopic.js. So that link text is essentially hard coded.

          The problem with editing whtopic.js is the same as you mentioned in the other thread--it's got to be changed each time you generate, or you need to keep it from being overwritten on the server after changing it the first time.

          Having a way to change the "Show" text through the UI would be a good request for the wishing well. Click here for the wish form.

          --Ben
          • 2. Re: Can the Show link for Table of Contents be changed in RoboHelp?
            Peter Grainge Adobe Community Professional
            Ben

            The method you describe should work OK, it does for me. Did you try creating a new output in a new folder.

            JWhitsett

            Try what Ben described. You might have issues having already tried to do it via the back door.

            Both

            It just occurred to me, try the correct way with webhelp. Maybe it is just FlashHelp that is broken. If it is, the bug report should be used but make it clear it is just a FlashHelp issue.

            • 3. Re: Can the Show link for Table of Contents be changed in RoboHelp?
              Ben Minson Level 2
              I just conducted a test with a Spanish project that I generate to FlashHelp. I generated WebHelp, and when I opened one of the topic HTM files, "Mostrar" showed up for the link. However, if I open a topic in my FlashHelp Spanish output, it says "Show." So it looks like it is a FlashHelp bug rather than a feature request. Thanks, Peter.
              • 4. Re: Can the Show link for Table of Contents be changed in RoboHelp?
                jwhitsett Level 1
                Peter, Ben,
                Thanks for the input. I have not found any problems with the backdoor workaround. It seems fine. I will ask our help author to generate WebHelp and see if the problem is there, too. I appreciate all of your prompt replies. :)
                • 5. Re: Can the Show link for Table of Contents be changed in RoboHelp?
                  jwhitsett Level 1
                  So, I had our tech writer copy my tweaked version of whtopic.js into a C:\Program Files\Adobe\RoboHelp 7\...template_stock directory. Now, whenever help is generated we get the modified link, "Show Table of Contents."
                  There are a few template_stock directories, so you need to find the correct one for your project. Regards...
                  • 6. Re: Can the Show link for Table of Contents be changed in RoboHelp?
                    Captiv8r Adobe Community Professional & MVP
                    Hi all

                    Indeed, the LNG file is normally ignored for FlashHelp as Ben intimates. So I would agree that it's a FlashHelp bug.

                    But for WebHelp it should work without quibbling. But here's the thing. Later versions of RoboHelp HTML will create the .LNG file among the list of files when a project is initially created. But that wasn't always the case. If you have a project that began life from an older version of RoboHelp (maybe X5 or older) the .LNG file wasn't present among the files when you first created a project. The file was created programmatically at the time you elected to change something inside it.

                    So lets fast forward from the past to today. Assume you have a project that was initially created using X5 or older and upgraded to 7. The LNG file isn't present. If you attempt to edit via the method Ben mentioned, RoboHelp doesn't quibble. It appears all is well and the dialog closes with no issue. But as there is no file to write to, nothing is created and no LNG file exists. Hence the reason the changes aren't observed.

                    Cheers... Rick