4 Replies Latest reply on Nov 13, 2008 4:48 PM by Newsgroup_User

    2 problems i'm having

    soapbox_justin
      hello all... thanks in advance for any help on the following issues.

      i've just transitioned to working on a new computer and am having a couple problems (mac os 10.5, dreamweaver cs3):

      1) images that are posted live online ( http://www.dicarlofinewine.com/email_campaigns/images/dicarlo_new_e-header.jpg) appear as broken images in the design mode. i have "display external files" checked, and they were appearing fine on my previous cpu... now to no avail. i'm wondering if it's just a setting i'm missing?

      2) trying to preview in firefox (3.0.3) gives me a "file not found" error. here's the path:

      file:///Macintosh%20HD/Users/justin/Documents/soapbox%20in%20progress/080932%20E-mail%20Bl ast/11-13-08.html

      whereas safari (which works correctly) points here:

      file:///Users/justin/Documents/soapbox%20in%20progress/080932%20E-mail%20Blast/11-13-08.ht ml

      i've seen this crop up a few times on these boards, but still can't seem to figure out what settings i'm missing on my end.

      thanks again for any help.
      justin

        • 1. Re: 2 problems i'm having
          Level 7
          Justin,

          > 1) images that are posted live online
          > ( http://www.dicarlofinewine.com/email_campaigns/images/dicarlo_new_e-header.jpg)
          > appear as broken images in the design mode. i have "display external files"
          > checked, and they were appearing fine on my previous cpu... now to no avail.
          > i'm wondering if it's just a setting i'm missing?

          Please post a link to a page.

          > 2) trying to preview in firefox (3.0.3) gives me a "file not found" error.
          > here's the path:
          >
          > file:///Macintosh%20HD/Users/justin/Documents/soapbox%20in%20progress/080932%20E
          > -mail%20Blast/11-13-08.html
          >
          > whereas safari (which works correctly) points here:
          >
          > file:///Users/justin/Documents/soapbox%20in%20progress/080932%20E-mail%20Blast/1
          > 1-13-08.html
          >
          > i've seen this crop up a few times on these boards, but still can't seem to
          > figure out what settings i'm missing on my end.

          These are links to files on your local computer. Please post them online
          and provide us with updated links.

          Randy

          • 2. Re: 2 problems i'm having
            soapbox_justin
            hi randy,
            thanks for responding.

            1) yes the image is hosted live online and for use in an e-mail blast. what i'm referring to is that the files appear in the dreamweaver design window as broken links. when the file is previewed, everything is fine. not sure why it would appear in dreamweaver as broken, as it's just an <img src="blah_blah_blah..."> and previews fine online.

            2) yes... i know they are links on my local computer... that's the problem. i'd like to "preview in browser" (firefox), but the only way i can accomplish that easily, is to drag the document to the firefox icon on the dock. if i attempt to "preview in browser" (firefox) through dw, it sends it to the broken path (file:///Macintosh%20HD/Users/justin/Documents/soapbox%20in%20progress/080932%20E-mail%20 Blast/11-13-08.html). whereas "preview in browser" (safari) sends it to a workable path (file:///Users/justin/Documents/soapbox%20in%20progress/080932%20E-mail%20Blast/11-13-08. html) ***notice the difference... firefox sends it to file:///Macintosh HD/Users... rather than file:///Users...

            not a major problem to preview in safari, but since i prefer firefox, i'd like to try figure out the problem.

            thanks again for any input.
            justin
            • 3. Re: 2 problems i'm having
              Level 7
              justin,

              > 1) yes the image is hosted live online and for use in an e-mail blast. what
              > i'm referring to is that the files appear in the dreamweaver design window as
              > broken links. when the file is previewed, everything is fine. not sure why it
              > would appear in dreamweaver as broken, as it's just an <img
              > src="blah_blah_blah..."> and previews fine online.

              Yes, I realize all of that. I'd like to see the exact markup on an
              actual page to check for things like character encoding of special
              characters in files paths, total number of remote images on your page, etc.

              > 2) yes... i know they are links on my local computer... that's the problem.
              > i'd like to "preview in browser" (firefox), but the only way i can accomplish
              > that easily, is to drag the document to the firefox icon on the dock. if i
              > attempt to "preview in browser" (firefox) through dw, it sends it to the broken
              > path
              > (file:///Macintosh%20HD/Users/justin/Documents/soapbox%20in%20progress/080932%20
              > E-mail%20Blast/11-13-08.html). whereas "preview in browser" (safari) sends it
              > to a workable path
              > (file:///Users/justin/Documents/soapbox%20in%20progress/080932%20E-mail%20Blast/
              > 11-13-08.html) ***notice the difference... firefox sends it to
              > file:///Macintosh HD/Users... rather than file:///Users...
              >
              > not a major problem to preview in safari, but since i prefer firefox, i'd like
              > to try figure out the problem.

              Not all browsers recognize local absolute paths.

              Have you tried using the DW Preview in Browser feature? You may need to
              add Firefox as a browser, but then you can preview either locally or on
              a remote server (if you have on defined). You can setup Firefox as your
              Primary browser and preview using a keyboard shortcut Cmd+F12 (not sure
              on exact Mac shortcut).

              HTH,
              Randy
              • 4. Re: 2 problems i'm having
                Level 7
                soapbox justin posted in macromedia.dreamweaver:

                > hi randy,
                > thanks for responding.
                >
                > 1) yes the image is hosted live online and for use in an e-mail
                > blast.

                For the email links, you should make absolute links to your server. ie:

                <img src=" http://www.example.com/images/blah.png">



                --
                Mark A. Boyd
                Keep-On-Learnin' :)