2 Replies Latest reply on Aug 2, 2006 7:06 AM by Kurt Mossman

    commons-logging Error when starting JRun with Flex

    bal_logicmanager
      Created new JRun Server and deployed Flex2 to this server. Receiving this error when starting up this server instance.

      Starting Macromedia JRun 4.0 (Build 92909), logicerm2 server
      07/13 22:23:28 info JRun Naming Service listening on *:2911
      07/13 22:23:28 warning No sessionSecret has been specified in jrun.xml. Installi
      ng a self generated sessionSecret.
      07/13 22:23:28 info No JDBC data sources have been configured for this server (s
      ee jrun-resources.xml)
      07/13 22:23:28 info JRun Web Server listening on *:8102
      07/13 22:23:28 info Deploying enterprise application "default-ear" from: file:/C
      :/JRun4/servers/logicerm2/default-ear/
      07/13 22:23:28 info Deploying web application "JRun Default Web Application" fro
      m: file:/C:/JRun4/servers/logicerm2/default-ear/
      07/13 22:23:29 info Web Services in default-ear#default-war:
      07/13 22:23:29 info AdminService
      07/13 22:23:29 warning default-war web application has 'reload' as true in jrun-
      web.xml. Consider setting it false if the application is running in production e
      nvironment.
      07/13 22:23:29 warning default-war web application has 'compile' as true in jrun
      -web.xml. Consider setting it false if the application is running in production
      environment.
      07/13 22:23:29 user JSPServlet: init
      07/13 22:23:29 info Deploying web application "Flex Data Services" from: file:/C
      :/JRun4/servers/logicerm2/flex/
      07/13 22:23:29 user JSPServlet: init
      07/13 22:23:29 user FlexMxmlServlet: init
      07/13 22:23:29 INFO Loading configuration file C:\JRun4\servers\logicerm2\flex\W
      EB-INF\flex\flex-webtier-config.xml
      07/13 22:23:30 INFO Loading configuration file C:\JRun4\servers\logicerm2\flex\W
      EB-INF\flex\flex-config.xml
      07/13 22:23:30 user FlexMxmlServlet: Starting Adobe Flex Web Tier Compiler
      07/13 22:23:30 user FlexMxmlServlet: Adobe Flex Web Tier Compiler Build: 143451
      07/13 22:23:30 user MessageBrokerServlet: init
      07/13 22:23:31 user FlexSwfServlet: init
      07/13 22:23:31 user FlexInternalServlet: init
      07/13 22:23:31 info Deploying web application "Flex Admin Web Application" from:
      file:/C:/JRun4/servers/logicerm2/flex-admin/
      07/13 22:23:31 user JSPServlet: init
      07/13 22:23:31 user MessageBrokerServlet: init
      07/13 22:23:31 info Deploying web application "Flex Data Services Samples" from:
      file:/C:/JRun4/servers/logicerm2/samples/
      07/13 22:23:31 user JSPServlet: init
      07/13 22:23:31 user FlexMxmlServlet: init
      07/13 22:23:32 INFO Loading configuration file C:\JRun4\servers\logicerm2\sample
      s\WEB-INF\flex\flex-webtier-config.xml
      07/13 22:23:32 INFO Loading configuration file C:\JRun4\servers\logicerm2\sample
      s\WEB-INF\flex\flex-config.xml
      07/13 22:23:32 user FlexMxmlServlet: Starting Adobe Flex Web Tier Compiler
      07/13 22:23:32 user FlexMxmlServlet: Adobe Flex Web Tier Compiler Build: 143451
      07/13 22:23:32 user MessageBrokerServlet: init
      07/13 22:23:32 error Could not pre-load servlet: MessageBrokerServlet
      [1]org.apache.commons.logging.LogConfigurationException: org.apache.commons.logg
      ing.LogConfigurationException: org.apache.commons.logging.LogConfigurationExcept
      ion: Invalid class loader hierarchy. You have more than one version of 'org.apa
      che.commons.logging.Log' visible, which is not allowed. (Caused by org.apache.co
      mmons.logging.LogConfigurationException: Invalid class loader hierarchy. You ha
      ve more than one version of 'org.apache.commons.logging.Log' visible, which is n
      ot allowed.) (Caused by org.apache.commons.logging.LogConfigurationException: or
      g.apache.commons.logging.LogConfigurationException: Invalid class loader hierarc
      hy. You have more than one version of 'org.apache.commons.logging.Log' visible,
      which is not allowed. (Caused by org.apache.commons.logging.LogConfigurationExc
      eption: Invalid class loader hierarchy. You have more than one version of 'org.
      apache.commons.logging.Log' visible, which is not allowed.))
      at org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactory
      Impl.java:543)
      at org.apache.commons.logging.impl.LogFactoryImpl.getInstance(LogFactory
      Impl.java:235)
      at org.apache.commons.logging.impl.LogFactoryImpl.getInstance(LogFactory
      Impl.java:209)
      at org.apache.commons.logging.LogFactory.getLog(LogFactory.java:351)
      at org.apache.commons.httpclient.params.DefaultHttpParams.<clinit>(Defau
      ltHttpParams.java:53)
      at flex.messaging.services.http.HTTPProxyAdapter.<init>(HTTPProxyAdapter
      .java:111)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

      at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Sou
      rce)
      at java.lang.reflect.Constructor.newInstance(Unknown Source)
      at java.lang.Class.newInstance0(Unknown Source)
      at java.lang.Class.newInstance(Unknown Source)
      at flex.messaging.util.ClassUtil.createDefaultInstance(ClassUtil.java:71
      )
      at flex.messaging.Destination.createAdapter(Destination.java:277)
      at flex.messaging.Destination.initDestination(Destination.java:103)
      at flex.messaging.services.HTTPProxyService.createDestination(HTTPProxyS
      ervice.java:78)
      at flex.messaging.services.AbstractService.createDestinations(AbstractSe
      rvice.java:82)
      at flex.messaging.config.MessagingConfiguration.createServices(Messaging
      Configuration.java:187)
      at flex.messaging.config.MessagingConfiguration.configureBroker(Messagin
      gConfiguration.java:84)
      at flex.messaging.MessageBrokerServlet.init(MessageBrokerServlet.java:10
      5)
      at jrun.servlet.WebApplicationService.loadServlet(WebApplicationService.
      java:1242)
      at jrun.servlet.WebApplicationService.preloadServlets(WebApplicationServ
      ice.java:789)
      at jrun.servlet.WebApplicationService.postStart(WebApplicationService.ja
      va:291)
      at jrun.deployment.DeployerService.initModules(DeployerService.java:711)

      at jrun.deployment.DeployerService.createWatchedDeployment(DeployerServi
      ce.java:242)
      at jrun.deployment.DeployerService.deploy(DeployerService.java:430)
      at jrun.deployment.DeployerService.checkWatchedDirectories(DeployerServi
      ce.java:179)
      at jrun.deployment.DeployerService.run(DeployerService.java:891)
      at jrunx.scheduler.SchedulerService.invokeRunnable(SchedulerService.java
      :223)
      at jrunx.scheduler.ThreadPool$ThreadThrottle.invokeRunnable(ThreadPool.j
      ava:426)
      at jrunx.scheduler.WorkerThread.run(WorkerThread.java:66)
      Caused by: org.apache.commons.logging.LogConfigurationException: org.apache.comm
      ons.logging.LogConfigurationException: Invalid class loader hierarchy. You have
      more than one version of 'org.apache.commons.logging.Log' visible, which is not
      allowed. (Caused by org.apache.commons.logging.LogConfigurationException: Inval
      id class loader hierarchy. You have more than one version of 'org.apache.common
      s.logging.Log' visible, which is not allowed.)
      at org.apache.commons.logging.impl.LogFactoryImpl.getLogConstructor(LogF
      actoryImpl.java:397)
      at org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactory
      Impl.java:529)
      ... 30 more
      Caused by: org.apache.commons.logging.LogConfigurationException: Invalid class l
      oader hierarchy. You have more than one version of 'org.apache.commons.logging.
      Log' visible, which is not allowed.
      at org.apache.commons.logging.impl.LogFactoryImpl.getLogConstructor(LogF
      actoryImpl.java:385)
      ... 31 more
      [0]flex.messaging.config.ConfigurationException: Unable to create service 'flex.
      messaging.services.HTTPProxyService' for 'proxy-service' due to the following er
      ror: org.apache.commons.logging.LogConfigurationException: org.apache.commons.lo
      gging.LogConfigurationException: Invalid class loader hierarchy. You have more
      than one version of 'org.apache.commons.logging.Log' visible, which is not allow
      ed. (Caused by org.apache.commons.logging.LogConfigurationException: Invalid cla
      ss loader hierarchy. You have more than one version of 'org.apache.commons.logg
      ing.Log' visible, which is not allowed.) (Caused by org.apache.commons.logging.L
      ogConfigurationException: org.apache.commons.logging.LogConfigurationException:
      Invalid class loader hierarchy. You have more than one version of 'org.apache.c
      ommons.logging.Log' visible, which is not allowed. (Caused by org.apache.commons
      .logging.LogConfigurationException: Invalid class loader hierarchy. You have mo
      re than one version of 'org.apache.commons.logging.Log' visible, which is not al
      lowed.)).
      at flex.messaging.config.MessagingConfiguration.createServices(Messaging
      Configuration.java:202)
      at flex.messaging.config.MessagingConfiguration.configureBroker(Messagin
      gConfiguration.java:84)
      at flex.messaging.MessageBrokerServlet.init(MessageBrokerServlet.java:10
      5)
      at jrun.servlet.WebApplicationService.loadServlet(WebApplicationService.
      java:1242)
      at jrun.servlet.WebApplicationService.preloadServlets(WebApplicationServ
      ice.java:789)
      at jrun.servlet.WebApplicationService.postStart(WebApplicationService.ja
      va:291)
      at jrun.deployment.DeployerService.initModules(DeployerService.java:711)

      at jrun.deployment.DeployerService.createWatchedDeployment(DeployerServi
      ce.java:242)
      at jrun.deployment.DeployerService.deploy(DeployerService.java:430)
      at jrun.deployment.DeployerService.checkWatchedDirectories(DeployerServi
      ce.java:179)
      at jrun.deployment.DeployerService.run(DeployerService.java:891)
      at jrunx.scheduler.SchedulerS07/13 22:23:33 user FlexSwfServlet: init
      ervice.invokeRunnable(SchedulerService.java:223)
      at jrunx.scheduler.ThreadPool$ThreadThrottle.invokeRunnable(ThreadPool.j
      ava:426)
      at jrunx.scheduler.WorkerThread.run(WorkerThread.java:66)

      PLEASE Help!!!

      Bernie