1 Reply Latest reply on Aug 13, 2008 12:45 PM by (Eric_Bakken)

    SDK FTP plugin fails on 2.0

      Hello -

      The FTP plugin from the SDK fails to upload from 2.0. If I try a SFTP upload, I get this error:

      Cannot upload because Lightroom could not create the destination directory.

      I get this error if there is a subdirectory to create or not. It happens if there is a trailing slash or not.

      If I try a FTP tranfer, passive or enhanced passive, I get this error:

      Unable to upload because Lightroom cannot ascertain if the target destination exists.

      If I hit Browse in the FTP settings it connects properly to the server and gives me directory listings. The same exact settings work fine in 1.4.1. I have upgraded the plugin to the one that comes with the 2.0 SDK. Anyone have any ideas?

      Thanks,
      otto
        • 1. Re: SDK FTP plugin fails on 2.0
          I'm getting this same problem. LR can connect to my ftp through browsing for a destination folder, but gives me the error message,

          Unable to upload because Lightroom cannot ascertain if the target destination exists.

          Tried different directories, tried existing directories, tried non-existing directories to see if it was trying to create a new directory...nothing works.

          Then I tried a different server...that worked.

          THEN...I THINK I GOT IT!

          It seems that the export plugin doesn't like symbolic links. on my shared hosting, I have both a directory in my home called 'www' and "public_html"

          I used public_html instead of www as the full path and the plugin worked.

          so my full path (and I just typed this manually instead of browsing for it) is:

          home/public_html/xxxx/xxxx/

          That seems to work.