10 Replies Latest reply on Feb 18, 2008 1:14 PM by (Tracey_Jenkins)

    My Catalog - "Can't open Database" error

      After being able to open Photoshop Album Starter Edition successfully and without incident several months ago, one day I received this error:

      "Problem opening the Catalog named "My Catalog". Another user or application may have the catalog open, or one or more files may be missing, out of date, or damaged. [Microsoft] [ODBC Microsoft Access 97 Driver] can't open database 'unknown'. It may not be a database that your application recognizes or the file may be corrupt. Attempt to compact and recover this catalog then try again? - OK or Cancel"

      If I choose OK, then I get another error:

      "Catalog Recovery Incomplete - A problem was encountered during catalog recovery. Your catalog may be ok, but if you experience problems with it that can't be resolved through the Reover Catalog option or restarting your computer system you may need to restore this catalog from a backup. - OK"

      That goes to a 3rd error message:

      "Unable to open "My Catalog because it is damaged. Please choose: Open existing or Create a new catalog named My Catalog-1.psa"

      If I choose existing, it goes to the folder where My Catalog is stored, I can click it, and then I receive the first message. If I choose create a new catalog, it does, then gives me the first error message. PSA SE never opens, but the photo downloader appears in my Task bar Notification area, and I can Launch, Enable/Disable or Exit that program. If I try to acquire a photo, I end up with the same first error message.

      I've seen the other threads that address what may be close to this issue, and I've done all the fixes suggested, short of reinstalling WindowsXP, which I'd rather avoid, but I've had no luck - I still get the exact same error messages.

      I am using Office 97, including Access, Word, Excel, etc. but I'm not having any issues with those. I'm also using Pagemaker 7.0 and no issues there related to a catalog or database. I did have at one time a trial copy of Illustrator, and this problem started occurring after that trial was expired. I've since uninstalled Illustrator, done all the fixes suggested here, deleted the My Catalog files, restarted, uninstalled and re-installed PSA SE3.2, and still it cannot 'see' My Catalog.

      Any other suggestions (besides upgrading to Office-this decade, which I would love, but employer hasn't made that leap yet.)? TIA

      Tracey